Flat 2 Connection to CD5xs

I have fitted the link plug to my CD 5xs as i wish to try it minus the Flatcap2
but no sound is forthcoming any ideas?

Just to confirm, it’s the correct paddle link you have fitted?

If so, check which output you have set to “on” depending on whether you’re using the DIN or the RCA Phono output.

1 Like

Yes i have checked the ‘din’ connection is on and the link plug is as shown still no sound
a player issue?

Is the mains power lead fully inserted? Does the logo light up?

Try on another input?

Does the RCA Phono output work?


Tried with just RCA connected have i the correct link plug? 4 or 5 pin?

The link plug should look exactly like the one I posted above. It fits like the image below (a CD5x but the CD5xs link plug arrangement is basically the same);

1 Like

Yep correct link plug still no joy maybe a player issue my biggest gripe about Naim is its no
plug and play as all other makes and it soo delicate to operate grrrr!

1 Like

Are you able to use the spdif out into an external DAC?
And make sure the output select switch at the back us set for spdif.
Or, analogue if using analogue, like you were.
That switch has caught me a few times. Making sure you power down, make the change and power up. You can’t do it live.

1 Like

Nothing from the RCA Phonos?

Does the player read the CD’s table of contents and play? ie. Can you hear the disk spinning?

1 Like

I’ll put my money on the spdif/analogue switch. And the need to power down/ up.

Manual certainly advises powering down if switching from one to the other.

Analogue switch is on still nothing either on DIN or RCA must be a player fault?

Yes all on display

If you haven’t already, turn off, move the switch on the back a few times, leave on analogue and turn on.

1 Like

Assuming the link plug itself is OK and everything works fine when the FC2 is in use then it sounds like the internal power rail that drives the analogue output section of the CD5XS is faulty.

Does the analogue output work if you plug the FC2 back in now ?

if so, It shouldn’t affect the operation of the player, but until it’s fixed, you’ll need to use the FC2 to power this section to get anything out of the analogue outputs.

Works with the FC2 in use just u/s without returned the player twice in the last two years cant keep doing it

That’s good that it works ok with the FC2 back in place. Not good regarding the problems you’ve had though. Did it go back to Naim to be fixed when you had the previous issues ?