Front display appears back to front

Hi there, I am new to streaming but have been fairly happily using a Unitiqute 2 these past two years. I was having some problems with certain types of usb stick not working (usb 3.1 for instance) so i decided to update the software to see if that helped. I did this yesterday using an r232 to usb cable and following the Naim guide. Everything seemed to go very well but then at the end my front display switched so that the text appears back to front. Very weird. Like i am inside the box looking out.

I tried reinstalling the software (i think it’s version 4.3.0) and again no problems with that but the text ended up flowing backwards again.

As far as i can tell it is otherwise fully functional (altho still doesn’t recognise a usb 3.1).

I didnt get any hits when i searched for this issue so it doesnt sound v common but i was wondering if anyone had any suggestions as to how i could remediate.

Thanks
Ben

That is indeed weird. I’d suggest turning it off for a few minutes and then turning it on again. This often fixes odd things. If that fails, try a factory reset. It’s my understanding that the latest firmware is 4.8, which is worth updating to. You may need to go via an intermediate version, Naim’s instructions should cover that.

Worth a read through this post, and the enclosing thread?

4.3 specifically doesn’t recognise some command to reverse the screen output IIUC

Yes this reverse screen issue was addressed in a production/service only release (4.5 I think) and then rolled in to all later firmware releases. Clearly this UQ2 had a new screen at some stage.

You should just update to 4.8 which you can download from the Naim website and it’s fine to go directly to 4.8 from 4.3.

1 Like