Help: UnitiServe-SSD - Can't edit metadata

I’m using my UnitiServe-SSD to rip; music is stored on QNAP NAS.
Unfortunately I cannot change metadata properly, mainly the cover art.

  • On the iOS app (on iPhone and iPad), I am able to select the new cover art on the Web, but it is not being changed.
  • On the Desktop Client, I am able to change it on the Properties Window, but it’s not being changed afterwards.

Does anyone know why this happens ?

Thanks,
MArco :cowboy_hat_face:

@ChrisSU will be your guy. :sunglasses:

I used the n-serve app on ios, find the album and edit, it worked for me. For some reason some cover image from the net was not possible to use, then i tried another one (could be the size of the image, i never found out)

Thanks for the hint.
Let’s see if he shows up. If I’m right, it’s not possible to contact members directly using the forum.
MArco :cowboy_hat_face:

That could be a point for sure, but I tried different images, with no positive result. For me it’s even worse on the n-serve app on iOS than on the Desktop Client, where the picture changes at least temporarily, but cannot be saved.
MArco :cowboy_hat_face:

And you are selecting picture, wait until respons back, and you can then choose “use image”

All part of the dialog, in n-serve, when you select “change image”

Sorry change cover, top-left corner

Hi,
I have used the UnitiServe ssd and Synology for around 10 years and also have the same issue, both via my iPad and the DTC.
I never used to have to be careful of the image size, though that has been suggested to me recently by a fellow member,perhaps I just got lucky.
My attention to this issue has been diverted for the present, to converting my some 5000 cds from WAV to FLAC, which appears to be a very necessary, but lengthy process.

Can’t you just put the picture you want in the album folder name it cover.jpg

I have just made my US converting my 3000 cd / 35000 tracks from wav to flac. Very slow pace (around 1200 a day, took the US 1 month non-stop to convert it all). But it did it, and all are now FLAC, ready to be exported

@ kim.bahlke: That’s exactly what I’m doing. The message “Use image…” appears, first it seem to work and being busy, but then: nothing happens. My files are FLAC.
@ garyi: I will give it a try, thanks.
MArco :cowboy_hat_face:

No you can’t do this because you risk breaking the indexing if you modify the Unitiserve’s own rips other than with Naim editing software. The folder is probably locked anyway.

The folder is not locked and I did try it, but it’s not changing anything.
MArco :cowboy_hat_face:

Likewise, mine is also around 1200 tracks per day though for some unknown reason its stopped counting down.
Now I’ve stopped checking (68,000 tracks in total).

Hi, the max image size the Unitiserve can use is 1280 x 1280 pixels, so if you have selected a larger image it may not load.

The US likes to take its time, so sometimes you just need to be patient. When you rip a CD it takes a little time to write it to the hard drive, especially if this is external, which yours will be, of course, as you have the SSD version.
Also, if you are saving the files in FLAC (which I would recommend) there will be a further delay, as the US rips to WAV, then converts to FLAC. If you have ripped a number of CDs they will be in a queue, converted one track at a time. So I find it’s best not to make any edits soon after ripping. Make sure there is no queue, or the edits will often fail.

I have tried with different images, with no result.
My files are already in FLAC, changed this about two weeks ago.
Queueing should not be a problem either. I have only ripped 10 albums this far, there’s nothing left in the queue.
Does the new firmware change anything to this ?
My US still runs on the 1.7b version.
MArco :cowboy_hat_face:

The 1.7c firmware is basically to delete the defunct AMG lookup, but when Naim came to do the firmware development work it turned out to be more complex that they thought it would be because it was possible for multiple different tasks for the AMG lookup to be queued (and never fulfilled of course).

Ultimately some units started behaving unpredictably. This is basically why Naim haven’t put the firmware on their website. You are supposed to get it from them so they can keep tabs on where they may need to offer additional technical support.

So I suggest that it is well worth putting the new firmware on it and seeing whether that helps your problem. If you need Naim support to help you resolve this issue, they will want you to put it on the latest firmware as a first step anyway.

Best

David

Thanks for this information.
I have sent a mail to the Naim support, hoping they can help me.
MArco :cowboy_hat_face:

I finally found the time to get around the firmware update and do some ripping.
Bur unfortunately, the problem persists. :neutral_face:
Will have to check with Naim again, to see if they have some idea of what’s going wrong.
MArco :cowboy_hat_face:

1 Like