Help with Tidal login inside Naim App

Hi All,

Wondering if anybody else is experiencing issues with Tidal / Naim app login.

I noticed yesterday that I was logged out of Tidal in Naim app. I tried to log back in and I am getting an error message. Same situation with iPad and Android Samsung phone.

Android example below:

Recently I downgraded my Tidal subscription from HiFi Plus to HiFi as I don’t need access to MQA with Naim. So I thought maybe this change in subscription is the issue. However, it all changed fine, even the monthly charges have reduced on my CC.

I tried logging out and in to Tidal on Tidal app and PC app and it all works fine. Qobuz also works fine in the Naim app, I can log out and back in. Streaming Tidal direct from Tidal app into Naim also works fine.

Today I unplugged the router, modem and all Naim gear. Deleted all apps and reloaded and still same issue.

Everything is running the latest software versions.

Any other ideas I haven’t considered? Any help would be appreciated, thanks.

Recently another member changed the credit card and then also had login problems, though a different message (Cannot contact server). I recommended the same things you did. In their case, logging in and out, deleting, and resetting the app did at first not work, but then they reset it once again and it did. It may have been this was a coincidence and something fixed itself elsewhere, I do not know.

1 Like

Thanks @Suedkiez, last night I did a forum search and found the info you are referring to, I tried few resets but no luck, just reset the iPad and still no luck.

Hoping the Naim team (@Richard.Dane and @Naim.Marketing) might have some ideas, I assume the error message comes from Tidal.

iOS error message using iPad


Sorry Timbre, I’m no tech expert on these software-related issues. Have you contacted Naim support about this? Perhaps @Tomvamos has an idea what’s happening here.

1 Like

A pity. I guess it might just as well come from Tidal (as might have the other one about the server) and go away on its own. Good luck!

1 Like

Thanks @Richard.Dane, no not yet, was hoping for something obvious I was missing. I am convinced its a Tidal glitch perhaps connected to my subscription change. Happy to register with support team.

Have you tried changing your password? I believe there may have been issues previously with TIDAL logins featuring unusual characters…

Thanks @Naim.Marketing, no not yet. Its always been ok in past and still works fine when logging into Tidal direct. Was the issue with characters connected to Tidal log in via Naim app or direct Tidal?

From Steve Harris, our Software Director, on another thread:
"I would suggest checking your password for non alpha characters (A-Z, a-z), as Tidal has an inconsistency in their system that they allow new accounts to be created with any characters, but then have strict character limitations else where. eg. changing password to something else.

If in doubt change the password so it’s strictly a-z via their website, login in again via the naim app and see if it works."

1 Like

Tried new PW with only the capital and lower case letters, still no joy. Will register a ticket, but I am not sure if this is Naim or Tidal concern as Tidal login works fine for me using Tidal app etc.

1 Like

Hi @Naim.Marketing , I just tried to raise the ticket but SignUp page is not showing, is this my firewall etc. or is that page down at the moment?

I don’t believe that functionality is enabled yet (it should be hidden; I will let web team know)) - your best bet is or calling between 9-5

Thanks, I have emailed the support team now.

Well looks like its proper broken, of to Naim software department for a more in depth look.

Update in case anybody else experiences this concern in future.

Naim customer services confirmed that even on their devices my login didn’t work in Naim app (I shared my login details for them to test this). However, even for them my login worked when using Tidal app, as it did for me. That confirmed something was wrong with my Tidal account, and integration between Tidal and Naim app.

Case was transferred to Naim software team, they emailed Tidal about my concern. With Naim staff away plan was to get an update on progress / solution next week. However, today out of share curiosity I tried to login once again and I am pleased to say I am all go again on both Apple and Android devices. I can only assume as a result of Naim email to Tidal.

Hopefully, there will be more information to come confirming what the actual concern was, but good news is Tidal is in and I can finally take the Elder Island new release for a spin in CD quality.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.