Innuos Issues

After a few months of faultless operation, my Zen 3 (feeding my NDS via Sense UPnP) now plays all tracks at ~ 110% normal speed! Some might argue this is a positive for a few selected artists, but overall it’s not a great result.

Several reboots / factory resets / app reinstalls haven’t resolved the issue. If I switch to the Naim app via native UPnP, everything plays at the correct tempo.

Waiting to hear back from Innuos support (waiting, waiting…). In the meantime does anyone know if there’s a way to reinstall Innuos firmware on the Zen 3?

Just to reassure you I had the same problem when I had the NDS on loan last month. I was wondering if there was issue with either the NDS or the Zen mini mk3 but looks like to be a software issue.

I hadn’t up dated my innous software since 2.4 it was after the update to 2.6 that the issue of the chipmunks arose. I’m back to using my 272 and there is no issue.

1 Like

Thanks, somewhat relieved to know I’m not the only one singled out for chipmunk treatment.

I’m also getting the same effect running the Zen 3 into my Qute 2, so I’m satisfied it’s not a Naim issue.

Seems to be no way to reinstall either current or previous firmware editions on the Zen, but I guess Innuos have their reasons for that.


Can not test here as I run zenith as server only.
Innous support is really nice - they will definitely help out.

1 Like

Innuos’ reply to my query was to suggest I use Native UPnP instead of Sense UPnP, as the former is ‘the more stable option’.

As several others have noted, Sense UPnP does seem to offer a slight uplift in SQ, but evidently Innuos concede it’s still a work in progress.

FWIW, I think I’ve resolved the chipmunk issue by resetting UPnP player preferences from the LMS server page.

I think the main issue is that Innuos are trying to accommodate a vast range of streamers and sometimes problems occur as a result. I had an issue where I could only play one track at a time via my Linn DSM and they advised using the Linn ap for the timebeing. That was a shame at the time as Sense was clearly superior but fortunately all has been resolved now and I’m back to using Sense.

1 Like

Try changing the sampling RPM from 45prm to 33 RPM…decades ago I made the same error with some 12" EPs.


Fair point, and they’re doing a pretty good job overall.

Unfortunately the chipmunks returned after a brief hiatus. The Zen 3 still works fine playing into a separate DAC via USB, so it’s definitely the UPnP implementation that’s gone wonky.

But given all the positive comments about Innuos support, I’d have expected some attempt from them at troubleshooting. Maybe the next OS update improves things.

I’ve opened up the unit but can’t see a rubber belt… any pointers?

1 Like

Knowing Linn, you need a 50Hz motor pulley instead of a 60Hz one.
When I went to the Geddon, I also had to fork out $$ for a 50Hz motor.