Installing lms-to-upnp Plugin to Roon enable NDS

Hi all,

I am trying to install the LMS plugin to Roonify NDS. There are a couple of topics that have covered this.

I have downloaded the UpnpBridge-1.25.1 zip file and unzipped it. I am struggling with step 4 onwards in the instructions below:-

Where to get it and read about it?

How to Run it?

  1. Ensure LMS compatibility is turned on in the Roon interface
  2. Put the application on a LOCAL disk where you have read/write access
  3. Choose the correct binary for your OS and CPU (choose the “static” version for the least problems)
  4. launch it with “squeeze2upnplms-??? -i config.xml” on the command line, and wait 30s till it exits.
  5. Launch it again just without any flags and hopefully your devices will appear in Roon.
  6. Go and edit the config.xml file if needed.

Appreciate your guidance.


1 Like

Are you running this on an RPi?

What command exactly are you trying to execute? You have to launch the correct version of squeeze2upnplms to match your hardware.


I am trying to install it on my Macbook Pro. I have the Roon core running on it and the aim is to play roon on NDS.

The command I need to execute is step
4. launch it with “squeeze2upnplms-??? -i config.xml” on the command line, and wait 30s till it exits.

Can some someone guide me how to do that? I believe the following file is what I need to ‘launch’.



Here is the screenshot of what I have downloaded and unzipped:-

So you need you need to open a terminal window on your mac.

Navigate your way to the Bin directory where you have unzipped the LMS package

Now try running “squeeze2upnp-osx-multi -i config.xml” and wait 30s till it exits.

If that works carry on with the instructions provided by Weta

Also not sure exactly what the differenece is between the above executable and the “static” version on Mac. I note that Weta recommended using the static version for least problems. So if the above doesn’t work try the static version of the executable by using command…

“squeeze2upnp-osx-multi-static -i config.xml”

Just download and install the roon software for Mac from

I have this on my MacBook Air, originally to trial roon - using the MBA as both Core and endpoint. I now have a dedicated server for roon, and use the MBA as one my many controllers for roon (Win 10 PC, 2 x iPad, 2 x Android phones).

lms-to-upnp is separate software to Roon. The OP is looking for guidance on how to run the lms-to-upnp to allow Roon to work with his NDS.

Thanks all for the replies. T-elmi, yes I have been able to install Roon and it is running OK. As trickydickie points out I am trying to enable NDS to play from Roon.

Still no success. What Terminal command do I use? I got the following:-

I user shown has admin privileges.


I noticed I was not in the Bin directory. Tried again:-

1 Like

Whilst not a Mac person I think you need to add ./ to the front of your command, at least that what you would do in Linux.

This forces it to use the current directory rather than search the path for the program as the directory you want to use won’t have been added to the path.

Thank you. Did that. Still no luck.

Are you logged on to the Mac with “admin” privileges?

Yes I have admin privileges. But just in case I tried to execute the command with ‘sudo’ and it prompted for my password. See screenshot above.

You sure you are in the correct “Bin” directory…you may be in the default Mac bin directory looking at your prompt. If you enter “pwd” it tells you exactly where you are. You should be in a directory that is something like your home path then /UPnPBridge-1.25.1/Bin


I thought about that as well. Tried again, see below:-


just try…

./squeeze2upnp-osx-multi-static -i config.xml

I did. Still no luck:-


That’s very strange, that should have worked…can you do a “ls -al” and post the output please?


Find the results of Ls -al:-