Invisible metadata

A weird one. I just bought the new Bach Goldberg Variations arranged for small orchestra from Linn, in the 192k version.

The files have full metadata - I can see it when hovering over the files on the computer - but if I try to edit using dBpoweramp the files show as having no metadata whatsoever and no album art. If I try to paste something in, there is a message saying it’s not possible.

When transferred to the Nas and played using Asset all metadata and art is present and correct, and the music plays perfectly.

This is the first time it’s happened out of over 4,000 albums. Does anyone know what’s going on.

It’s a wonderful album by the way! I just wonder why I can’t see or change the metadata.

Perhaps you have bought DRMed data? Something like that never occurred to me but I have no experience with Linn downloads. Have you tried editing the metadata with another editor? What’s the file format, by the way?

It’s just flac. I have lots of Linn downloads and it’s never happened before. As it happens the metadata is fine, but I’d like to know why it doesn’t show and cannot be edited.

It sounds like permissions possibly. Try running dbpoweramp as admin. Though its curious that would occur.

I wonder how I do that? I’ve edited literally thousands of albums and never encountered this previously. Never say never of course.

If windows, then right click on the exe or shortcut and choose run as administrator.

How do you know that it is a flac file? Have you tried editing the file with metaflac ( Perhaps it is simply a Linn error and the file is actually not a flac file?

When I hover over it on the laptop, a box comes up showing all the metadata and the file type. That shows flac, so it has to be. I’ve messaged Linn and will see what they say.

If anyone else likes Bach - and this is a brilliant album - they could buy the 192 for £15 and see if they get the same.

I am downloading the album … it’s huge! More soon.

It looks like a dbPoweramp problem. I have downloaded the album and the metadata of the single tracks are perfectly editable with ExFalso:

Can someone try looking for metadata on this album with Mp3Tag ?
It’s my preferred metadata editor for anything other than basic stuff, dBp does that for me.

I would buy the Linn album but I already have it with a different artist (+70 tracks)

This recording is arranged for a chamber orchestra rather than a piano. I heard a bit of it on Radio 3 yesterday and it sounded great.



1 Like

It’s a wonderful album and a real tribute to Trevor Pinnock. I was listening to it yesterday and marvelling at how something can be expanded from a piece for solo harpsichord into a piece for chamber orchestra. I have a string quartet version by Fretwork, which is excellent, but this to me at is at a whole new level. I’m sure Bach would be delighted with it.

Perhaps if you buy the 192 you can see if dBPoweramp works for you. It’s certainly the first time I’ve encountered this problem.

After metadata cleanup and with Work, Period, Form, Genre and Ensemble tags:

All tags were perfectly editable with ExFalso and it was no problem adding my standard tags to all tracks. Now copying the data to the server and to the various backup disks.

Interesting. It may be a thing for the dbpoweramp forum. Do let us know what you think of the album.

I wish I could. Last week I had to shut down the system and move around cables and speakers to allow for the plumbers to replace the valves of the radiators. This was expected to be a routine maintenance work to be completed in a few hours.

We are now left with two broken radiators, a cold living room and no music. At least the speakers, the DAC and the SN2 haven’t been damaged so far!

Oh dear. I do hope it gets sorted out quickly.

Naughty Nigel – encouraging me to spend more money!

Anyway, downloaded 24/192 version and I have no problems editing it with my preferred metadata editor: Metadatics. So perhaps your problems is a dbpoweramp issue.

Not had a chance to listen yet, will report back when I have.


Linn have been looking into it for me. They think it’s because the file names are too long. They have sent me new files with truncated file names and have asked me to check, which I shall do a little latter. They are a little perplexed but are keen to sort it out. Clearly dBPoweramp should handle it. I must say, I’m really impressed with how helpful and responsive they are being.

Just seen this. This is what I’ve experienced with a few albums - particularly if I’ve buried them in a deep directory. I solved the issue by downloading the to a directory further up the tree so the path isn’t so long.