iOS 15 and Naim app

Since updating to IOS 15 on my iPad and iPhone the Naim app has ceased to work - it cannot find Rooms and the ‘press play and then home* instruction simply returns me to the Home Screen on the NDX2 - ie the unit works as normal but it cannot be controlled by the app. I have deleted and reinstalled the app and rebooted the phone and iPad too many times to count. Luckily I mainly use Roon (which still works fine) but it would be nice to still access the app. This has been raised with Naim but no response.

1 Like

A couple of thoughts.

Select Settings in IOS and scroll down until you see the Naim app. Select that and check that it has permission to search the Local Network.

And in Settings, select Privacy and Location Services. Check that the Naim app is allowed to use Location Services.

The Naim app is working fine on my iPad with IOS 15. And also still works with my phone which is still on 14. I don’t have Roon - Maybe Roon related? Frustrating though.

Just to add that my app worked OK after iPadOS 15, no settings were changed & it went straight into business as usual. But I suspect Davids suggestions to check the app has permission to search the Local Network and/or is allowed to use Location Services, is the first place to go.

Also an associated NB = iOS & iPadOS 15.1 is being released today.

To add to the excellent suggestions above, I would suggest power-cycling your NDX2. Unplug it from mains power, leave for 30 minutes then reconnect.

Let us know how that goes!

When you say “power cycling” that does not include a hard re-set? Or merely unplug for 30 min and then plug in and turn on normally?

Yes, just unplug and leave. It’s not a full reset.

1 Like

I did just update with no problems. I checked my settings and they were as prescribed herein. The sound of both Airplay and Qobuz certainly isn’t adversely affected. I’m tempted to say improved on both. But this dang Nova…LOL…it’s so spectacular. I’m sure if I spent $50,000 I’d hear a difference…but good Lord…best money I’ve ever spent.


Many thanks for all these suggestions. The settings were/are not the problem as are as suggested) but after powering the ndx2 off for a while and restarting the Naim app now works on the iPhone - sadly iPad still ‘work in progress’. I suspect the problem resulted from a streamer update and an IOS update overlapping….?

Glad your iPhone is sorted. With the iPad, try deleting the Naim App and reinstalling, to see if that does the trick.

1 Like

Hi, David

A query regarding the Naim app in iOS. I have the Naim app on both an iPad using iPadOS 15.1 and on an iPhone using iOS 15.1. On the iPhone, the Naim app is listed under Settings and I can control its’ access to Location data, Local Network, Siri & Search etc., but on the iPad it does not appear at all as an app under Settings. Any idea why this might be? I should say that the Naim app works perfectly using both iPhone and iPad, so this inconsistency is not causing any issues. It is the latest version 5.22.2 on both. I’m just curious to know why the app appears under Settings on one device but not the other. It was the same under iOS 14 versions also.

1 Like

I’ve just checked and the Naim app is showing in Settings on IPadOS 15.1 on this IPAD (2018).

Mine is the same…Naim appears on the iPhone but not the iPad Pro.

Have just tried the same and it is indeed invisible in Settings on my iPad Pro, but there on IPhone. Will discuss with @tomvamos and team on Monday.

However, Naim App is working fine on the iPad Pro - no usability issues at all.

1 Like

I was wondering what this was all about as the app is working OK.
However I checked & the app is not showing in Settings on my iPad 9.7 (2017) with iPadOS 15.1

My iPad Pro is still on iOS 14.8 but I can see the Naim app under location services.

I wonder whether you only get both setting options on an iPad that uses mobile data (and therefore has a GPS module). My iPad Pro is a WiFi and mobile data version.

You could be onto something there…

Yes, I see it in Location Services also in iPad Storage, but not in the Settings opening screen left side column app list.

Mine has mobile data as well as wifi. Just to check, is this what other people can’t see or am I misunderstanding?


This might be it - my iPad is WiFi only.