iOS vs. Android - Naim app

For those of you who have gotten to have a substantial amount of time with both versions of the Naim app, which did you prefer, Android or iOS? Did you find one to work better, or more stable than the other?

I have been running on Andriod, but going to give it a try on iOS as well.

iOS, no contest, it just seems one step ahead in all areas
I have iPad tablet & Android phone, although it works, I can’t remember the last time I used the phone app

1 Like

It’s been a while since I used the Android app but when I did it worked fine and was essentially the same as the iOS version in virtually all respects.
Having said that, iOS is almost certainly a safer bet as Android runs on a wide variety of different devices which can make consistent performance more difficult to achieve.


Naim app? Meh…

1 Like

@elverdiblanco I tried that one too, but its not working for me, it just keeps playing 1 track over and over. Initially I checked the gapless box and it started playing properly, but I think that was co-incidence as it has started just repeating one track again.

Never had an issue like that. What does the playlist tab show when that’s happening?

Should show all the tracks in the playlist

Yep it shows all the tracks, but just keeps repeating the first one over and over, it won’t go to the next track.

If I just tap on the track Idiot Country that’s all it will play and if you have the repeat icon tapped in the playback screen it will keep looping around. Either tap the Play icon above the track list or tap the three dots on the right and select Play all from here

I don’t have the play button at the top on mine, and when I tap the 3 dots, I don’t have any options to play from there either. So I have been tapping the track to start play, however, I did check that the repeat track function is not selected, and even when its not, it still repeats that track over and over.

Really? What version of the app are you on?

I guess I should have confirmed that this is the app I think it is, BubbleUPnP right? and I have the latest version, just downloaded it the other day.

I just started a new playlist on it and now its not repeating … so no clue if it is something I am doing, or the app is just botched that sometimes it repeats and sometimes it doesn’t.

I have had both for a couple of years now. The IOS version is much better, I reluctantly bought an Ipad because I was so dissatisfied with the Android version which I found really slow and buggy on my Pixel phone. The Ipad only gets used as a remote for my naim gear, occasional games of scrabble and to read the Waitrose food magazine.

1 Like

@paulbysea I really don’t wanna give up my S7+ as going back to an iPad would suck, even the iPad pro doesn’t compare screen wise. But I am finding the iOS app version faster so far. Also, mine has been very unstable on Android.

Yes it is Bubble UPnP app. Do you have Bubble UPnP server running anywhere to create an OpenHome version of the streamer?

You can see from that I’ve used the Bubble UPnP server to create OpenHome versions of both the ND5 XS2 and my Sonos speakers so they can all be controlled from the Bubble UPnP app

I did have it set up on my main PC, but have since deleted it and am only using the app itself now. Interesting you have those play options, I wonder if that is because I am on a Tablet version as opposed to phone.

No, same on a tablet. I think if you don’t have those play options there’s something very wrong. You got the app from the Play Store rather than an apk from apkmirror or suchlike? I’d think about emailing the developer if you’re not seeing any play options, he’s usually fairly good at responding. Also try putting the server back on your PC and see if that helps and make sure you use the OpenHome version of the renderer.

1 Like

strange. Mine looks like this. Yep, got it from the google play store.

I have no issues with the stability of the app, but the Android app is behind in features. Now playing widgets, Rovi, in-app help.


Nearly 5000 tracks in the playlist? Maybe that’s the problem?

No Rovi is a pretty substantial feature missing on Android. Otherwise I agree, though it can be confusing to be told to look in the in-app help but it’s not there on Android.