Mu-so 1st Gen becomes inaccessible

For years now, I’ve been living with my Mu-so becoming inaccessible almost every time I use it, usually after an hour or so, but can be pretty random. Sometimes it will continue on a playlist but will accept no input. It is Ethernet connected to my router. It happens via Naim app or Roon app. Occasionally, when trying to reconnect, I’ll get the error “someone else is connected to the device”, which is impossible in my household. If I turn it off then on, and try to re-connect, it usually fails. If I reset via pinhole, I can usually re-establish contact, but what a hassle. Suggestions?

Are you saying accessing it via the Naim app is inaccessible, or accessing music?

If the former, what are you using to connect to the Naim app (iPhone, android, Mac, PC, etc).

Probably more question after your response

1 Like

Have you tried connecting it via WiFi instead of Ethernet?

1 Like

Have you tried replacing your router? My MuSo (1st Gen) always works (connected via Wi-Fi) using Nether Orbi MESH system. Is your router firmware up to date? Have you more than one device (router or extender) on you network that issues IP address, as this can cause double NAT.

1 Like

Depending on your router and your mobile device (iPhone or Android?) some routers can cause issues which defy logic.
My old Telstra (Australia) router was solid. Telstra sent me a newer version of router which constantly dropped devices off my network.
My IT guy has recently installed a new “Araknis” router and my devices (including QB1’s) are solid again.

1 Like

Both. The usual pattern of behavior is that I launch the device via Naim app, play music for an hour or so, usually Tidal playlists, then at some point the app no longer responds to input but continues to play through the list for a bit until it quits and is no longer visible in the “room”, but remains on.

It was connected via WiFi and the problem was even more prevalent, so I wired it directly. I’d say the frequency of the problem was halved after the change.

It is wired directly to an Orbi router. However, there are two satellites in the mesh as well. Router firmware is up to date. Something to mention, the Orbi is connected to a (very cheap and very old) AT&T router that has it’s WiFi capability turned off.

Mobile device is an iPhone. I should also mention that I have two G1 Naim Cubes on the same network, as well as a G1 Naim Unity Atom that do not exhibit similar problems?

1 Like

Turning Wi-Fi off in the other router still means it is handing out IP addresses via DHCP. If the Orbi router is also set in router mode then it will also be trying to hand out IP addresses, which leads to double NAT (network address translation). Ideally remove the AT&T router or set it to modem mode. If not possible then you need to configure the Orbi to access point mode and not router mode.

1 Like

Yes probably double dhcp conflicts; good guess from your earlier post!

1 Like

Just to backup the last two comments, you need to make sure only one of the main devices is using DHCP, and that is typically the main Router that comes from your ISP. Therefore you need to ensure that the Orbi is in “AP Mode”, as shown below (this is what I have)


Once done, you are best disconnecting the power of your Naim devices for 5 mins, and restart your phone

1 Like

Probably not helpfull, but in the absense of better advice.
Try to fix the address assigned by the router. Usually you can find a list of connected device in the router firmware and tell the router always to give the same address to the qb. Sometimes this helps and you do not have to use manually assigned ip addresses just force the router always to use the same address when it restarts or after the time when it renews ip addresses.
Another thing to look out for that plagued me for some time with my current router. This router has a firewall in the router itself. Even with that firewall set to minimal or low it would make the qb unavailable after a few hours mening I had to power down and power up every morning, really anoying before the first cup of coffee!
Why this firewall attacked the qb discovery I did not really try to understand after turning it off completely.

1 Like

Thanks! I’ll give that a shot.

Fantastic! Thanks!

Apologies. No disrespect intended. Indeed, great responses from all and I’m appreciative. Been super sidelined with lots of other stuff lately and forgot to check back!

Thanks Claus!

Just to update, I did go to Orbi advanced tab. The router was already set to AP, but by exploring some of the diagnostics, I discovered one of the satellites was misbehaving and was able to fix it, so it was worth the visit. I reset the Orbi router and the AT&T router and re-synced the satellites. I’ve been testing for the last couple of weeks and have not had a failure. Can’t say it’s fixed for good, but the devices are playing nice together for the time being and appreciate the forum for helping.


Also worth checking for any firmware updates for your Orbi. I just updated my RBR750 and RBS750 following an update yesterday. Improves reliability of the satellites. See RBR750 / RBS750 Firmware Version - NETGEAR Support