Mu So 1st gen, dropping out

My Mu So has worked pretty reliably for a couple of years but however recently I’m plagued by it suddenly losing connection.

It is wired directly to my router and I stream music from my iPhone via Airplay 2/Apple Music. I don’t have any other speakers on my network.

The Mu So disappears from Rooms on the Naim app. Sometimes switching wi-fi on and off solves this, sometimes restarting my phone, other times restarting the Mu So itself (which takes an age) or the router.

But it’s becoming a very regular occurrence, it’s happened four times today and I’ve restarted everything and still no music. At the moment the Mu So is dead. Becoming REALLY ANNOYING!

My home network hasn’t changed recently, I’ve not added any new devices. All the software is up to date.

Before I put it on eBay and buy a Sonos, does anyone have any suggestions?!

Hi, it sounds like there could be a fault somewhere in the broadband network outside with Openreach or your broadband supplier. Have you had your line tested?

Reboot everything starting with router, give each item you reboot 5 mins or so to settle down.

Funny there have been a few network threads recently and all have iPhones…

I’ve not had it tested but no other devices seem to loose connection.

I’ve rebooted everything again and it’s now working, but it’s becoming very tiresome having to go through this procedure every time I use the Mu So.

It’s not working but rebooting every device every evening is very tiresome.

Interesting… it does feels like communication problem between the phone and unit to me.

How strong is your wifi connection with your phone? I’ve been told in the past that if it gets marginal you may get issues. Also make sure you don’t have other networks as connection options. Otherwise, get in touch with Naim tech support. Details on the website.

Problem solved, although the Mu So is wired to my router, when I switch off a WiFi extender I have plugged-in upstairs, the dropping issues stop.

Sounds like I may have to purchase a mesh WiFi system to prevent this?

Incidentally I can’t get access to to look at the Mu So settings. I’ve tried disabling my MacBook’s firewall but still no joy.

I bought a Google Mesh system but this has made the situation worse.

Each time I want to use the Mu So I have to go through 20 minutes of rebooting, finding Rooms, setting-up the Mu So from scratch – in order to get it to work.

If you connect the muso to the router using ethernet cable, it will just work always. The first gen WiFi is just not very good.



If the wifi is strong though - and I assume that the Mesh system ensures it is strong and has good coverage - connecting via wifi on the Mu-So should be fine. I have certainly used original Mu-Sos wirelessly without many issues in a number of locations. My question here though is how a Mesh system can make things worse. Could it be a configuration issue? How close is the Mu-So to the mesh unit?

Richard is right. The muso gen 1 can work well with wifi, indeed mine does. But I have a vague memory that google mesh WiFi, unlike most of the main mesh systems available, isn’t good with Naim discovery (but I may be misremembering). In any case if it works with ethernet then that is helpful diagnostics.


Is your router still running a DHCP server as well as the Google mesh? You need to run only one, and I believe it’s not possible to disable it on the Google devices, so you may need to look at your router config.

Afraid the Mu So has been connected directly to the router all along, initially to the Vodafone one, now to the Google Mesh unit. With the latter, with either the flashing purple or white light, the Naim app refuses to recognize it.

I’ve emailed support, hoping they can help.

The Mesh base unit is 30cm away from the Mu So, wired via cable.

I’ll try setting it up without the cable later today.

It is definitely worse. Connected to the Vodafone router, it took less restarting and whatnot to regain a connection. With the Google Mesh even setting it from scratch is very hit and miss, takes several attempts.

Sadly I have no idea what you’re talking about!

I’ve emailed support, hoping they can help.

It’s important to remember that even when a device is hard wired by ethernet cable, your controlling device (iPhone, iPad, Android device etc.) is still connected via wifi, so strong wifi is still very much required.

What Chris is referring to is that your Google Mesh base is also a router. If you still have your original router in place then it isn’t going to all work properly. You need to disable the old router so that it just acts as a modem. Then your Google system can act as the router as well as the WiFi source.

Otherwise, as Richard is implying, your phone and muso may well end up on separate sub-nets and unable to see each other.



1 Like

Thanks Richard.

I’ve tried setting it up without the Ethernet cable but the problem is the same.

The wifi connection is strong throughout the house (I would definitely recommend Google Mesh!).

Thanks for taking the time to reply.

I understand that may be a problem – the Vodafone router doesn’t have a bridge mode so I would need to replace it with a modem. I’ve already spent £200 on the Google Mesh so I’m a little reluctant to spend another £70 on a modem.

And this problem predates the purchase of the Google Mesh.

OK, so do try to make sure that any other wifi network is disabled (you should be able to do this in the router setup menu) and that the devices are not trying to connect to another network.

Otherwise, have you been in contact with Naim tech support?