Muso 1st Gen & Minimserver

Hi All
Does minimserver 0.8 or minimserver 2 work on muso 1.

What i have
Windows 10 laptop

music stored on 1TB Maxtor usb drive

Files are a mixture of FLAC (ripped by dbpoweramp) and mp3 files bought from emusic back in the day. (also whilst i was ripping cd i made copy to Apple lossless as well in a different folder)
D:\Lossless (FLAC files)
D:\mp3 (mp3 files)
D:\Apple Lossless

Asset uPnP running on laptop

Ipad Air running Naim App

What I can see
When i open Naim app in upnp i can see the Asset server
and DLNA server built into the Panasonic DVD player / HD

What I have tried
downloaded and installed Minimserver onto laptop and i get a green minim in the tray. Pointed properties to the lossless and mp3 folders.

uninstalled minim 0.8

downloaded and installed minimserver 2.0.12 on to laptop pointed properties to lossless and mp3 folders.

BUT neither minimserver ist showing on the ipad naim app - i have tried closing the app, rebooting the ipad.

I’m fairly computer literate but find the minimserver website confusing / unhelpful.

Am i missing something?

or do i just say to heck with minimserver and stick to Asset and spend the time sorting the tagging of the old mp3’s

Thanks in anticipation

What’s the problem with the tagging?

But, did you turn off/shut down AssetUPNP while running Minimserver? Likely the muso was confused as you were running two similar servers from the same ip address. Easy to test.

Mimimserver runs fine on Win 10 with a Muso 1 from my first hand experience.

There is no consistency in what info is stored in which tag …

3 examples:
Album Artist Academy of St-Martin-in-the-Fields & Iona Brown
Album The Four Seasons
Artist Iona Brown
this one has missing composer on several tracks

Album Artist Academy of St Martin in the Fields under Neville Marriner
Album Music for the Royal Fireworks, Water Music
Artist Academy of St Martin in the Fields under Neville Marriner

Album Artist Barry Wordsworth
Album Saint Saens: Carnival of the Animals, Bizet Jeux d’enfants
Artist Barry Wordsworth
so no mention of Ravels Mother Goose or the London Symphony Orchestra

and so it goes on
however Popular music follows the usual Artist / Album / Album Artist data

yes even uninstalled Asset just in case.

I’ve never come across a problem running more than one UPnP server before, even on the same hardware, so I don’t think this should be a problem (although I’ve never run them on Windows).
If you don’t get anywhere, try posting on the Minimserver forum, the developer is usually very helpful.

Have you seen a Java warning when staring Minum for the first time? Asking you to allow it? Something to look at. Haven’t used minim for a year, now use Asset on Rpi. Minum should be straight forward and work fine. Something’s missing.

when first installed minim 0.8 did get a cant run this rar so associate with a program.
Realised didn’t have java installed on laptop so downloaded javasetup8u251 and installed it
minim showing it is running.

still waiting for a forum activation email (3 hours) even requested a repeat notification.

Well I just downloaded Minimserver for Windows 10 ( Installed quickly and is up and running.
I see it immediately from the Naim app connected to Muso. See pic, Asset is from my Rpi, minim running on Win 10 laptop. I did get the windows firewall warning asking to allow minim which I did. Check that.

Thanks will keep playing with it.
Really want to get it to work because I’ve seen a tagging scheme based on Minimserver which I like.

I’m guessing it’s your win firewall blocking it or java setup.

Rar? Are you sure you have the proper version? Should be If you have java installed and get the proper Minim version, and allow it in windows firewall when asked on first start up.
Minimserver will not be viewable until it has first completed scanning your music folder as well.

It was the java rare not Minimserver. I do have and it is running on laptop.

Do you know what it is called in the Windows Defender Firewall list of allowed apps as I can’t see anything called Minimserver
Guess that may be the problem

Uninstall Minim, reinstall, start it up and wait for Windows defender to ask to allow it. If it does not ask (normally it should), I guess a google search to find how to add app to Win Defender (firewall).

May not be relevant in your situation but Minimserver doesn’t deal with artists beginning with The. AssetUPnP does.

And… I’m in and showing on App

Found this in the minimserver installation guise for windows buried at point 11 of 12.

If MinimServer appears to be running but you can’t see it from other computers or control points on the network, you might need to update your Windows firewall settings. In the list of inbound rules, there should be entries to allow TCP and UDP access for Java™ Platform SE binary

Needed to be in Windows Defender and Firewall with Advanced Security.

Thanks all


Thanks think all my artists with The are listed as Alarm, The, Who, The

Haven’t tried The The yet :grinning:

1 Like

On what way does MinimServer not work for artists beginning with “The”? It works fine for me.

So it appears that Windows defender message popups might be suppressed on your particular machine. When I install a new server type app that wants network access, I get a popup asking for permission to allow it.