Muso regularly disappearing from Naim App

Hi All,

Hope someone can help with some frustrating network issues I’m experiencing with a Muso 2nd gen I recently purchased for the bedroom.

I try to explain my setup first. I have Fibre to the House, the router is an Eero 6 given by the broadband provider linked to an Openreach modem, in the lounge on the ground floor of the house.

I also have a Nova wired to the router via a network switch.

In the bedroom on the 1st floor I first attempted to connect the Muso wirelessly to the Eeros (I have 1 more in the room next to the bedroom where my NAS is), but the music would drop constantly, so I used an old TP Link wifi extender, connected to the Eero wirelessly but using its Ethernet port to connect to the Muso.

Things seemed OK at first, it would play fine, sync with the Nova when needed (with the occasional drop) but after a few days the Naim App could no longer find the Muso and it constantly searches for it without success (see screenshot sample).

The only solution is to unplug the Muso, plug it back in and re-add it to the app, but then after a few days it would do the same again! I have also tried to reboot the routers.
It’s annoying, I can’t do this on a regular basis.

I can cast via chromecast with no issues, I can see it in Google Home, Plex and other audio apps see it, so the problem only appear to exist within the Naim network environment.

Now I know that the fact that Eeros are limited with tampering, ie manually assigning channels etc, could be a problem, but has anyone else had similar issues and how were they resolved? I don’t want to change the routers with something else.

Thanks for reading.

This is the source of your problem. Does your ISP supply mesh WiFi systems as these will be much better.

Yes the two Eero 6, they are a mesh system but as I mentioned I tried to connect the Muso to them wirelessly first but the audio kept dropping out, so I opted for the extender instead.

With a mesh system you simply connect to your single wireless network yet you say connect to ‘them’. :thinking:

I can see that Eero 6 support DHCP, you only need one DHCP server on your network. Assuming that the ISP router is then providing DHCP is the mesh DHCP turned off?

DHCP is turned on. When I say ‘connect to them’ I meant that the mesh system automatically connects the Muso to one of the two routers. It has been connected to the main one downstairs for the past few weeks and yet the Muso is now not found on the app, or rather as the picture shows, it keeps trying to find it.

Based on your environment description It sounds like you have the following:

Openreach ONT → Eero 6 Router → Ethernet Switch

Additionally you have an Eero extender on the 1st Floor and from that a wired Ethernet connection to another TP Link WiFi extender

It sounds like the root cause may well be the TP Link device. Whilst the Eero devices are interoperating to provide a mesh for backhaul between Eero’s as well as extended reach for host connections, your TP Link device is acting in isolation from the Eero devices whilst still utilising the same WiFi spectrum and working against the Eero devices as it requests air time and spectrum allocation.
Your Muso host device is having to make frequent decisions on who to connect to and is probably dropping and reconnecting between AP’s in doing so, the effect of which would be audio drop outs as the Muso playback buffer clears and control app disconnects.

You also need to ensure that you only have one device on your network (should be the Eero router connected to your ONT) acting as a router and acting as a DHCP Server for allocation of host IP addresses otherwise, again, you’ll have a resource contention.

Likely the simplest solution would be to add another Eero extender that is in the same room as the Muso, this way it will act as a bridge to the other Eero’s in your home and importantly interoperate correctly with the other WiFi Access points and the Eero acting as the router.

The TP Link extender is not wired to the Eero, it is connected wirelessly to the Eero mesh, the Muso is wired to the TP Link.
I tried to exclude the TP Link extender and connect the Muso wirelessly to the Eero but then I get the audio dropouts.
The Eero on the ground floor is the Gateway router.

Do you use Tidal Connect via Tidal app? It sometimes causes the Muso to “disappear” from app until restart.

Thanks for correction, I’d still suggest adding an additional Eero extender will be preferable than having the TP Link device in the chain. Does the Eero companion application give you any data on connection quality or spectrum utilisation out of interest?
I see no harm in making the mesh more robust using only Eero devices. The Eero app may also provide you location guidance for where to site the AP’s, ideally have them higher up in the room, above head height if possible, that tends to give the signal fewer obstacles to deal with in a typical home.
As with any mesh capable WiFi system, the hidden backhaul radio between the devices and how stable that connection is will have a marked effect on how well the clients perform even if their connection to the nearest Eero appears ok and stable.
You’ll find any WiFi mesh system will have an optimal density determined to an extent by the environment of operation and materials obstacles between devices. The Eero app may well have settings that can help to determine optimal placement as mentioned earlier, unfortunately I don’t have personal experience of Eero devices.

No, I only stream from my NAS.

The Eero app shows a strong connection to the Muso (via the TP Link extender), and as I said earlier the Muso is seen by Plex and other apps that use Chromecast, I can stream audio from those apps without any issue, it’s just the Naim environment that has issues with my network set up.
I’ll try to remove the TP Link and connect to the Eero via WIFI again and see if I still get the audio drop outs.

That doesn’t quite answer the question. You have a fibre modem, some Eero Mesh devices and a TPlink extender of some sort.
Which of these devices also includes a DHCP server, and which of them have it enabled?
Have you ensured that only one device has its DHCP server running. If more than one is active it will cause problems.

DHCP is set to ‘automatic’ in the Eero’s network settings and assigns the IP number to the various devices in the network (the other settings are Manual IP and Bridge mode).
DHCP is also enabled in the Naim’s web configuration.
I’m not sure about the Fibre modem, I thought that the IP number sequencing and assignment is determined by the Eero Gateway alone. I’m probably still not answering the question :slight_smile:

You fibre modem is also likely to be a DHCP server as well unless you have disabled it.

The link between the Muso and the Eero is probably fine, the hidden backhaul WiFi connection might not be so good however.
If you were getting audio drop outs that’s a good indication the mesh isn’t optimised as much as perhaps it could be, adding more Eero extenders will fill in any coverage holes and importantly ensure a sufficient backhaul link.
With only a single Eero extender it won’t matter but if you choose to add a 3rd or 4th ensure it can support daisychain backhaul such that an extender can act as a backhaul bridge for those Eero extenders further away from the Eero wired router. It may be by default that all extenders will prefer to backhaul directly to the wired Eero router, worth checking if you go that route anyway.
The TP Link extender may well be creating additional interference and channel congestion that may impact the performance of the backhaul on your Eero extenders as well, they’re both juggling the same resources and they are limited to begin with regardless.
Hope you find a working solution, raise a hand if needed!

It’s a fibre ONT, it’s a simple optical to electrical bridge device.

1 Like

People tend to use router/modem interchangeably sometimes. :slightly_smiling_face:

It’s a alphabet spaghetti most of the time!

1 Like

I was thinking the same regarding the backhaul.

One mistake people can make with mesh systems is placing the units too far apart, being mistaken that having the units close to the devices that connect to them is the best option.

Sometimes moving a mesh unit a little further away from the device that connects to it and closer to the ‘master’ can improve matters. It’s a matter of trial and error.

I think I have identified the issue but still can’t fix it.
I have completely removed the TPlink extender and connected the muso to the mesh system via WiFi.
The audio drop outs started again…
Within the eero app I disabled the 5ghz band and it now seems to work fine, no drop outs BUT unfortunately it’s only a trouble shooting feature that lasts for 10 minutes, after that the mesh automatically renonnects the muso to the 5ghz band and the drop outs start again!
I don’t think it’s possible to select bands invidually and therefore to keep the muso on 2.4ghz. What next?