N272 wifi connecting issues

Hi folks, my N272 streamer is no longer connecting to wifi in my home; whilst my uniti core and muso connect without any issues: has anyone come across this issue with their N272?

My 272 sometimes vanishes from the app but the uniticore and muso stay on. I power down the 272 and then it appears again.

@rdmotti it could be time to try and hard wire the streamer to the router. The 272 wasn’t brilliant on WiFi and in the end I found it too annoying to live with and installed a slim network cable. I think you will always be chasing problems if you try and stick with WiFi only.

1 Like


Many thanks for your reply. My N272 is connected via a network cable to a Bonn N8 Gigabit Ethernet Switch. Only use WiFi when using the Naim App for selecting various components. It’s really strange that up until recently was able to connect the 272 with the Naim App, although, like you, it would disappear from the App on occasion. Wondering maybe if there’s a possible malfunction with the 272 connectivity? The Uniticore and Muso on the other hand connect no problem.

If you are using an iOS control point for the app, any apple device can be connected to your switch via an ethernet adaptor and a patch cable. If the app then works, you will have identified the cause.

If your 272 isn’t visible in the app, but can access internet radio etc., then try accessing the device website in your browser

http://192.168.1.x (or whatever your 272 IP is)

Then reopen app.

I had a wire shark capture somewhere of our 272 failing to respond to broadcast discovery traffic, but after an HTTP session it magically responded. Probably some obscure bug in firmware or network stack.

Didn’t pursue this with naim support as we sold our 272.

Many thanks for your suggestion; yes did access the 272 via the website whereby it worked for a while. Tried the same again and now prompted that this IP address has already been added. Still not visible on the Naim app…very bizarre!

Have exactly the same problem. After reboot N272, it becomes visible again in the app but is not viable long term. Disappears after some days for unknown reason. Muso no problem on the same wifi network.
Set up anew is impossible as it asks to press play on the front panel then home button on the remote but home button on the remote does not exist. Incidentally, this connection problem appeared exactly when the new Naim Focal app was introduced.

It happens every now and then here also, even though 272 is wired to the wifi network. A bit annoying at first but just restart it and it works again. (For me anyway)

It’s actually well known here that the legacy streamers have terrible WiFi performance. That’s not just an opinion, it’s a fact. The first Gen musos are better and the second Gen musos and the new Unitis and NDX2 are better still, but if you can make a legacy streamer work well on WiFi, then you are doing unusually well.

Oh, well noted. May be some advice from experience on how best to make 272 work (on Wifi)?

Basically it doesn’t work well, even with the 272 right next to your router.

You really need to get an Ethernet cable between your router (or a switch on your network) and the 272 and all will be fine.

One option might be mesh wifi. Locate one of the mesh boxes next to the 272 and connect them with ethernet. You’d need to ensure a good solid connection between the mesh box and the router.

Yes that could work, as it’s not using the WiFi circuits in the 272 at all.

If your router is set to dynamic channel selection, it will be changing WiFi channel without you knowing.

It could be that the 272 works well on some channels and not so well on others.

My router is set to manual channel selection, but it ignores this setting and changes channel from time to time. I set mine to 11, last time I checked it was on channel 1, it is now on channel 6.

I do have an Ethernet cabled connection.

Ok so why are you worrying about WiFi for 272 then? It’s generally regarded as fine on Ethernet.

272 does not appear in the Naim app so I can not take control of it.

I suspect the confusion has arisen because you added your issue to someone else’s thread. What you have is a discovery issue, where the app cannot find the streamer.

You need to make sure that the streamer and app are on the same network. Things can go wrong if you have the broadband supplier’s router, and then another of your own. Only one should supply the wifi and give out the DHCP allocations. That may not apply to you, but it’s worth being sure.

You can tell the app to find things by pulling down the rooms screen.

If you can’t resolve it, I would get in touch with Naim support. These things can be very frustrating.