Naim app failing to find ND5XS2

I’ve been a happy ND5XS2 owner for 10 days until this weekend. My router was re-started and that seems to be when the problems started. Since then, the Naim app on my Android devices have real trouble finding the streamer. My network is fairly simple, the streamer is connected via wifi and it is in the same room as the router with a direct line of sight to it. When it is working the connection is solid but all the time the app can’t find the streamer it is no use.
My laptop connected to the same network on wifi can see the streamer as a network device and I can open the internal web page on the ND5 where it tells me it is indeed connected but quite often the Naim app can’t see it.
I tried setting the IP address on the streamer as a static address but doing that the app told me that it couldn’t connect to a manually reconfigured streamer?! Why have that option if the app won’t recognise it?
Switching back to DHCP it seemed to lose the wifi configuration altogether so it was a case of the reset button on the back to get it back to factory defaults. That entailed the same frustrations I had when I first got it where it took at least 10 attempts to connect to the streamer from the app while the status indicator was flashing purple. The app finds the streamer and even shows the serial number of the device in the app but it just won’t connect.
Last night for example it was streaming from my NAS but the app just lost contact with the streamer so even though the music was playing the app couldn’t find the device.
When it is working it is fantastic but these connectivity issues are a PITA and really not what to expect from an expensive bit of kit. Any suggestions on what might be the problem and how to fix it? Unfortunately connecting via ethernet just isn’t feasible at the moment.

Spooky coincidence. I have complained before on here about our Muso2 and ND5xs, both brilliant but the experience is spoiled by the SW.

Friday night great Muso listening session, all day Saturday too. Faultless. Sunday morning with nothing touched or changed,

just a white spinning disk on the screen

Rebooted everything

Said this for about 30 minutes so went for a walk. Came back

With the purple LED on the side on.

When for another walk till Sunday evening. All working normally again. Flabbergasting experience. Good luck elverdiblanco.

Both devices on wifi?

The infuriating thing is that even if I power down the router, the streamer and my phone and bring them back one by one, sometimes the app will find the streamer and sometimes it won’t. Sometimes it will take 5 minutes after powering up the streamer before it is visible on the network and just because my laptop can see it, it is no guarantee that the app will find it. Naim really need to sort this but given the seemingly random problems trying to fix them will be difficult. I’m a software developer myself and if you give me a consistently reproducible bug I’ve got something to work with but these random sometimes it works and sometimes it doesn’t are a nightmare to track down and fix.

1 Like


This is what i do - Have you tried shutting everything down then and re-powering everything back up again, one by one, starting with the router. Once all rebooted then try reseting the Naim app?

All rock solid here, no problems, so i know it’s not the Naim app - in your case.


I’ve been doing all that apart from resetting the Naim app. Is that any different to clearing the cache from the OS because I’ve been doing that too.

This may be a silly question but how does a Linn app help with a Naim streamer?

OK in my case the upnp server is minimserver running on a Qnap NAS. So what you’re saying is that the Linn app would see the minimserver and send the music to the ND5XS2? What about streaming radio or Qobuz/Tidal?
Anyway that sounds like a bit of a different issue to what I’ve been having. I don’t think the ND5 ever loses sight of the upnp server as it can be streaming quite happily from the NAS while the Naim app point blank refuses to find the streamer.

Exactly. Just briefly, Muso 2 in Germany, ND5xs2 in the uk. Both can be brilliant for weeks then sudden mad random behaviour. So it can’t be location based imo.

Guys this is not about software, this is about your home networking components not working correctly.
To explore properly you will need to state the home networking products you are using and how they are connected. Also state whether using Android or iOS.
From the look of it this is about errant wifi bridge components or faulty client (Android/iOS device… some Android implementations are troublesome here)
Almost certainly your home wifi components or Android device are not processing multicast group addresses correctly. This is a key part of many discovery techniques used in some IoT software and home audio/UPnP discovery.

You can sometimes work around faulty home networking components in this regard, at the cost of less efficient network use by disabling their IGMP Snooping feature, especially on the wifi bridge.
If your devices don’t have this, then you will need to replace them with correctly functioning devices or contact their consumer tech support and perhaps if you are lucky ask them to collect logs etc, so they can provide a firmware update.

If you are using a quality audio switch there are configurations you can give them, such as with a Cisco 2960, to encourage your home network to process multicast groups more effectively if having discovery performance issues . You will need to enable an IGMP Snooping Querier, but you will need to resolve the above fundamental issues first.

To be fair to Naim they have tried to make their software as robust as they can here by supporting all group versions and many behaviours to cater for differing home network device performances, but ultimately this moves beyond Naim’s control if home network devices are faulty.

Yes I have spoken to Naim before about suggesting lists of known correctly behaving network products, but they are reticent to do so, as the variability and quality of such things for a global market is so huge it would be impractical to administer. I take their point.


Ok… it’s what I do for a living… but its upto you, but hopefully it might be of help for the OP … I see it a lot with errant consumer equipment… although less so more recently.

A test is to ping the SSDP group address and sees what comes back,… all UPnP discoverable devices that are reachable should respond.

Another check is to run a little consumer app called LAN Analyzer that helps diagnose such errant home network behaviour and run a discovery sweep on your subnet and your reachable SSDP devices (ie used for UPnP discovery amongst other things) should have a little U by them. (I think Naim used to recommend this)
Kazoo uses a different method from memory at the expense of efficiency… or at least has the option to.

If you search back over the forum over the years you see my advice has helped many members who had similar issues who now have correctly working network audio, not to mention those who contact me privately that I have helped.

Now if your client with the Naim app, the UPnP media server, and the streamer all have a U by them, after having run the UPnP discovery sweep, or respond to ping with a group address ping… then there is a possibility that it is the Naim software/client OS… but bear in mind the Naim application is working fine for tens of thousands people world wide… not to mention the extensive beta programmes… but sure occasionally a rotten apple gets through.

The good news is the quality of consumer network equipment has improved in recent years because of increased IoT, home automation, IPTV etc… but you will note I am usually quite careful of what equipment to recommend and wary of certain off the shelf consumer products.

But please don’t blame the software unless you have specific evidence… it’s a bit like blaming the car for a bumpy ride when the road is littered with potholes… you kind of need the evidence to suggest the suspension is faulty.

BTW you still have not listed your home network equipment and how it’s connected which is curious.


Not in my experience. Apps that work the same way and use the same efficient protocols that Naim use tend to operate the same.
The Naim app is rock solid when supported by a troublefree infrastructure.
If you have consistent issues, it does point to something else of than the app, otherwise it would be consistently troublesome for everyone or most other else… which isn’t the case.
I like to apply an engineering approach to such matters.

In fact a lot could learn from the efficiency and cleanliness from the Naim app and design, especially on iOS in my experience.

The longest I wait for discovery clients appearing on the Naim app I estimate at .5 second,
but clearly when being let down I know it’s frustrating. Perhaps one area where Naim might improve things is to provide better user accessible diagnostics to see what is happening or not on the infrastructure.

Simon, thanks for your knowledge first of all. I still share jmtennapel and his/her frustrations.

2 inputs > we have two separate streamer experiences. Muso2 and ND5xs2. one in the UK one in Germany. So different routers (a netgear D6400 in the UK and Speedport Smart 3 in Germany, but I guess the components inside are generic Chinese or something), wifi environments, BB suppliers, firmwares, setups and even the cabling and sockets are different here, even the box in the street outside is different (I’ve seen inside it during a fault) distance to the FTTC box is about 10 meters in Germany and 950 meters in the UK.

My background is medical electronics and diagnostics so i (hope) have a technical enough brain to understand but not so much in coms protocols.

So finally a question. In your explanations do you mean the source providing box, the wifi router, can change its protocols and settings by itself dynamically, thus interrupting the receiving Naim box protocol?

This would explain the random behaviours, but my point is that in two separate installations in 2 countries the issues remain. Works brilliant for days then in both cases we are turning every box on and off until its working for the next few days.

Maybe Naim should launch a router of their own that is nailed down to a protocol that just plug and plays!

Thanks to all



Thanks for the replies @Simon-in-Suffolk I’ve installed an app called Net Analyzer on my Android phone (and even stumped up 99p for the Pro version!) and here’s a few screenshots.
The first one shows some of the results of scanning my network, the second shows the detail page for the ND5XS2 and the third explains what the icons beside each entry mean. The fact that the ND5XS2 shows only Bonjour services, does that sound right or is this perhaps a flaw in the Net Analyzer app?
I’m typing this note on a desktop computer connected to the network via an ethernet cable and it can see the ND5XS2 on the network while my phone sitting to the right of the keyboard can see it on the network but the Naim app can’t.
I have a Billion 8800NL R2 router. There are also some TP-LINK powerline adapters in use but today I’ve ordered a BT Whole Home Wifi mesh kit so the powerline adapters will be gone tomorrow.
Any thoughts or ideas in the meantime are welcome.

I approached my dealer 10 months ago with a view to buying an nd5xs2. Since then I have bought a cd5si and a nait xs3 but still no streamer. I have watched the forum carefully which may account for some of my hesitation but this thread has now convinced me that it’s not for me. I can buy a lot of vinyl and cds for £2400.The last thing I need now is more stress.

1 Like

For me the motivation behind buying it was not having to have hundreds of CDs littering the room and as a serious upgrade to the Sonos Connect streamer. Both those objectives have been met; I have all my CDs ripped to a NAS so they’re all available from an app on my phone, and the sound from Tidal/Qobuz is vastly improved compared with the Sonos. Hi res streams from Qobuz leave the CD5si for dead and streaming from the NAS they sound better than the CD5si though not massively so. I don’t regret the purchase and I’ll be selling my CD5si in due course, for now it is all back in its box.

Sure, these connectivity issues are a pain in the neck but I’m confident that they are just teething problems and that one way or another I’ll get on top of them, after all there are thousands of other ND5XS2 users out there who aren’t complaining. If you can hard wire a streamer you probably won’t have any issues at all.

For me, being able to store all the CDs away and not have them littering the listening room is almost worth the purchase price alone. If the connectivity issues can’t get resolved and it is too much of a frustration, I bought it at a good discount and would get most if not all of my money back if I were to sell it but I’m confident it won’t come to that.

The protocols don’t change, but the protocols control the network devices, yes. The discovery technique used by UPnP uses SSDP.
SSDP uses a multicast group with IP address
Now multicast groups are usually snooped and ports filtered to stop clogging networks with unwanted broadcast information, this is particularly pertinent to wifi, and so IGMP snooping (multicast group snooping) is usually applied on WLAN bridges.
Now for this to work the clients need to advertise they belong to the group… this is usually largely managed by the OS of the client device.
These advertise messages are listened to by the snooping device which then allows the snooping device such as a wifi bridge to allow the communication to this group address to pass to a MAC address/port.
If the snooping device doesn’t recognise the IGMP protocol versions by the OS/software used or is not functioning correctly, then communications may not pass, and discovery will fail.
A work around on devices that support it is to disable snooping and let group messages pass through as ubiquitous broadcast messages… this can lessen the performance on the LAN or WLAN.

As you can see the poor a Naim app is being left out in the cold in this scenario.

1 Like

Something is a miss on your home network/Android device, as your streamer should have a U as well, and it doesn’t… it’s only supporting Bonjour on your home network.

This is what I see for my streamer using an iOS client.

Just checking to see if you connect your streamer with Ethernet or wifi? And confirming you are not using any workarounds like powerline adapters.

Martin, my advice to you unfortunately will be to replace your Android device with an iOS device. If you read technical user forums, you see quite a heavy volume of issues with certain Android / driver implementations with Wi-fi broadcast and multicastissues… and it can be down to application execution timing, or the Android OS build that can allow broadcast/group data to work correctly.
Luckily iOS seems to be significantly better behaved consistently.

The streamer is connected via wifi in the same room as the router with a direct line of sight to it. There are powerline adapters in use (until tomorrow anyway) and when I posted the screenshots earlier I was in a room where the phone would have connected to the wifi from a powerline adapter. Running the scan on the same phone and in the same room as the streamer and router it now shows all the services as in your shot. Hopefully once the powerline adapters are gone tomorrow and replaced with the BT mesh system things will be a bit more consistent!

Forgive me if this was addressed, but I didn’t see any mention of the hi-fi dealer who sold the nd5xs2 to begin with.
Someone who buys a pricey piece of gear should expect some support or proper installation by the retailer, no?