Naim app failing to find ND5XS2

I bought it online a couple of weeks ago from a Naim dealer as ex-demo. The dealer I bought it from isn’t my local dealer as they were all out of ND5XS2s so it came from a fair distance away. I’m sure if I had asked the selling dealer for advice he would have been happy to help but given the nature of the problem I figured there might be a better chance of an answer in here perhaps from others who have seen and solved the same issue. I’m fairly confident the unit isn’t faulty, if I suspected that I would have been straight on the phone to the dealer.

One other thing about that LAN Analyzer app, it was a bit of an eye opener seeing how many devices are connected to the LAN. I’d have guessed without thinking too much about it around a dozen but there’s actually 23!

Interesting you blacked out the mac address, could this a security issue if shared? Thanks in advance.

When I first used the Naim myradio site to add stations I was able to do so with simply a MAC address. Maybe it was doing something clever from the website over my LAN but better safe than sorry.

I have a Supernait 2 and decided I would try the ND5 XS used before I put up for a newer Naim streamer because they are pretty pricey, I also got a great deal on it. First, it sounds fantastic. However, I have the same connection issues. In my opinion, it is absolutely the Naim app and I will show why I believe that. I also work in IT, been doing networking since the token ring days in the 80’s. Here is my setup and what I have done.

I have my whole home wired. I have a router that runs to a central switch in the basement. I basically have a rack with a blade server, a NAS, gigabit switch and a UPS. I have tried both the iOS and Android app and the dropping behavior is the same. If you look at the reviews on both app stores, they are full of people with the same complaints and both apps were rated 2.something out of 5 stars. If you go to settings and turn on keep connected, it helps some, but not significantly. I have spoken with Naim support and they tried to be helpful, but there was no solution.

Things I have tried:

  • Running a cable across the house from the streamer to the router to cut out the switch.
  • While doing the above, standing right next to the router(it is in a different room) with both my Ipad and android phone to be sure that wifi signal wasn’t dropping. Behavior is the same.
  • Trying the streamer on wifi as well just to be sure it didn’t behave differently that way.

My observations:

  • The streamer is always on the network. If I go to my computer and type the IP in the browser, I can always see the streamer. Even when neither app will find it. This is a handy way to be sure it is staying connected.
  • If I reboot my iPad, it will pretty much always(maybe always) find the streamer the first time and then it loses it after some arbitrary length of time. This is a huge PITA when you are sitting in your chair in the sweet spot trying to enjoy your amazing system.
  • If I go to the Spotify app on any device(PC, android, iOS) it ALWAYS sees the streamer from what I can tell. I prefer the Spotify app experience in general, but the quality is not as good. I have about $10K worth of gear and I shouldn’t have to settle for lower quality. (Spotify, please bring out HQ quality, pretty please?)

I have a computer in the corner of my listening room. It doubles as a home officel. My preference is typically to control the streamer with the computer anyway, so my work around is I run MEMU, an android emulator that lets you bridge your hard wired PC network card. Most emulators do a wifi emulation and don’t appear on the same subnet. Bridging your connection allows MEMU and the Naim app to communicate with the streamer. This has also never lost the connection, unless the computer goes to sleep.

The fact that I can always see the streamer on the PC browser, the android emulator and the Spotify app tells me it is the way the Naim app is interacting with the wifi on mobile devices. I feel like I have forgotten some things above, but I have spent many hours putzing with this setup. I have tried different cables and switches. I have a $500 router sitting at home to try, but I have so many devices it is a major pain and I haven’t done it.

I am open to suggestions and would love to figure it out. It seems like some folks don’t have issues.


1 Like

That’s why I have abandoned the idea of buying nd5xs2. Half my listening is on cd or vinyl with the other 50% of the time on lo fi streaming devices in order to preview music which if I like I buy on cd or vinyl for higher sq on my main system. Plus I like to own the hard copy. Using something as simple as say a HomePod is a fun way to discover new music and if it does ever lose connection I am much more forgiving than I would be if I had spent £2400.

When I purchased it, it was on 4.6. I upgraded to 4.7 and it did not help.

I have tried it both wired and wireless.

The IGMP Snooping thing Simon posts about a few posts up?

I will try it this evening, but Simon’s previous suggestion that it is an android problem and to switch to iOS has not helped me. I have a higher end Asus router so I will take a look in the settings there as well.

Simon cheers, i will do some reading.

No… it can be specific or even potentially unique, but it has no meaning in terms of addressability outside of your subnet.

1 Like

Don’t forget the ‘pull down’ feature in the Naim app for this to search again for the device/room, which saves doing a full setup for the device.

I had big problems getting my Muso Qb2 to connect (previous Qb1 was fine) to a particular router over WiFi, this was partially resolved by changing the IGMP frequency in the then Draytek Vigor router, and then fully resolved by going over to PlusNet-supplied router. There are two standard Cisco 2960 switches on base settings as well in my network, DHCP from the router.

I had fewer problems with my then ND5XS2 which was on ethernet in the same environment, although it did often take a while to connect into the Naim app until I amended the IGMP settings (to a 30 seconds search frequency) - then it was instantaneous.

The Qb2 is now on a wired connection into a localised switch, with control over wifi into router of course, using iOS. Testing occassionally over wi-fi shows this is now stable. I have no hard evidence as I do not want to get into network scanning and engineering, but because I live in a small estate with many visible wifi networks (Sky, Talk-talk, BT) there could be interference from these and other wifi connected devices.

I am using roon 75% and the Naim app 25% (the Qb2 is currently my only Naim device, in my office), both are stable, except some evenings I get short dropouts from streamed services.

1 Like

Would you have any suggestions on my situation? I ran lan analyzer on my NOTE 10 and the first time through the ND5 only had a P. I ran it a few minutes later and it had WUP. It would not connect either time(I tried on the iPad as well.) My router does have professional settings and I had IGMP snooping disabled. I did try enabling it, but did not appear to make any difference.

I have been around the block IT wise and know a lot about networking, but I am a jack of all trades and not a network expert. I think my current router is an Asus AX88U. I also have a Netgear AX12, but I have so much home automation that the thought of reconnecting everything has prevented me from trying it out(and teenagers that die when disconnected from the internet :wink:

can you run the analyser on the iPad please - the same one that you use to run the iOS app.

If when you do and you see a U against streamer and server - but the Naim app on the same devices is still not working - then looks more like a Naim issue.

Can you advise which interfaces or bridge the IGMP snooping was applied to? If it was disabled and applied to your switch ports and wifi bridge - then you will be broadcasting everything - and so the issues will be not to do with this.

However you should see a fairly consistent set of symbols against the streamer using Analyzer on your iPad. If it varies significantly frequently - then it points to an issue with your network devices or client devices. Ensure you are not using any kludges like power line adapters as really you need ethernet or wifi for reliable operation.

Unfortunately I have previously had issues with Asus wifi bridges in the past in terms of reliable operation elsewhere - not to say yours is faulty - but I have not had positive experiences in the past.

My next suggestion would be bypass the Asus wifi bridge and use an alternate wifi access points(s) such an old Apple Airport Extreme or some of these new consumer wifi easymesh solutions, or even an Ubiquiti access point connected to your LAN switch port

I ran the analyzer on my iPad Pro 10.5. The streamer comes up with a P. I try the app and it doesn’t work. I power the iPad down and back on. Run the scanner, still a P, but I open the Naim app and it is instantly available. Seems to be that way every time I reboot.

IGMP is disabled. I have no powerline adapters. Router upstairs, ethernet to 24 port Gigabit switch in the basement and everything else plugged into the switch. I have tried bypassing the switch and running the streamer directly to the router via ethernet.

Not sure where else to go short of changing the router.

It does sound wifi bridge related on your router… and the virtual port on the wifi access point for that Mac address is closing and not opening up again…
If you had the know-how and the right equipment you can run an IGMP querier… which is a process that wakes everything up in a group regularly to keep bridge ports and snooped ports open.

I would try an alternate wifi access point. Can you try that? If you can disable your current one. I suspect if you use an Airport Express or Ubiquiti access point or an EasyMesh solution plugged into your switch it will spring into life and stay alive.
I can’t be sure at all without looking at any logs… but that is my hunch.

Can you confirm whether the switch is a basic consumer one or managed?
If managed can you see if it’s snooping and what groups it’s processing?

Here are the group IP addresses on one of my Cisco Catalyst switches and the ports enabled for which groups using snooping to give you an idea

The last group shown here is SSDP used by UPnP, and would have a U using NetAnalyzer for hosts connected to this group.

Just to add that I used to have similar problems (although not identical) with the Nova. These have completely gone away since switching to a Mesh system.

Only two days in with the mesh system and getting rid of the powerlines (even though they weren’t used to connect the streamer) from the network but so far so good. Fingers crossed…

1 Like

I’m with @PW42 on this one. Once I switched to a Mesh network, all my problems went away. I don’t even think about WiFi anymore. WiFi throughout my house with thick walls has been fabulous. Still in shock that Apple didn’t get into this game by buying out a company like Amazon did. Sorry I digress! haha. Happy that’s it’s working out for you. We are lucky to have resources like @Simon-in-Suffolk on this forum, and that he’s happy to help.

Excellent, I have suggested that the wifi bridge is possibly at fault… and trying a new wifi solution.

Glad to hear all sorted. Yes a quality wifi solution you can expect to just work and take for granted, without a fear of funnies or frustrations with more demanding applications.

1 Like