Naim App not finding Unitistar

I have a persistent problem with iphone and iPad unable to connect to my unitistar.

Unit is wired via Ethernet and is able to play from the front panel without issues. iOS app is 5.18 and firmware on unitistar is the latest. The app claims it cannot find any units when you initialise it. Tried multiple app re-installs and power cycles on the unit.

Anybody seen similar issues?

I spoke to Russell in phone support and he has no idea what is causing it. I sent him a network scan but no issues were reported back to me.


Have you tried deleting the app and reinstalling? I updated to IOS14 yesterday and the Naim app wouldn’t connect, but did after reinstalling.

Thanks…as said in original post, re-installed many times. Updated everything to ios14 but that doesn’t help

I’ve had a 272, ndx2 and now the uniti and the Naim app is unstable garbage considering how much Naim charge for their kit…tired of it now

Even when it was ‘working’ yesterday for a short period the album artwork was stuck on 3 albums prior, the track name was one track out of date and the audio was correct. Do Naim actually test their systems?

For me, on a daily basis, I don’t have issues with the app, it just works.

Where I have had problems it’s after I’ve played around with the network.

I have Muso gen 1 and Unitilite and discovery isn’t particularly a problem. Many on here have issues, so clearly something going on, but whether it’s app or network who knows.

I hope others on here can shine some light on your issue.

Just a thought do you have 2.5 and 5 ghz on your router. Could be that they are on different WiFi frequencies.

I haven’t changed anything in the network in the last day or so. I reckon it’s highly unlikely that it’s related to that. WiFi broadcasts on 2.4 and 5 and has done since I can remember.

Sorry, forgot to ask what you mean by ‘they’. The unit is wired.

This sort of issue is really aggravating but you would probably need to give more information about your network (for example, which router do you use, does that generate WiFi or do you have a separate access point) for the many knowledgeable people here (not me!) to be able to help.

Ok. Just if on WiFi and the tablet was on one frequency and the Star on the other it can cause problems.
If wired then I don’t knows

I had the same problem today with my Core. Reset the router,unplugged the Core,unplugged the switch…still searching for rooms. I updated the Core last week, and updated the iPad to the latest firmware the other day. Glad I have my Rp10 and Teac DSD player,will have to try again on the weekend.

That’s not necessarily correct. It all depends on how the network is configured. For example I have Virgin Media Superhub that has both 2.4 GHz and 5 GHz networks and they work as one. It doesn’t matter which anything is connected to.




SkyQ router but not used for WiFi. WiFi is enabled using an Apple router. This has all worked fine for years

Nothing has changed on the network. Only the Naim app and the unitistar firmware.

Thanks…that sounds like the same issue. I’ll call Naim again on Monday

Have you updated the firmware on your Star? Is it now in 3.5? If so then I think it would be worth trying a factory reset of the star as there seem to be some issues with the new firmware release.



The only thing I have not looked for, is maybe my I-pad reverted to 2.4 when I updated it, where normally I use 5g…hopefully that is all it is.

Try performing a network reset on your iOS device. Go to Settings > General > Reset > Reset network settings.
You will need to enter the Wi-Fi password to reconnect after doing this.

1 Like

Thanks for this, I will try it when I get home from work.

I ended up deleting the App and reinstalling it, now it works again…not sure why this happened though.