Naim App on iOS doing my brain in

Any tricks to keeping the Naim App connected to your kit?

My iPad is the host for the App and gets used all over the house via Wi-Fi but for the life of me I cannot work out why the App and 222 are so angry at each and refusing to talk to one another.

My 222 is sat very happily on the house Wi-Fi but the App connects, then disconnects, then cannot find the 222. When it condescends to reconnect it happens when I least expect it.

If there is anything special I need to do to get the warring factions to talk to each other please let me know.

The system has been rebooted, the iPad rebooted, the App closed then reopened, the App has also been deleted and re-installed, each reboot/closure has a positive result but its long before the talking stops.

It’s driving me mad.

Update, no connection all evening, then suddenly the sulk is over and they’re talking to each other.

I’ve not moved, the iPad has been on the settee next to me, all I have done is get up to turn LP’s over.

It’s mad.

Your problem is going to be in the network. Can you describe it and how your 222 is connected to it? Basically the iPad and the 222 need to be on the same sub-net and it needs to be transparent to the protocols that the app uses to discover streamers.

1 Like

Do you have any issues with streaming or just with IOS app? Try going into IOS WiFi network settings and disable private WiFi address option.

1 Like

Both are on Wi-Fi, no Ethernet cable in the room, Wi-Fi dongle within 10ft of both iPad and 222

No issues with anything on the 222 it is simply the connection between the iPad and the 222

Is the only source of WiFi in your home the dongle? Usually this sort of problem occurs when the streamer is on one network and the iPad is on another, both of which are supposed to be the same network, but actually are subtilely different.


No, the hub is downstairs the dongle on the first floor, it’s a BT setup

I had a similar problem a while back, I’m all ethernet, except iPad obviously.
I found the same as thirdEze is suggesting, I had an IP Address conflict with the iPad.
To check this, go to iPad settings > WiFi > open the BT hub tab and make sure Private WiFi Address is disabled. Your BT sets this with DHCP and it needs to left as-is.


Okay, I’ve turned this off and will see how I get on. Thanks.

1 Like

Nope, didn’t work, contact lost between App and 222.


When contact is lost can you try the device website, using IP address (which can be found via app when connected - Settings, About, IP address)

For example, on iPad browse to (using device IP - 82 is today’s NDX2 address in our household)

Should give you a lovely naim info front page if devices can see each other over basic TCP connection.


OK sorry for this, but whatever please leave Private WiFi Address off. It’s pointless in a home environment as your connection is via your BT assigned IP.

I know you’ve done all sorts of reboots, but have you run all system power down and restart?
All off, wait 5 mins so BT register you’re off line.
Restart BT only, let it complete restart … then
Restart 222, then one at a time all the other stuff on the BT hub.

Final question, what is the ‘dongle’ what make/model and why do you have it, I’m thinking it could be a signal conflict with the BT Hub. A BT Hub wifi should cover the whole house or you need to add a pukka BT extender disc.


Apologies, running around dealing with errands from Mrs O at the moment will check and respond properly later today.

I would check if your iPad can stream something e.g. youtube, without any problems. Just to rule out general iPad WiFi problems.

And update iPad OS and the Naim app as well.

1 Like

I suspect that your issue is that the 222 is talking to your WiFi dongle and your iPad is sometimes talking to the WiFi dongle and sometimes to the router downstairs, and that the two wifi networks aren’t seen as one by the Naim app.

You could force the iPad onto the WiFi dongle by putting it very close to the WiFi dongle and turning WiFi on the iPad off, wait a few seconds and then turn it on again. Does that help?


Thanks everyone for the suggestions.

One part I should have made clear is that the ‘dongle’ is in fact a pukka BT extension disc, apologies if I misled anyone.

This is what I have done after reading the replies.

Private browsing is off.

To test whether there was an issue with one Wi-Fi output conflicting with the other I set the 222 playing internet radio and then simply turned off the extension disc which I presumed that the 222 was connecting with.

Nothing happened, radio continued to play, not a pause or blip in proceedings.

My iPad continues to work fine, in fact I’m typing this reply on my iPad.

Big news, my iPad and 222 are now friends again, well at least they are at the moment, it has only been 30 minutes but it’s a start.

I am not sure where I go from here, restart the extension disc, move it higher up the house, leave it off, I’ll play around with things and see what happens.

Thanks for everyone’s help and suggestions, much appreciated.

If there are any changes I’ll update the thread.


One question for clarity …. what BT hub is it and what BT extension disc.
The older pre ‘smart’ hubs can only play with the white discs.
The Smart Hub 2 is designed specifically to partner the black disc

I’ve quickly browsed thread. I used to work in broadband tech support and as soon as I seen your post with issues having first thing I thought was BT Home hub those are really common and the only to sort out connectivity issues is to rip out all BT hardware get a new router and get rid of all BT discs.

The Hub and Disc are the latest type, approx two years old.

I have not had any issues with anything connecting over WiFi until the last few days, even the installation of the 222 and linking it to the WiFi went without a hitch.

Overall very happy with the WiFi.