Naim DTC cannot locate NSSVR (Unitiserve) on the LAN

This could be a noddy one!!!
My Naim Desktop Client app cannot connect to the Unitiserve because it the wrong IP address and re-scanning doesnt fix the problem. My PC finds it no problem, so do all my iOS devices – iPads, MacBooks etc. The serve app on my iPad finds the unitiserve OK. So this problems seems to be specific to the DTC on my PC. Is there any way i can get the DTC to snap out of the inocrrect IP address and re-scen for new one???

Are they both version 1.7c?

Have you tried this button?

Are you using any software firewall or antivirus that may be blocking the app?

Regards
Neil.

Are you using Windows 10 (or 11) by any chance? If so, do you have SMB1 turned on (it’s turned off by default in Win 10 and 11 for security reasons).

Edit: Never mind, if your PC can see it in network explorer, then that’s not the problem.

yes, i have tried that button many times to no avail. i downloaded the latest version of the DTC. I am also pretty sure my NSSRV is also on latest but not sure.
image

yes, i am using Win 10. when i open File explore under Network – i dont see SMB1 – what is that and how do i manually turn it on?

I use Malwarebytes for antivirus on top of Windows antivirus and firewall. if this is indeed the issue, how do i fix it?

That’s 1.7b but there’s only a very slight change as far as I’m aware with 1.7c.

Correct, 1.7c was just an improvement to metadata lookup, so apart from that 1.7b should still work fine.

It’s probably turned on already but type in “Windows features” in the bottom left search bar and click on “Turn Windows Features on and off”. Go down to “SMB1/CIFS file sharing support” and make sure it selected.

Switch it off & see it resolves the issue. If so, you should be able to add an exception within Malwarebytes to allow the app to circumvent it.

Regards
Neil.

This doesnt seem to help even after wind 10 restart

I have to admit, I’m running out of ideas here, as I’m no networking expert!

Is there anything remarkable about your network - vlans etc? What address range are you using?

You say that DTC is stuck on the wrong address - are you seeing that in this location?

DTC1

Regards
Neil.

No, nothing special about my network. The fact that all other devices find the IP address OK must suggest that i guess. As i said, in Win 10 File explorer, i can see the NSSVR. I can play music from my NDS perfectly OK. I ran a network scanner on my iPad and it finds the NSSVR IP address OK. So the problem seems to be something wrong with DTC, not my network as far as i can see here. No?

enjoy/ken

Possibly. I have not heard of any discovery issues with DTC, but one of the other tools provided by our then partner Digital Fidelity, is quite fussy about certain address ranges & will not return any search results from units on those ranges. Hence my question regarding which address range your network uses.
If it’s something pretty standard like 192.168.1.* or 192.168.0.* then I’m probably barking up the wrong tree.
So my last ditch piece of advice would be to change your router’s address to 192.168.0.1 with a DHCP pool between 192.168.0.2 to 192.168.0.254 with subnet mask 255.255.255.0 & try again.

Regards
Neil.

thanks for your continued help Neil !!! Will give this a try… I dont know how configurable the Virgin Superhub 3 is – but i will definitely give it a go. Thanks again…

1 Like

ah, could this be the problem then?


Local addresses on my Hub starts at 192.168.0.10
and DTC is looking for NSSVR at 192.168.0.3???
image

It shouldn’t be a problem, as long as your Unitiserve is set to DHCP.
Really, DTC should see it even if the address is outside of the address pool, but on the same range.

Regards
Neil.

I guess that begs the question, what sort of DHCP server sets an address range, and then allocates IP addresses that are not within that range?
Maybe worth checking the Unitiserve IP address in the router’s address list to check that it has actually assigned it the .0.3 address, and it’s not just an old address that the DTC refuses to forget.