Naim streamers slow

I was just reading this and thought humm . So from across the house upstairs from both router and my G1 streamer, which was asleep I selected my G1 and it took about 3-4 seconds to wake and instantly allowed selection of music. I’m not nagging on Naim, I’m just surprised my system is so quick… all on WiFi

I would, in that case, sell the Ndx2 and get an Ndac/ Xps dr for the sell price. Running the Ndx2 only as a dac is a big waste of money. IMH.

I have noticed that a Chromecast stream playing on the NDX 2 responds instantly to the playback controls (Pause, Next Track) that are either incorporated directly into Android or the Source app (e.g., the Radio Paradise app)!


Awhile ago when I was trialing Quboz, I noticed app slow response on playback for Hi-Res tracks. I thought it was just something with my wireless network, however I don’t notice it with local tracks or Tidal (All going through Roon). FWIW

Yes! I noticed the exact same issue with 96 kHz and 192 kHz tracks playing from Qobuz. The Progress Bar showing how much of the track had been played was very slow to update and would occasionally leap forward in big chunks. Also, the track details suck as Protocol and bitrate took ages to show up.

I did ask about that in an earlier forum posting but nobody responded.

1 Like

Sorry I missed that post. I would have chimed in. It’s one of the reasons why I don’t use Qobuz. I did think the SQ was slightly better than Tidal, but grew frustrated waiting for tracks to start playing.

1 Like

This specific ‘track info updating’ issue has not always been a problem with Qobuz. It seems to have started after Naim added a fix for the stuttering on 192 kHz tracks. I access Qobuz from my Limetree Bridge steamer and the track info updates smoothly. So I am assuming this problem is related to the Naim app and is not endemic to all higher resolution tracks on Qobuz

1 Like

Someday I’ll have to try Qobuz again. I hated the delay!

Strongly Agree.

You may be correct about the app SW, and about the response times (I have complained in this forum many times about the app). I have been near to throwing out Naim for that reason.

But thruth be told, when you listen to music on a high end system, the node2 (which I owned before, feeding a Naim dac 1), is not on par with the NDX2. In my personal opinion it’s not even on the same planet :wink:.

The problem is in getting it to play. But given the latest version of the app, my ears are very glad I stayed on the NDX2, and my mind is able to cope with the (indeed not -yet?- on par) command stream. I live in hope.


Should be noted that the buffering commend was apparently based on a misunderstanding and Clare corrected this immediately when realizing that the OP was about the app as well.

As a counterpoint:-

The Naim app response time on my iPad for both Atom and Qb2 this evening is instantaneous - for albums and cover art from Asset UPnP on a NUC on my wired network and from Qobuz (internet connection is FTTCabinet); internet radio stations also showing quickly. There are approximately 15 devices on this network including SmartTV, the router is a standard PlusOne from Plusnet the ISP.

The Naim app and firmware has been vastly improved this year.

Interesting. As mentioned, I don’t see a difference with the dealer’s iPad mini.
Do you have “keep connected” on? Does it react instantaneous when you wake the screen from sleep? Mine is also instantaneous once it is woken up and while I am constantly using it. But after the screen wakes up it takes up to 10 secs sometimes until it (the app) updates the currently playing track or accepts user input incl. volume change

Likewise. Except my Muso is a QB1, not wired, and the router is a Fritzbox. I also have an Auralic streamer in the main system and the Naim setup is at least as fast in responding to the relevant app.


Yes, ‘keep connected’ is on. The wakeup from sleep is quick. I did have problems with Naim app connectivity with a previous router (a Draytek Vigor), especially with my Qb2 setup process when it first arrived. This was eventually traced to the ‘IGMP’ setting in the router; once this was set on and to rescan at least every 30 seconds the problems were reduced.

Ok thanks. Well, keep connected helps with the unresponsiveness, for me too. However if I enable it, the screen stays on as long as the Naim app is in the foreground. This is the case on my Android and the dealer’s iPad. The result is that the battery drains in a day. This is not a real solution. Is it the case for you as well that the screen stays on if the seeing is enabled?

Thanks for the router tip, will check. Although, I had the same problem with the older router and now the new Fritzbox too. Peakman above also has a Fritzbox and says no problem. In any case, a router issue might affect the streamer response but should normally not make the app unresponsive after wakeup (if the app isn’t doing something silly)

This just stops the iPad from sleeping and keeps the screen on so you don’t have to unlock it. Nothing in the preformance of the Naim app changes. Unless you find unlocking the app too much of a faff, I wouldn’t bother with it.

Though I agree in principle, in my case it helps because the main issue is unresponsiveness after waking up, so if the screen stays on this is improved. It’s just that the side effects are unacceptable :slight_smile:

I have ‘Keep Connected’ on & use an iPad cover that makes the iPad sleep; all works OK & nothing is slow.

I don’t find the responsive of the app slow. Most things are pretty instant including starting playback.

I just use as is, no keep connected or any fancy settings. I use an iPad 2018 and Asset running on a QNAP.

I have created a short video to demonstrate how it is for me. I terminated the Naim app before starting by swiping it away so this is loading up.

I would suggest that if you don’t see a similar speed to this then you have an issue elsewhere. I find the Andoid application similar in responsiveness.