Naim streamers slow

I run the app on an iPad and iPhone. No problem with responsiveness from me. I actually mainly use Roon. Any responsiveness issues there (very minor) are down to Roon and not my ND5SX2. I do have a full ubiquiti network which I find is rather good.

I mainly use Roon too. It’s quite a bit faster than the Naim app but the Naim app is more than adequate speed wise.

The video does not show how it is after it is waking up from a blanked sleep screen. As mentioned numerous times, it is responsive for me once it is fully woken up from sleep, which takes anywhere form 2 to 10 seconds.

As for other issues, I struggle to see what it would be other than the app (possibly not an all devices, I can’t say) that would cause the following behavior:

  • Unresponsive after waking up, both on dealer’s iPad Mini and my Android devices (a tablet and a phone, both Android 10 and current hardware), both in the dealer network and mine (edit: the dealer set it to “stay connected” to overcome this as it would be embarrassing otherwise)
  • At home, on a tablet that is connected with 800 Mbit/s (5 Ghz) to the wifi router and router <-> Nova via a good switch and high-quality ethernet cables. The phone only manages 2.4 Ghz but also at 200 Mbit or whatever it is
  • Internet uplink at 250 Mbit/s
  • In a very simple network with usually only one active mobile and the Nova
  • On the tablet and phone everything else works normally, I stream HD video to the same devices without issue
  • The BluOS app and two different BluOS devices (Bluesound Node 2i, NAD C658) worked flawlessly in the same network and with exactly the same devices in the network, without any delays or app unresponsiveness

I have just tried waking up from sleep and there is no delay whatsoever. I don’t think I can video this but I assure you it’s instantaneous.

My network is reasonably simple.

At the heart there is a Draytek router with dual wan connections, it’s set to use my Virgin cable connection by default (200 mbs). Wireless is disabled on the Draytek as I use TP-Link Deco for wireless in access point mode. Otherwise there are Netgear swiches throughout, they are the managed switches but the management is very primitive and left to defaults.

I have no issues with discovery or speed. One wired Muso Qb, 2 wireless QB’s and one wired Naim NDS.

Thank you. Which leaves me only to conclude that the app does not work the same on all devices. If it had a logging option, I would enable it, but I offered to Naim support and apparently there is no such option, at least they did not take me up on it.

I have set up ethernets etc. since 1992 and my professional work is as a software tester and supporter in a successful software company. I am not a computer idiot :wink:

And others posted above that they are experiencing the same issues with unresponsiveness. I am happy that you don’t, but I bet that the issue is in the app somewhere and apparently only hits on some devices for whatever reason.

@trickydickie Here’s a video, sorry for quality. I wake up the screen with a double tap and try to change the volume. As you can see it does not react. Then I try to play music by touching the Play button and it does not react for 2 seconds, then starts to play music; only two seconds because I had first fiddled with the volume. Had I tried to play music immediately, it would not have started with the music for the whole time, either (and neither would have reacted to anything else). Then, after it has become responsive, it works fine.

1 Like

Suedkiez, tricky use an old streamer, you use an Ndx2.
With my Nds it’s very quick . But sometimes, not often, I have to click a second time.

Actually despite my system profile it is just the Nova. (There were delays, the 252/SCDR/NDX2/555PSDR will be here in two weeks. I had updated the profile thinking I would have the NDX2 the next day and didn’t bother to change back)

Edit: I see with tricky, thanks for pointing out. But I don’t see what it has to do with it, the app does nothing during these 10 seconds, including not anything that does not appear to interact with the streamer, like go to search, or go to the app settings, or go to the app home screen, or anything at all. (And even if an NDS would change this, no I won’t turn the NDX2 around and buy an NDS because the app has troubles!! :wink: )

Edit: And like I said before, I got used to it - the trick is just not to try anything for those first 10 seconds after wakeup. After this it is fine. Teaches patience, but it’s not right for casual Nova buyers. And a pain when the phone rings

I was not suggesting that :face_with_thermometer:

Just joking :clown_face:

1 Like

I am now pretty sure that it has something to do with multiple wired access points in the house (wired Asus AImesh network).
I unplugged my Nova and moved the ND5XS2 to another room close to an access point and it respons much faster now… as soon as I replug the nova both units start to becomes slower.

Surely possible in some instances, but I don’t have that. I also just tried to turn off battery optimization for the app but no change. The way this is going I will after all have to whip out the android development environment and see if the apps logs something useful over USB. This was what I did not want to do with my Naim hifi in the spare time :wink:


…just in case it is relevant.

So I finally received and installed my new NDX2 etc. (pic :heart:) and replaced the Nova.

It’s a mixed bag with the app:

  • The Stay Connected setting now does just that, and does not cause the tablet screen to stay on all the time, like it happened with the Nova. It’s a bit more convenient as a reconnect was so far never necessary and battery usage seems ok.
  • It’s still just as unresponsive after screen wakeup as on the Nova, though.

I get that the app cannot know the volume when system automation is enabled and therefore shows only the volume buttons instead of the slider, but it turns out to be a bit less convenient without visual volume in the app - weird how quickly one gets used to these things.

When turning off system automation, the Volume Mode setting switches to Fixed instead of Variable, which seems a bit scary, and is confusing because the app shows no volume controls at all because of this.

Magic. Played music yesterday evening and it was still the same wit the unresponsiveness. Woke up today, woke up the tablet as usual, and the unresponsiveness was gone. It has now stayed gone for an hour or so during multiple wakeups. Nothing changed (I hope very much) in my network while I was asleep. Naim’s the only hifi manufacturer where even the app needs to be run in :wink:
Let’s see how it continues, but for now I’m happy.

(Sidenote: When the volume buttons are used, they are displayed on the left hand side of the bottom bar, fighing for space with the artist and song title information. The rest of the bottom bar has plenty of space. The buttons would fit better and be IMHO more conveniently located on the right hand side of the bottom bar next to the play buttons. (At least for right-handed people, but the play buttons are already on the RHS anyway))

Edit: shouldn’t have said something, it’s back half an hour later :smiley:

Edit: Better again another hour or so later. Having an explanation for this witchcraft would be more satisfying, but if it is always like this, I can be happy. (And the sound of the new system, oh my! It’s so good that I’d flip the bits with tweezers if this was necessary)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.