Nd5 xs2 latest update, now all I see is purple

Hello all, I am feeling a bit bitter considering this is 3 weeks old.

Did the update today for the streamer. It rebooted and sat with the purple light on. Tired some resets and power plug pulls. I have completed 2 factory resets and everytime it fails to transfer the wifi passwords to the streamer and just sits with a purple light.

I have looked a bit on this forum and online and tired what others have suggested. Anyone have any other ideas? Not sure what else I can do. Thanks

Ask support. Try using an lan cable and see if that helps if it is a wifi issue?
It is a big unclear where you are in the process does it still work on the old firmware or are you having a bricked player?

1 Like

Hello, by support you mean dealer correct? I will try a lan tomorrow. I cannot get it to even pop up in the app won’t connect when setting up. Currently it’s bricked. I can try another factory reset tomorrow with a wired connection.

Worked perfectly fine before the update. Is there a way to usb force a rollback?

There is your dealer, but also direct with Naim product support … look at Naim website for details

1 Like

I would suggest deleting and reinstalling the App - let us know how that goes.

1 Like

The purple light means it’s not connected to your network, which is why the app can’t see it.

What you could try is to use an Ethernet cable temporarily between the ND5 XS2 and your router or network switch, then power cycle the ND5XS2 again. You should find that it successfully completes the update now and then you can take the network cable out, restart it again and complete the WiFi setup.

But if this isn’t clear, calling Naim support or your dealer is the way forward.



I’ve no idea why they call you Helpdesk Hendon. You too can be an HH.


There can be only one HH!



Thanks everyone for taking the time to reply. I really appreciate it.

So i have tried what everyone has suggested as well as reinstalling the app. When plugged in it works as it should. As soon as it get to wi-fi it drops to static purple.

I did a full reset and setup while wired, updated, restart on wifi for set up but it again fails to transfer settings to the streamer.

If anyone has any more suggestions or if i missed something, i am all ears. Thanks.

It seems like no matter what i try. I cannot get it off static purple OR complete the transfer settings section in the wifi setup, always fails.

I don’t know how far it is from your router, but if you put it really close (3 or 4 metres) so it’s a stonking strong signal, set up WiFi and then move it to where you want to use it, it should be ok.



Was your streamer working perfectly before the update?

I can give that a shot. Its about 8 - 10 feet away from it. 1gig down. wifi devices if capable get 900+, so the signal is strong.

My fear is. Once i do that and IF it works wont it just have issues streaming once i put it back? guess we can address that if we get there. Correct me if im wrong, on that part of the setup i am using the streamer as a network so in that case putting my tablet 1" away from it would be more ideal correct? since its transferring the wifi info from my tablet to the streamer. if so, i tried this and no luck

Yes worked perfectly. Got the notification for the update, updated and now its having issues. After the updated and the self restart is just sat on purple solid. When i do a factory reset it appears to be on the latest version of firmware.


1 Like

Interesting but ultimately frustrating to state the obvious. Sorry you’re having this issue. I had something similar in the past and the culprit ended up being network-related. So I went to the source since nothing was working with regard to the unit, itself.
Try disconnecting any Ethernet cables if applicable, as well as powering down your router and switch if you have the latter as well; the router for certain. Unplug, replug and let it power on/reboot. Then see if that helps after the first attempt or a few thereafter. I think it took me a couple of times, but it did the trick. I think I might even have closed the app from the background and reopened it from start when re-trying. Oh, and ensure your settngs are on wired or wifi, too, of course.
It looks like you’ve done most or all of these steps, but I wasn’t clear if you did any physical network restarts.

1 Like

Hey, thanks for the reply.

I will give this a shot. I did nothing with the physical network as it worked fine before and the update didnt mention anything about network updates etc… that i noticed.

Will give this a shot and reply. Thanks.

Here’s hoping it’s successful…

1 Like

Quick question. So it seems to be failing on the part where the streamer is set as its own network and the tablet i am using connects to the streamers local WIFI to transfer the wifi settings for the house.

in this case my house wifi shouldn’t have anything to do with this, correct?

I am going to try it anyways because why not, but just wanna make sure i understand as well.


Not certain that method will work. If it is on its own network, your tablet or phone needs to be ‘synced’ with the streamer. Sometime my phone goes to our whole-house network and it cannot and will not see the streamer. Once I switch it over it is fine. You say you’re using a tablet? What OS is it? I know some people have had issues using tablets…even iPads.

1 Like

Hello, I am using a samsung s7+ (android) I can give it a shot on another device and see what happens.

Just tried it with my phone (android Pixel3) and got a “Failed to send config: Failed_to_upload_credentials”