ND5 XS2 Problem Please Help!

My Naim ND5 XS2 is just blinking the Power LED Green in a sequence :4, 1, 2 (like **** * ** ). The logo is not lit. The App sees the unit on the network , but it does not show “Ready” therefore cannot receive any command. I unplugged and plugged few times , and it does the same. There is an audible relay click when plugging or unplugging. I cannot reset, as this unit can only be reset when it is ON (which seems to be absurd, as you want it reset when you have a problem). It has shown this symptom before, but before it would work after unplugging the power cord and plugging again. However, now I tried this few times and it does not restart, just blinking the green led in sequence as shown above. Please help , if anybody has encountered the same problem.

Have you tried unplugging, leaving for an hour or so or overnight then plugging back in?

I’m not sure what the error code sequence here signifies, perhaps @NeilS would know.

Also, you may want to read through this thread where a similar issue was experienced;

If it persists then I would suggest contacting your dealer.

Hi Dan,

Indeed, as Richard indicated, a problem like this was previously reported. However, in my case, the error code was 3-4-9. I provide an update and an additional observation that might be of interest / relevant.

I found, as I wrote previously, that leaving the unit powered down overnight, or for at least 30 mins, followed by power-up always solved the problem. However, the issue continued to occur sporadically – perhaps every few months. I didn’t send the unit back, until suddenly a couple of months back – some nine months after the problem first arose – the fault occurred several times in the space of a single week. I therefore bit the bullet and sent it back.

Last week the unit came back from Focal Naim (in Germany) after about a month, with no fault having been detected, extensive testing, reset etc. The firmware had been updated to V3.6.0 (5106). So far the unit is operating without a glitch, but with such an intermittent problem, only time will tell.

Now to an observation that may or may not be related. When streaming from Tidal, I found that very short tracks – as of a few seconds as one encounters from time to time – would cause streaming to stop and the only solution was to manually move to the next track. Damn annoying. I thought this was probably a tidal problem. However, I realised that the problem never occurred when streaming the same album via my MuSo (2nd G), or a UnitiQute 2, or directly from the Tidal app. And didn’t occur when my ND5 XS2 was slave to either of the aforementioned devices. So seems this was some problem with the ND5 XS2. I then began to wonder if the unresponsive state that the ND5 XS2 occasionally entered was somehow related. And whether using the ND5 SX2 as master and the UnitiQute & MuSo as slaves was somehow problematic. Do you also connect multiple streaming devices?

Interestingly, just this morning, I streamed the typically problematic St John Passion (Masaaki Suzuki) via my newly returned ND5 SX2 and to my surprise, the unit moved through all tracks without glitching. Luck? Or has the firmware update solved the problem? Or maybe the unit getting thrown around in transport? Or maybe the colour of the bishop’s underpants? I don’t know. But I will be keeping an eye on things.

As annoying as sporadic glitches are, I would recommend checking that you have the latest firmware, and if so, and then problem continues, then return it to Naim. Clearly the problem was not unique to my unit.

Good luck and I will be interested to know how things go. I will also update here in a month (or earlier) if the problem recurs.


I suspect that this may be the first time that the phrase “colour of the bishop’s underpants” has been seen in the Naim forum. Congratulations!




David, the colour of the bishops’ underpants has a lot to do with intermittent problems. If bishops wore underpants of a single colour, day in and out, let’s say purple, then problems such as periodic failure of ND5 Sx2 streamers would be a thing of the past. At least this is what I’m told. Apparently electronic failures are more likely to arise when the combined colour of the collective of bishops’ underpants, within a 50 km radius of said electronic device, approaches the colour pink. All best, Paul


I will have to take your word for it!

1 Like

Another possibility: something changed on the streaming service side, they may have fixed faulty file data or whatever.

I’m inclined to avoid bishops who flash their underpants about.
But if unfrocked clergy floats yer boat …

Fault code 412 means that the unit cannot communicate with the front panel button PCB.
I must admit that these newer units are not my forte, but I’m surprised that you are unable to reset the unit when it is in this state - have you tried a very long press of the reset button via the little key?
Does the LED on the front panel change colour when you long press the reset?


Hi NeilS,
Reset is definitely not possible during this condition, I tried again after seeing your post. However, following your suggestion about what the code 421 means , I removed the unit top cover (not easy, as there is a hidden screw which require a long thin screwdriver) and I just moved slighty and pushed all connectors that I could see between inside boards. Following this - surprise! When powered again, my Naim started normally and it now works well. Hopefully this fixed it - some loose connection was causing this malfunction … Thank you for your help.


Hi Richard.Dane, I tried keeping it off power over night and then re-powered next morning , however nothing changed. NeilS posted that my error code 412 means misscommunication from an internal board. Following this hint, I removed the unit’s top cover (not easy, as there is a hidden screw which require a long thin special screwdriver which I do not have) and I just moved slighty and pushed all connectors that I could see between inside boards. Following this - surprise! When powered again, my Naim started normally and it now works well. Hopefully this fixed it - some loose connection was causing this malfunction. I live in Australia, and just to have somebody at a service center to look at it they charge AUD200! Then surely they would have found some faulty board - so hopefully a significant expense was avoided (unless there is a real intermitent fault which will manifest again).
My experience with this NAIM was not very happy. While it sounds fantastic, I already had a power board failure (in warranty), then all kind of hiccups when upgrading firmware . Also the apps at times do not communicate with the Naim unit. And this lack of remote, and the fact that it cannot be reset unless it is operating normally (!!!) … Anyway, today everything works, so I am happy for now.


Thanks for the update Dan. I just hope that when you opened it up you took proper ESD precautions, or at least wore an ESD strap - it’s critical with chipset populated boards as otherwise you may have component failures down the line. Still, good to hear it was probably a ribbon connector that needed re-seating.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.