ND555 Software Upgrade Issue

Is anyone else having trouble with the 3.6 software upgrade?

My system is completely non-functional after it (just sold TT, so only stream and digital file serve).

I have followed all the steps in the known issues link, but the the issue is clearly software function issue within in the ND555…
When I power up the nd555 from completely off (both power sources off for a minute), it powers up initially per normal, but takes a long time to join the network, and as soon as it joins the network, the green Naim logo / light goes off.
The main screen stays on, but it won’t respond to any buttons on the right of the ND555 fascia being pressed, nor will it even connect to the remote (have tried re-pairing), nor is the app picking up the room.

I have tried powering up from scratch many times in the hope that it right itself, but alas not.

Via the app, no room is accessible, the things that are accessible:
Output settings, Other settings and Check for updates, with firmware version showing as attached.

You should read it, some have resolved the issues.

I would try to delete and install again the app. If it doesn’t work, try a factory reset ( not a reboot). Instructions in the thread just above.

Thanks FR, I’d done the app reinstall, but not the factory reset, and it’s that that did the job (as annoying as it is to re-setup everything in the app).

For the record here - factory reset is holding down the play and input buttons on the ND555 while turning power source(s) on, and release buttons when the screen cones on.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.