NDX 2 System Automation

Hello all,

I recently exchanged my ND5 XS2 for a NDX 2. To me, with my Supernait 3, it is a better match.

I do have a question with the System Automation that I can’t seem to figure out.

I connected the NDX 2 to the Supernait 3 with a 3.5 mm cable. The volume aspect of System Automation works fine, I can control the Supernait 3’s volume with the NDX 2 remote.

Also, when I select internet radio on the Naim app the input on the Supernait 3 switches to Streamer.

So, all good so far…except for one thing:

When I select Tidal on the Naim App the Supernait 3 input does not change to Streamer.

It is not a big problem, as all I really have to do is get up off my chair and move my creaky knees. But if I could avoid the walk to the Supernait 3 to avoid switching output that would be great. Also, my OCD dictates that I answer this problem. Does anybody know why it is doing that or how to fix it?

Many thanks in advance.

There is only the one input here, the one you connect the NDX2 to on the SN. The app controls the source from the NDX2 , which goes through the one cable and plug to the SN. I use the CD input in my case.

1 Like

thanks mike, but yes that is done. I have one Din cable going from the back of the NDX 2 to the back of the SN3 called Stream In. That is fine. As I said, when I select internet radio on the Naim App, the SN3 automatically changes to Streamer input. The problem is that when I select Tidal on the Naim app, it does not change the SN3 to the Streamer input (the SN3 simply stays on the input it was on lastly, phono for example).

I suspect it is a problem with Tidal? Because the Tidal input or icon also does not appear on the screen of the NDX2 even though the Tidal input is enabled in the Settings of the Naim app.

1 Like

When I look at the 5 inch NDX2 screen it does not show the Tidal input (or icon) even though that Tidal input is enabled in Settings. (Strangely, the Tidal icon DOES appear on the main screen user interface of the Naim app on my iPad.) It is simply not appearing on the 5 inch Input screen of the NDX2.

This is normal though annoying. There is only Spotify on the unit screen and it cannot be removed nor replaced by Tidal.

As for your original problem, this works for me with Qobuz on the 252. I.e. I use the app to switch to cd input, then I go to Qobuz on the home screen and when I start to play something it switches to the streamer input on the 252 (as configured under system automation in the app Settings)

I don’t think the app can change the input setting on the SN, you just use one input from the NDX2 for streaming. If you change inputs on the SN2, you need to switch it back to the streamer input, the app won’t do that.

I could be wrong, but I believe you just have to program the Tidal input on the preamp, under system automation. I was having the same problem when I first got my NDS/SN2.

David, how do I do that?

You access the preamp input settings from the NDX2 window using the remote. The button with the wrench on it brings up the right menu, then scroll down to system automation, then scroll to preamp.
Under preamp, there’s selections for what source uses which input.
And you have to push exit when yer done to save the changes.
I’m doing this from memory, at 2 am; so try it and let me know if it’s not clear and I’ll check it phycically in the morning. But I think you’ll see what’s going on when you get there.
Best of luck.


1 Like

Thanks David, but the settings menu on my NDX 2 screen does not have a System Automation menu.

The Naim App has the System Automation menu but no was to add Tidal.

I suspect this is a Naim / Tidal integration problem.

Again, this problem (and my problem of the SN3 not switching input to Streaming when Tidal is connected despite System Automation being turned on) are not big problems, they are easily solvable by getting up off the couch and pressing the buttons myself. It’s just that it seems a little inelegant and unpolished for a streamer in this price range.

If anybody has any solutions (IF a solution exists) I would appreciate hearing from you.

I’ve been having similar issues. Sometimes starting a upnp stream will get the SN3 to switch to stream and sometimes it won’t. It’s very strange. As you say not really important in the grand scheme but it would be good if it worked consistently. My solution, which is a bit rubbish because it involves another remote, is to use the SN3 remote in pre mode and press 3. At least is saves us getting off our bottoms.

HH, yeah, that two remote solution is all I can think of too until this issue (hopefully) is resolved by way of update. Preferable not to have two other remotes lying around, but I guess it is what it is for the time being.

I know. Then there is the telly remote, the Virgin remote and the iPhone. It’s all a bit of a mess.

I think Dave was giving you instructions for setting up System Automation on the old Naim streamers which was done via the remote control/front panel display. With your NDX2 you use the Naim app, as you have discovered already.

1 Like

Yes, you’re right about that. Sorry, I didn’t know the process had changed with the new streamers.

Neither of which works. Disappointing that Naim hasn’t sorted this out yet.

I shall email them and see if they can sort it out. Like you say, it should just work. Press upnp, Tidal or Qobuz, hit play and it should switch to the stream input.

I think it does work. If I’m playing from the NAT01 or LP12 and select that input in the app (which won’t change anything, of course), then select Qobuz or Server, the preamp will switch to that input when I touch a play command in the app. That seems quite logical to me.

Clive, this weird but I think I understand what’s happening now. I switched to phono on the app. Then I chose a Qobuz album and when I pressed play it switched to the stream input. The same worked for upnp from the Qnap.

Next I physically pressed the phono button on the Supernait. When I chose a Qobuz album and pressed play, it didn’t switch.

So maybe that’s it - do everything on the app and it works as intended, but if you get your sticky mitts on the amplifier it all goes wrong.

Nigel, if you press phono on the remote or the preamp, you then need to select it (the phono input) on the app before selecting Qobuz or upnp on the app. It’s like you need to tell the app where it’s starting from.