NDX and Mu-So can't be found in App

Hi there, I have the following problem:

NDX: cannot be found by the app. Through the remote control I am able to connect it to uPnP en listen to the music. But no Tidal, no Iradio.
Mu-So: can b found on the App but no Iradio e.g.

Internet is working since I am workin on a computer.

Any suggestions what the problem is here? I live in the Netherlands.

If you have no Tidal, the NDX isn’t connected to the internet. Turn it off. Turn off the router. Turn on the router. Let it boot. Turn on the NDX.

I don’t know if it’s the same issue but my Mu-so1 and Qb1 both died today. They wouldn’t play anything, then said another client was connected. They kept disappearing off the app so I did a factory reset. That worked but they still won’t connect if I try to play anything. They just hang while connecting and then disappear :slightly_frowning_face:


1 Like

I was wondering if Naim had done a software update that has bricked them. Unfortunately, when try to check the app crashes.

The wired NDS is fine.

Yep, my Muso1 and Qb1 both died this morning. Won’t play anything either. Keep disappearing off the app. Same as Keith and OP.

Same issue here too :pensive:

Uh oh, I suspect Naim have done a bad update and failed to properly regression test legacy products. Can you advise us @Richard.Dane?

1 Like

Naim last updated the app about a month ago. There hasn’t been a 1st gen. streamer update for ages, and if you had done it, you would know because it’s a manual update. I think you need to look elsewhere.

1 Like

KRM, if the members aren’t able to help out then I would suggest contacting Naim support.

Thanks Richard, will do but might give it a while to see if it fixes itself.

This is affecting all devices including NC. See the Vtuner thread which has a load of similar problems today.

I did that several time but that did not do the trick

We use the new version of the App everyday. Could listen to the music until today. Seems that overnight something has changed.

There does seem to be something odd going on with iRadio. Probably another vTuner issue.

Thanks Peter,

Yes, the vTuner thread looks like the same issue. So this time, they have managed to screw the whole device rather than just radio playback?!

I did manage to get UPnP working briefly but it wouldn’t work after I tried to play the radio.


Yep, I’m having problems, have been all morning. No radio on either of my Musos, both 1st gen.
Anyone had a fix yet?

So, l can use Roon via Airplay and perhaps both devices will be fine unless/until I poison them with iRadio :slightly_smiling_face:

So I guess I’ll wait for it get fixed. It’s Easter school holiday so, presumably the guy at vTuner who keeps it going has gone on holiday again

Vtuner only affects iradio, not anything else, so if you have other problems (eg tidal or the Naim app) it’s nothing to do with Vtuner.

That’s strange my Mu-so gen 1 died today as well, I’ve tried everything, it won’t connect.

1st Gen Muso and Qbs all fallen over. But ND5XS2 is fine - so does feel like a Naim issue