NDX problem with Linksys mesh

Hey guys. I hope you can help. I am having problem finding my NAS (Synology) through Naim App on iPhone. Everything was working well until I upgrade(?) the router from Airport Extreme to Linksys (Mesh wifi). I am worrying it is a compatibility issue because I saw another post with similar issue using Linksys. I have a 3 unit Linksys set up with NDX and Synology connected to a satellite unit by Lan cable.

Any idea please.

try to restart your router, then lindsky, ndx and nas. It can work.

As FR says but power up the NDX last, after the NAS.

Thanks guys. I have tried almost every way to reboot the system, including powering off all devices, disconnect the power cables and also the connections. But the App just can’t see the Synology.

Everything is alright apart from this. The App can play iradio, Spotify and etc.,just not the Synology! Sad!

Any clue?

So the problem then is the NDX can’t see the NAS… I assume the ‘app’ can see the nas okay? If so then the network connection from ‘app’ to the nas is okay but not nas to NDX. So describe the network setup from nas to the ndx? Also, I assume, you’ve tried music selection from your nas directly on the NDX? Does that work?

Yes, worth checking if the NDX can see the NAS by using the remote. The Media server should be viewable from the from panel.

Thanks guys for advise. Actually the nas can be seen and be controlled by ndx but only through its hard buttons. The App just can’t see the nas, no matter how I tried. I have tried resetting the App, deleting and reloading it from App Store but still in vain.

My connection:

Router>WiFi>router>lan switch>nas(Synology)Ethernet >ndx Ethernet

This setting was working perfectly well until I switch the routers from Apple to Linksys.

It is quite likely the problem with Linksys, which is a new set of router with 3 units working together for a mesh Wi-Fi network.

Two routers? Really? Why? If so then I’m not surprised!

Hmm, sounds like suspect Wi-fi product… one has to be sometimes cautious with some of these consumer products as their software can trip up applications using the home network.
Check to see if there any setting such as ‘allow L2 discovery’ or ‘disable IGMP snooping’ or ‘allow multicast’ on your Wifi access point management tool
Also check every device is in the same subnet… so if a class c network all the IP addresses have the same first three octets… ie 192.168.1.
And the subnet mask is or /24

Finally your chain had two routers … can you check you really mean that…(some people use the term network router incorrectly and really mean something else… it’s important to get right as routers have very specific functions and need to be in the right part of the home network). You must only have ONE router in 99.9999% of valid home network setups, and that is between the internet and your home network

Ie internet -> router -> home network switch -> -> streamer/NAS/Wifi access point(s)

It’s worth remembering many home routers have the switch built in, and the Wifi access point connected to that internal switch. Often these routers then expose four separate switch ports for home network connectivity.

Hi Simon, I should have made it clearer at the outset. I actually have one router at the entry point. The second one is a repeater/extender in function, where the nas and ndx are connected to by cables.

All supporting one single Wi-Fi network in home.

With your advise, I would check the router settings to see if there are options.

you should buy a single cheap netgear or tp link switch, like netgear gs105, connect it to your router and ndx and nas on this switch.
It’s a common set up that works.

Ok, just make sure the second router is not doing any routing type functions such as network address translating etc. I am curious as to why it’s referred to as a router if it’s not routing.

So the second unit is NOT a router then… it’s wirelessly repeating the wifi from your main router - yes?

Which linksys mesh product is it? Some of the linksys units specify a router at the source and some a plain repeater.

Yes. You are right that the second one is not functioning as a router but a repeater of the first one.
This is a Linksys Velop mesh system with 3 node units. I just discovered another post in this forum where the same problem of mine was reported after setting up with Linksys Velop.

Not sure whether it is a software problem of Linksys.

Sounds like it… see my earlier post. Alas I am not sure you can get your product to act as a regular multi AP setup providing an ESSID, with the AP backhauls connected to a switch, or even the third AP via a wireless backhaul, I am fairly confident that would work reliably, performant and well.

I tried to see what standards the Linksys Velop product uses, and see if it supports 802.11s, the mesh network standard, but as far as I can see it’s simply a consumer propriety product so there could be many interoperability unknowns… is it too late to get your money back?

Hi Simon. That would be ideal getting the money back. I am talking to the shop now for the money or a suitable router replacement that could work with my system.

Are you using the wifi on the main router? If so turn it off. Connect lan cable from first linksys to the router. So only using linksys units for the wifi.

Tried but still not working. Apart from failing to see ndx on iPhone app( it’s only the App, not the hard button of ndx, meaning that I can see and control through hard button)everything else is perfectly ok.

I am waiting for response from the dealer.

Anyone got similar experience?

linsky velop on image specs. Perhaps the answer is in the picture, the specs…

What exactly. Any pointer please.