Nova setup issues

Good morning everyone. I have had my Nova for a couple of weeks now. During this time I have listened to the sound burn in (a slightly surprising up and down process including one day when the bass virtually disappeared and I thought I had broken it!) to the point that it is everything I hoped for and more. I have also been learning how all the many functions work and getting it (and the app) set up just the way I want.

I do, however, have one outstanding issue. I have ripped virtually all of my cd’s onto my computer using dbPoweramp. I started by transferring a few of them onto an old (smallish) usb drive. All worked well - the files appeared on the USB input without cover art AND on the Server input complete with cover art. I did the same on an SD card with the same happy result. Finally I filled a much larger usb stick with lots of music. (A 128gb drive, formatted to 119gb, loaded with 117gb of music.) This time, however, it appeared as a usb drive without art but there was no sign of it as a server. I tried both the front and back usb ports and I tried deleting a quarter of the music. All to no avail. Do any of you have experience with this? Someone has told me that if I buy an external SSD that it will work. I am happy to do this if it fixes my problem but don’t want to waste the money if it won’t.

If anyone can advise me on this I will be most grateful. Thanks.

How long did you wait? With lots of files, it may just be taking time to scan the metadata in the files for the server input (because this is the difference between choosing USB and server inputs: the USB shows the raw folder and file structure, the server input is displayed based on the files’ metadata)

It’s been plugged in for days at a time. But with the smaller drive you can see it flashing after it is inserted as it sorts things out. The bigger one flashes a couple of times then stops.

I see. Assuming that the file system on the large disk does not have any errors, I don’t have any other ideas. But I haven’t used the USB option much, and not with a large drive and many files at all. I’m afraid we need someone with more experience.

Is the larger USB formatted with the same filesystem, just a thought ?

Hi Pieto. I’ve actually re-formatted the usb stick a short while ago. Now loading about 90gb of music onto it. I’ll let you know what happens.

Drives filled very close to their maximum capacity often don’t work properly. Try leaving at least 10 or 15% of the capacity empty and see if it helps.

Hmmm… so I’ve reformatted the USB stick - loaded about 90gb of music onto it this time - same result. :frowning:

I’d be grateful for any suggestions. I’d particularly like to hear from any Nova/Star/Atom owners who have been through the same process.

A USB stick is a small SSD! I can’t see why it shouldn’t work, I’ve never had a problem with memory sticks myself.

One more thing you could try: remove the USB drive, clear the cache in the Naim app, turn off the streamer and unplug it for half an hour.
Then restart the streamer and insert the USB stick.

What file system are you formatting the USB stick?
I believe the stick must be formatted as FAT or FAT32 for music streaming on Naim.

Fat32 is what you need to use.

Thanks. Do you know what new drives come formatted in? My micro sd card and old USB drive seem to work OK. It might be easier for me to buy a new USB stick or external ssd if they will work as they come.

I expect it would be ntfs, that’s certainly suggested by the Samsung website.

Reformatting to Fat32 is straightforward with the correct software.

If the drive was incorrectly formatted I think you would have had problems reading the files in the USB input as well as elsewhere so I suspect that is not your problem.
I find that memory sticks work out of the box but there’s nothing to lose by trying a re-format, other than that it will wipe off the data and you will need to reload it.

My previous post was based on the idea that the streamer may have cached metadata from a previous drive, and become confused by the introduction of one or more new drives (possibly containing some of the same music files as the previous drive?) thus powering down and clearing the cache might help….but this is just speculation.

Is the Nova support page wrong? Says FAT32, NTFS, or HFS

Fat32 works with all Naim streamers, if you are looking for cross compatibility.

Ok, but the OP has a Nova. I guess that it should work with NTFS. But of course reformatting is a good way to rule out certain issues

1 Like

I don’t know how my usb stick was formatted before I reformatted it. But afterwards it was in FATex. On doing a bit of research I have read that FAT32 can only be used on drives up to 32gb. So maybe I can’t use this on my 128gb stick?

From robert_h’s post a bit further up:

I don’t have that particular experience with my Star. I have one of these Aluminium Samsung sticks, it’s formatted on NFTS, and then the Star did the futher folder config itself. Funny enough I have 148 GB on a 256 GB which officially shouldn’t work, but it does. When my Uniti arrived at the start of Lockdown #1, I had already 30% ripped using EAC. When I continued ripping with the Star, I quickly noticed I needed to rename every EAC defined cover art file to ‘coverfront’ to make them show up on the display. Not sure if that helps. Since the Nova doesn’t do any ripping itself, the way that it accesses a USB may be entirely different from a Star.