Nova-streamer not responding

It happens occasionally and it’s frustrating but nothing to worry about.

Would you know why?

computers, technology, software, multiple vendors, coding error, hardware failure, third party vendors, etc. etc. the problem lies within

1 Like

Sorry, I can’t be specific but merely responded to say that it happens less frequently than the need to restart your home computer(usually) and to put your mind at ease.

I recently purchased an Ndx2 to go with my Naim system and have problems. The main issues are “Streamer not responding” and “Leo server sent an error response 429”. It also sometimes cant find the room. It seems the Naim app isn’t “talking” to the streamer. The wifi signal is showing -43dbm strength and there are no drop outs when music is actually playing but when you go to select music on the app one of these messages occurs.

The streamer is connected ethernet into a Cisco box and BT Disc (a temporary measure until I can run it wired ethernet or optical into the router which is at the front of the house)

Any help here is very much appreciated. I’ve got a great system and atm can’t use it!

Please help!

Thanks in advance,

If you search the forum for Leo Server you will find quite many posts. I believe that rebooting everything tends to solve it, like here:

I would recommend that you go through the whole list of usual recommendation:

  • Ensure you have the latest app
  • If you use Tidal, log out of it in the Naim app and back in
  • Turn off the NDX2 and pull the plug. Leave for 30 minutes or so.
  • In the meantime turn off the router and also leave a while just to be sure.
  • Turn on router and wait until it is fully up (and your other devices on the network do work again)
  • Power on the NDX2
  • Try if it works now

Also ensure that you have the latest firmware and do the update if you don’t


Ok thank you I will try these suggestions


Good luck, let us know how it goes


I tried these suggestions. Did a firmware upgrade too so now have the latest version.

The unit worked fine for around 20 mins then throws up the same issues. I noticed a dropout in the wifi at the time. However, what is a bit bizarre is that these issues propped up prior to this without the wifi dropping out, so now I’m confused to say the least.

What is also confusing, is that a Yamaha streamer that we have also playing last night for almost 4 hours experienced no issues at all.

Any guidance is very much appreciated.

Kind regards,

Can you plug in an Ethernet cable temporarily for testing, even a long one? Just to narrow down whether it’s related to the wifi or occurring anyway even when cabled

Hi there,

The unit is wired ethernet. Plugged the unit this evening back into the Naim system after doing the firmware upgrade.

Worked fine for about 20 mins then low and behold, same issues. No issues finding the room now, but always the same issues:

Leo server sent an error response 429
Streamer not responding

Not sure what to try now, but after £25,000 spent its soul destroying to say the least

Amy help is very much appreciated

Kind regards,

I would suggest you contact your dealer or else Naim support.

Is it wired to the BT disc or to the router please?

I found that force stopping the app sorts out the problems.


In answer to all. Thanks for replying. Its plugged into the disc atm, but experienced the same issues plugged into the router but seemingly not quite as often but still happens.

In answer to “nova” what do you mean by force please?

Kind regards,


Naim have been contacted and have made some suggestions that haven’t worked as yet.


If you go into the app settings on your tablet you can force stop the naim app. I found this to work. Also just use your tablet for the naim app only. I found when using my tablet for anything else the problem happens again. You can also uninstall and reinstall the app as I found this works as well.

You don’t need to go into settings to force stop an app in IOS. It depends on whether you are on current IOS software and hardware or not, but in principle you either swipe the app upwards or double click the home button if you have a home button, then you can swipe away upwards the app you want to stop and then tap the Home Screen or press the home button if you have one. Then you can restart the app by just selecting it. It takes just a couple of seconds to do.

Can I get some advice on how to force stop the Naim app please?

Kind Regards,

On iOS:

On Android it differs between devices, but essentially open the overview of running apps (e.g., swipe up from the bottom, but depends) and swipe the app up/left/right (depends) or tap the X button if those are shown.

Alternatively, go to the phone Settings > Apps, go to the app and tap the close (or force stop, depends) button there. (Works on both iOS and Android, one way or other)