Problems with qobuz via BubbleUPnPServer?


since some days I have problems with streaming music from qobuz via the BubbleUPnPServer (installed on my Synology NAS) to my superuniti. Music plays fine for some tracks when suddenly the stream stops. I have to start the track again (or the next one). This does not happen every time. Today I have listened to 3 albums fine and a 4th one broke in several tracks. Some days ago I already had such a problem. Before that I usually did not have any issue with qobuz.

Are here other users who are using BubbleUPnPServer and have similar problems since some days?

I really do not know what could have changed in my setup. So if others have the same issues, it is probably a problem on qobuz’ server side?

Thank you

Hi Gert,

I’m using Bubbleupnp server on a Synology 214+ streaming to a mk1 NDX. Wired with Ethernet and an iPad running Lumin as a controller and no issues whatsoever.

Your problems describe my issues with the Naim app running Tidal on the NDX exactly and is the reason for going to Bubble in the first place after finding no answers.

Try the simple fixes first. Reboot your router, NAS and player. Power down for 5 minutes then retry.

Thanks for your answer. I have begun with stopping and restarting the BubbleUPnP server. Because the problems only occur from time to time, it is hard to tell if this did fix something or not. I have to test it the next days.

The NAS and superuniti are wired to the LAN, so it is not a WIFI issue. I am happy that I can say this since a few years for sure. :slight_smile:

Same problem here Gert.
I run the BubbleUPnP app on my android tablet in order to play Qobuz on my N272. On my NAS I have Minimserver running.
With the BubbleUPnP app I have exactly the same problem as you have with the server. I have an -old- Qobuz Sublime subscription.

Hello Maarten,

so you are not using the BubbleUPnPServer but only the bubble app? If so, minimserver and your whole NAS should not be involved in the playback of qobuz music.

Is the music stopping while a track is playing? Or does one track finish correctly but the next one does not start? If it stops while a track is playing, the problem seems to be the same as in my case. But if it is a track advancing problem this might be because your tablet turns off to standby and the bubble app does not recognize when the current track is finished, so that the app cannot tell the streamer which track to play next.

Like Maarten I use the BubbleUPNP app (and excellent it is) but not the server and I am using Qobuz without issues on a regular basis.
I think the advice to switch off your modem and separate router if you have one (I have a sub-net) too. Try “unplugging” the modem as well leaving it off for at least 20 minutes. Also closedown BubbleUPNP on the tablet which I presume you are using as well and the tablet too (remember this runs on wi-fi even if everything else is wired).
Re-boot your NAS which supports BubbleUPNP server.
I suggest you switch off the renderer (SuperUniti) as well, unplug it and press the power button to discharge the memory ( I had a (very) occasional problem with a Denon streamer that got it knickers in a twist and this always cleared it).

I also usually run my tablet on charge - I think I saw something about this - to give stable power. (ASDA sells a long charging cable which is useful).

Resisting the temptation to switch stuff back on is the hardest part and wait for everything to stabilise again when you do switch-on…

I run Qobuz on my Synology NAS via BubbleUPnP Server, and it’s been faultless. Maybe it’s a geographical thing? I’m in the U.K.

Thanks Gert,

You are right I am suffering from the track advancing problem, so different from yours.
I addressed once more the settings in BubbleUPnP and my tablet.
Wish you success in resolving your issues.


So I will try to power off and reboot the involved devices. But I do not understand why you need to keep them turned off for more than just some seconds? The RAM will be cleared and all processes will be restartet from scratch after such a power down. I think there is no need to wait minutes. Or do I overlook something?

btw. my app is the lumin iOS app which I need to restart anyway several times a day because it hangs very often in combination with bubble upnp server.

BUT, very important for all qobuz users: It does not seem to be a qobuz problem. At least a 2 hours stream from mixcloud (pushed into the bubble upnp server playlist via the bubble upnp app) did show the same symptom after one hour and a few minutes: the music did stop but the control app showed the track as still playing.

So will do some restarts. But as want to know the culprit I will do it one device after another and check each result.

Make sure that the bubble app is taken out of the power management of android. You will find some hints for this e.g. in the threema messenger FAQ, that suffers from this power saving, too.

I run Bubble Server on a RasPi and it works flawlessly with Bubble App on Android.

I’ve been running Bubble server on my QNAP NAS and using the Bubble App On Android as well as the Kazoo app on my iPhone To stream Tidal and Qobuz. It sounds better then streaming directly to the SuperUniti with Naim app. However I also get the odd glitch, like when a different track starts plying then what I selected. Or the last album I played keeps playing for hours after I switch to another input on the SuperUniti. Even if I clear the playlist. The only way to fix this is to stop the Bubble server from running on the NAS.

Yes, that’s the trouble with these unsupported workarounds. Like you, I found that BubbleUPnP server sometimes had a mind of its own. Now using Roon, which I find achieves the same thing with Tidal sound quality, but is much better behaved.

1 Like

It is the Modem connection to the ISP that you want to reset and try to trigger the ISP end to do a reset. Just switching on/off will reset your modem but not necessarily the ISP connection and it might pick up the same connection again. Increasing the wait is to try to overcome this issue. Of course you could ring your ISP and ask them to do a reset at their end.

PS I came across this article about resetting Internet fibre links - it is a very different issue but gives a clue about potential issues etc https://www.ispreviewDOTcoDOTuk/index.php/2018/02/ability-reset-openreach-fttc-broadband-dlm-profiles-arrives.html

I have just installed BubbleUPnP Server (not used it before) and it is streaming from Qobuz without any issues.
During the installation I noted that a new version was released on the 19th November 2019 and that this new version required Java 8 and not Java 7 as previous versions. I wondered as this seems to be a recent issue to you if you might be using the updated version still with Java 7. This might perhaps still work but not properly.
Just an option for you to investigate.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

I asked Mr Dane to reopen this thread…

Bubbleupnp Server installation fails on my Raspberry Pi 3, running Rasbian v8. The install gets a fair way through then terminates with this message:

  inflating: ffmpeg                  
  inflating: ffprobe                 
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 102
Errors were encountered while processing:

Once the install has hit this step Bubble isn’t available. I’ve tried numerous suggestions by searching for the error, including complete forced removal and retrying from scratch. Am I missing something? Java is installed.

Any suggestions to get it installed to run Bubbleupnp would be welcome.

Ist the Rasberry Pi 3 linux 32 bit or 64bit? Maybe you have got the wrong installation files?

Otherwise I recommend to ask the Bubble-Developer in the XDA-forum as mentioned on his website.

Is there a particular reason for using Raspbian v8? If not, I would strongly recommend Raspbian Buster Lite, which is v10.

Raspbian is based on the Debian version of Linux, so best to follow the guides for that -

However, in short -

i) Connect the Raspberry Pi to the Internet (if only for the install).
ii) Check Java is installed by issuing the command -

java --version

iii) If not, to install Java -

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install openjdk-8-jre-headless

iv) Download BubbleUPnP Server to the Pi -


v) Install BubbleUPnP -

sudo dpkg -i bubbleupnpserver_0.9-2_all.deb

Connect to BubbleUPnP by entering the IP address of the Pi into your browser using a PC, Mac, tablet, etc., using the following format -

Substitute the address with that of your Raspberry Pi

1 Like