QNAP NAS waking up too often

Please excuse the dopeyness of this question. I’ve used a Qnap NAS for many years to hold my music files, which are served using Asset.

The NAS goes to sleep and wakes up when I activate upnp on a streamer. But for some reason the NAS will wake up and start clonking about at random times, say early in the morning when no music has been played since the night before. In fact, it spends more time awake than asleep.

I suspect it’s running things that don’t need running; I turned lots of things off in the past but there may be things running that I could switch off.

Here is a picture of its App Centre to show what’s running. Any advice on what to switch off would be great, and anything about power settings etc. I really only want the NAS on when it’s playing music. Thanks.

I have been using a QNAP NAS for about 6 years and over the years I have got up at night and it’s been chugging away. I just assumed it was part of its job updating files and tidying up.

I’ve never had a piece of kit where there were so many software updates.

I would start with disabling the download station and see if this resolves the issue, you probably don’t use it anyway unless installing an app, downloading bit torrents etc

I have/had a similar problem with my Synology.
It was waking up to all sorts of on line broadcasting acivity, this can be a whole long list of hello, bonjour or similar services including NTP, some active Synology packages & third-party packages. Some prevent a NAS from hibernating or wake it up from hibernation mode from time to time.

I compiled a list that takes up two pages of notes.
First thing I did was uninstall any app included with the Synology package that I was not using that Synology allowed to be uninstalled.
I also disabled or changed settings of some of the NAS services that I had ID’d as liable to cause wake ups. These all helped but did not stop wale ups for what appeared to be random & no reason.

I found the most effective that reduced wake ups to just a few (2 to 5) per 24 hours when the NAS was not in use, was to turn off SMB (un check the tick box)
With SMB off the NAS still wakes up on control point command (iPad to Asset UPnP) & full control of iPad/Asset for normal streaming.
In my case I only need SMB to be on when I upload a new album,
It just a few extra seconds to wake the NAS to turn SMB on (& off when finished) when a new album(s) are loaded.

Why not have a look in the Power options and setup a Shutdown/Startup time, I have mine shutting down @ 01:15 and restarting around the time we get up

1 Like

As a matter of interest, what are the pros / cons of shutdown…besides saving disk activity / wear?

@HungryHalibut you raise an interesting issue (definitely not a dopey one). I’ve had a QNAP nas for a decade however, since it sits on a shelf under open stairs, away from system, I have never paid much attention. It ain’t broke - yet, but needs replacing, so have left well alone.
Quick search on web, brings up same issue you raise on both qnap forum and qnap’s own web site.
Nigel, you will know the forum rules perhaps more readily than I do, if I am allowed to link to those sites, I have kept the details and can post. In the meantime there seems to be some issues with syslog, the running of rsyslogd process and having disk standby mode enabled. I have never set any of those, so I’m in the dark.

edit - there are also a few you tube vids from QNAP (and others) which may be worth a look

I have my QNAP NAS to power off at 2200 and power on at 1000. It takes a bloody age to boot up so WOL isn’t an option.

Hi @sound-hound’ really depends what your NAS is used for.
Its widely accepted that leaving HDD’s powered on all the time is better for disk life than frequent short hibernations & disk spin ups typical of a busy home multi purpose NAS.
However a typical audio only NAS is will be infrequent use & should benifit in running/nonrunning total disk life.
Its really a question of balance & personal preferences.

Other benifits are power consuption. My 2 bay Synology uses 22.64W (running) & 9.12W (Hibernation). Some NAS have a deep sleep mode that reduces power even lower. Obviously the more disk bays the NAS has means higher power consumption.
Other stuff such as noise & flashing lights are reduced or stopped during hibernation.

1 Like

Mine is running off and on, I don’t think it ever really sleeps since it’s performing various tasks throughout the day. That said, it’s situated around the corner from my hifi and I don’t hear it or notice it.

That’s a nice idea, but as others have said, it takes an age to boot up. What I’m really looking for is to get it sleep. I’m very much hoping that someone will look at my photo and say ‘ah, turn off X and it will behave as you’d like’. Maybe I wish for too much!

I have of course searched online, but it’s all so bloomin’ technical.

1 Like

I’ve spotted that @Suedkiez responded to a post a month or so ago on a Roon forum along the lines of a QNAP not sleeping. I recall he is not such a frequent visitor or perhaps poster here, in recent times. However maybe he sees this and will be able to offer some insight.
IIUC you are using an iMac HH? The discussion I found related to the NAS being kept awake by Samba running. It seems to be necessary when running or rather accessing from a Win PC The caution was that changing the configuration might be the answer, however as he suggests, if you have to ask what Simba is, best leave alone. I for one, don’t know the answer to that question!

One is a dance, the other is a fictional lion.


Have you looked in System Status and Resource Monitor, either of which might help you to narrow down what keeps the NAS active?

My Synology used to run the fan almost constantly despite the NAS often being inactive. Adjusting the fan setting reduced its running time drastically. I previously thought this was the hard drive spinning up needlessly but it was only the fan. Not sure if QNAP has similar issues, but maybe worth investigating.

Hi @sound-hound, though I am not much writing these times, I have email notifications enabled in case I can do anything :slight_smile:

@HungryHalibut (nice to see you back :slight_smile: ), indeed I remember that discussion on the Roon forum that sound-hound mentioned. There were two things:

  1. The HD Station software that provides multimedia features (IIRC including the built-in DLNA server as well as audio/video transcoding, video playback (for those QNAPs that have an HDMI output)) prevents disk sleeping.
  2. When googling I found many people mentioning that configuring “Enable file service for Microsoft networking” in the QNAP Control Center (i.e., file sharing with the Windows SMB protocol, implemented by Samba on Linux/QNAP) prevented the QNAP (or just its disks, I am not sure anymore) going to sleep.
  • I didn’t look into it in detail, but it wouldn’t surprise me if running server software does that, as nobody would be able to access a file share on the QNAP if it goes to sleep.
  • Or it may just be background activity by Samba (as a server process, it most likely does some regular logging and stuff like that) that might never give the disks enough time-out to actually enter sleep.
  • In any case this is certainly a topic that comes up on the QNAP forums.

Not sure if issues, but the QNAP also has default fan settings that can be adjusted (taking care that it doesn’t overheat). The default is probably targeting more typical use as an actual file server that is under more constant load.

I’ve never paid attention to this stuff before. Looking at my resource monitor system processes are the primary user of resources on my QNAP with hal_daemon and chartreq.cgi using the most of that allocation. The highest I’ve seen is 18% and it fluctuates to a low of 4% when I’m watching it. I don’t see any fan settings to adjust. Power management is not set to power down, there’s a EuP Mode configuration that is not enabled, not sure what that is. Asset, Minimserver, and Container Station (for bubblesoft), register less than 1% of usage. I’ve disabled some apps as I wanted to streamline processes as much as possible.

A NAS is designed to be run 24/7 and that is how I run mine.

1 Like

Hi @Suedkiez thank you for your response and good to see you here.

1 Like

A year or more ago, I posted a thread Synology v QNAP, since my QNAP needed (and still does) replacing. Peps have their favourites, but no clear answer emerged. Good advice, was what you are used to, when replacing. Like so many incidents these days, the old rule no doubt applies when using a NAS. User around 80% use 20% of the units capabilities. Even in simplest form a NAS iiuc has significant capability and @spile comment reflects that.
My own conclusion so far, set power off if the units is required to be quiet.
It doesn’t answer the question, but the true answer may be allusive!