QNAP TS-251+ problems!

QNAP 251+ problems !

I run a QNAP TS-251+ NAS which seems a pretty popular choice on here :-

I have spent a few frustrating days without my music ?!

My NAS was ‘beeping’ the other morning, so I investigated.

The front panel showed both HD lights red, and the USB lamp blue (nothing connected to the USB socket)

I logged in to the software QFinder & it appears that one of the 2 HDs has failed, so I bought another HD and tried re-build

Logging in to QFinder there was a small red cross, indicating that the fan is defunct, despite the fact it seems to be spinning fine?

Re-build was now disabled.

I spent some time online, and there are a few posts on one website, where someone is suggesting that it is a firmware update that can cause the issue. The suggestion was to go back to previous versions, which I see no means to do. I do not understand the fan error, as it seems to be whirring away quite happily.

I logged a ticket with QNAP outlining the issues. I asked about the firmware comments I had read as well.

All I have got back is that it is :-

“ This means that the back plane board and system fan have failed and will need to be replaced at our RMA Center“

This can be repaired a t a fixed cost of $270 + P&P to post it out.

It has to be posted to the Netherlands, or the new U.K. office – who will forward it, all taking up to 31 days.

It seems to highlight the fragile state of things, I think possibly it is just one HD which has gone, but getting the issue resolved is tricky.

Do I just pay up and send it off, get back a 5 year old NAS with a 6month guarantee for around £220

Do I buy a new NAS with a 2 year warranty for around £320

My inclination is to buy a new NAS with 2 new disks and start afresh

I may be wrong but I also understand that taking the usable HD from the old NAS, one cannot just plug it in to the new NAS, which means if I choose to buy a new NAS, or a NAS is beyond repair, one has to buy new and HAVE BACKUPS (which I have)

I wondered if anyone has had a similar experience, or/and any useful tips !?



I had this fan issue with my TS-453Pro. I had advice from QNAP which was no help at all and managed to resolve the issue myself.

In my case the /tmp directory was getting filled up and I have discovered that this is implemented by QNAP as a ramdisk and has only 64mb size. There was an application using this temp space which was filling it up which causes the temperature and fan monitoring software to fail giving the warning that the fan is not spinning when in fact it is.

I found that rebooting the NAS temporarily resolved this as the Ramdisk is recreated when the system boots.

If your cause is the same then you will need to identify which program is filling the Ramdisk up and then either remove it or try to reconfigure it to use somewhere else for temporary storage. I did the later and haven’t had any issues since.

If you believe this is firmware related you can download older versions from QNAP’s website. https://www.qnap.com/en/download?model=ts-251%2B&category=firmware

1 Like

Have you tried removing the failed HD and seeing if it works with the 1 drive. I had one disk fail and the nas still worked just fine. Put a replacement in and the new disk was rebuilt. This will only be possible if they are setup as Raid 1 mirrored drives. I am not sure if you had the back plane renewed the existing disks would still work retaining your files as the serial no of the nas may have changed and it sees them as new disks! May be better to cut losses and get replacement. Good that you have backups.

I purchased a new QNAP to replace an old one which I got 2nd hand.

Dependant on model you can just swap disks over. QNAP have a chart that shows which ones you can do that with.

Was really easy.

Thanks very much for quick & informative reply.
I cannot access the section which allows me to alter the .tmp size i.e. autorun, not sure if there is any other way to access it?
I will try to see if I can download older firmware, but I am pretty sure there is something fundamentally wrong with the unit, losing faith in it.

Thanks for reply - I have tried to boot up with just one (working) disk installed - no luck
I bought a new disk and tried to re-build, it is set up as raid 1 - again would not have it, does not recognise 2nd disk old or new
I think I will probably just cut my losses
Emphasises the value of backups!!!

Thanks for that - if I do replace the unit I will give that a try - useful to know

I don’t think you can alter the size of the tmp folder.

My solution was to modify the configuration of the program that was filling it up to use a disk based tmp directory instead. It was a 3rd party backup program in my case.

Hmm - I tried to run ‘user defined process’ but I do not think my QNAP is working properly as I could not get in to it. Re: 3rd party backup software, I do not have access to that, but thanks for tries !

I’m not sure if the TS-251+ has the same processor family, but the TS-251 (no plus), and some other NAS’s from that timeframe, will eventually start exhibiting a boot-up failure. It’s due to this LPC Clock issue with the Intel C2000 family processors: Silvermont - Wikipedia

It happened to my 5 year old TS-T251 a few months ago. I temporarily repaired it by soldering in a 100 ohm resistor as described in this thread: https://forum.qnap.com/viewtopic.php?f=45&t=157459

As also mentioned in that thread, it will likely fail again. It could be a couple of months later, or a couple of years later.

I didn’t want to deal with it again, so I copied off the data (I had backups but they were a bit dated), and replaced it with a new NAS.

1 Like

Thanks for that - I have read similar elsewhere.
I am not going to start the soldering route

What NAS did you buy as a replacement please, and has it been satisfactory?

Just for a change, I went with Synology this time, instead of QNAP.

I bought a diskless Synology DS720+ (Intel Celeron J4125 4-core, 2GHz, 2GB RAM), and added Seagate IronWolf 4TB NAS HDDs, configured as Raid 1.

I like that the Synology software interface appears less cluttered than QNAP’s, which seems to offer every feature under the sun, 99% of which I don’t use.

It also shuts down and boots up much faster than the old TS-251. It’s not really a fair comparison, as the Synology is a much newer model, with a better process and more memory (and different HDDs).

I run Asset on it, and mostly access my tracks via Roon. Though occasionally via Naim UPnP directly.

I have a very modest digital libary, but so far, the CPU utilization and memory usage are barely registering while using Roon and Naim UPnP. The most I’ve seen is 4% CPU and 14% memory. Of course, your mileage will vary depending on your libary size and usage patterns.

So far, so good. I am pleased with the DS720+.

BTW, for those that like to pop a LPSU onto their NAS, this one would be tricky, as it uses a dual output ±12V wall wart with a 4-pin DIN plug.

Thanks for comprehensive reply - am trying to fathom out the best thing to do still, not easy, but nice to get some replies from here, as people use NAS for similar purpose

I was just looking at a 4 disk Raid 5 solution, but wondered if using QNAPs HBS Synch backup, one would just get copies to external drive as I do now ( i.e. Files in folders which one can just copy/edit etc. or whether they are in some special (to QNAP) format that one cannot access in Windows)

1 Like

It looks as though you have plenty to go on here but I would recommend posting the issue on the Qnap forums to see if there are other solutions.
It seems too much of a coincidence that replacing a HD and a hardware failure happen at the same time.

Maybe there was never a HD failure. It’s the QNAP hardware that failed and the “failed” HD is actually hidden by the QNAP electronics failure?



I’m thinking of making the same move. I am only hesitating because the QNAP has the HD station and an HDMI connection which enables me to use my TV as a monitor - can the Synology do this?

Thanks - I agree

Thanks for reply - that is exactly what I now think. I think the fan/circuit board has failed and therefore the system does not work. Just tough to decide best course of action. It is not easy getting questions answered, not sure where one learns more about NAS operation?

I have this model of QNAP, hence my interest.

Assuming your removable HDs haven’t failed, if you decide to simply replace the QNAP, isn’t it a question of transferring the exiting HD’s to a new NAS?

Exactly! My thinking too.