Radio Paradise Mellow Mix dropping out

Anyone having this problem?
Other Naim radio stations work fine
Even the other RP stations have no problem

I’ve had the odd drop-out on my Node and a couple of times using Bluetooth to a Bose speaker. Nothing that hasn’t been instantly recoverable though.

Have experienced RP drop outs on all of their stations at some point. Probably a buffer issue somewhere along the line. Have also experienced drop outs on other devices and other internet stations, in other places. Implication is that this is a general internet issue and not necessarily a hardware issue (i.e. your streamer). Usually the drop out is only for a second or less before the stream is recovered.


Today again could not get radio paradise stations to play, whereas other stations would play.
Fixed this by shutting off my ndx2, disconnecting the internet cable to the streamer.
After reconnecting and turning the ndx2 back on.
Now all RP stations play perfectly.
Such a fragile medium.

I’m in the states and playing RP Main for the last 7 hours with no drop outs.

Well since mine works on all RP stations after rebooting my ndx2 then seems that it wasn’t a RP problem.
What is strange is that all other Naim radio stations were working as was streaming from Qobuz.
I guess rebooting the streamer probably good to do once in awhile.

1 Like

RP Mellow Mix playing OK in UK.
Maybe it is your network/equipment.

I listen to Internet Radio a lot and for the majority of stations experience no issues.
Would not listen if it was fragile.

My wife has been streaming RP Mellow, through her iPhone, direct to a little JBL boombox. Has never had a problem.

I run it (wired) through my Superuniti to the main system and have never had an issue.

I will admit that, prior to getting 1 Gbps fibre and using either Starlink (approx 200/70 Mbps, but high latency) or a self-built radio relay internet system (50/15) I had dropouts on ALL types of streaming, including video. Latency is a killer for straming and it can be from anywhere along the system - including a poorly connected ethernet cable…

We are in Canada.

Now I cannot get any RP stations.
Rebooted router, reinstalled Naim app, updated iPad to latest software, already have latest firmware on ndx2. My ndx2 is wired direct from uptone ER switch
All other radio stations work perfectly including Naim hidef stations.
My internet speed is 75- and for the past year all had previously worked fine.
Any ideas?

I’m streaming RP main currently in the states and have been for hours, no drops.
I wonder if you have something in your network causing havoc?

My network speed is perfect with proper test
All other radio stations work perfectly
I’m stumped. Mellow mix my favorite

I was thinking more along the lines of a device or software interfering. You’re on a new streamer so not sure what it could be. I’m using work arounds since I’m on a legacy streamer. Both Kurt’s cloud solution for integrating lossless (iRadio) and minimserver flac streaming (UPNP) are working fine for me currently.

Nothing in my system has changed.
Could location play a role? I’m in NY.

None of the Internet radio stations work on my NDX2. I have been having problems for a few days. Streaming from Tidal is just fine, so it is not a network issue.
All I get when I try to play Internet radio is “Ready” displayed in the app, but no music.

I don’t think it should for you since you’re on the new platform but I’m no expert here.

Exactly same for me….except only all RP stations

Where are u located?

Montreal, Canada.

Maybe comes back tomorrow

Here’s the vtuner view of Kurt’s RP Main cloud solution.

Is this something you can try just for troubleshooting purposes?