ReadyNAS offline according to HDX

Hi all, I cannot get my ReadyNAS 102 to work with my HDX. Everything is wired (ethernet). I’ve been using these two for many years via an old (c 2008) Apple AirPort Extreme. I had no problems. But a few days ago I changed my ISP to a fiber optic (we moved house), and changed to a new much faster modem provided by CenturyLink (I’m in Colorado). Everything works fine except the HDX connection issue - the HDX can connect to the internet, I can stream internet radio with the HDX, and the HDX can see the NAS - but the Network Music Share on the NAS stays ‘offline’. When I refresh music shares using the N-serve app (I’m on a Mac) it says ‘online’ for a while, then ‘pending’, then ‘offline’. If anyone is using this ReadyNAS and HDX can provide screen shots of the settings (Permissions, Network Access, File Access etc), I would most appreciate it.

Or any helpful insights! Many thanks
Wayne

had you tried to switch off your router first, wait for the return of internet, then switch off the nas and hdx, then on the nas , wait, and finally on the hdx.
It often works.

Thank you frenchrooster. I just tried this, and unfortunately I still get the same situation. The Music_Share appears ‘offline’ with a big red dot.
Wayne

1 Like

some help maybe by @davidhendon, @ChrisSU, @hungryhalibut, or @Simon-in-Suffolk?

I suspect that your new router uses a different IP range and the Ready NAS is set for the old one. I’m not the expert here, especially not Ready NAS, so you will have to wait for one of the NAS kings to wake up here.

Best

David

You have either a duplicated ip or an ip out side the range of ip’s set by the router. I would shut the power off on modem/ router/ NAS/ maybe even the Mac, Hdx. Unplug everything for 10 minutes not just power off. Re-power modem/router first, give it time to start. Cell phone is good for checking that network is up. Then add one item at a time. I’m guessing your router is set to give auto IP addresses. Hopefully you get a new corrected ip for the NAS. If not you need to get to the router settings to see what’s up.

Rick, auto IP addresses almost certainly won’t work (169.254.0.0 to 169.254.255.255 ) the OP needs to ensure DHCP is enabled on the router and assigning new addresses.

Wayne can you scan the devices on your network, perhaps looking at your router and check to see everything including your ReadyNAS has an IP address?

Then check permissions, temporarily check guest as read write access to your NAS and see what happens.

I’ve seen this behaviour a while ago on my Unitiserve (which is essentially an HDX without the DAC) but that was with the music stored on its internal drive. So I suspect this might mean that the network connection to your HDX is flaky, rather than the NAS.

Thanks all. I turned everything off, unplugged for 10-15 min and turned it all back on. Same issue persists. @Simon-in-Suffolk The router is giving out IP Addresses to all devices, including the NAS and HDX. They are sequential from 192.XXX.X.4 to 192.XXX.X.15. (not sure if giving entire IP addresses is wise, hence the Xs). DHCP is enabled- at least I assume so as my iMac 's Network tab says Configure IPv4: Using DHCP. IPv6 is disabled on the router, BTW. The router configuration browser page does also show “Shared Folders”- and sure enough, they are marked “unavailable” for all devices on the network.

Should the ReadyNAS Services be SMB, AFP, NFS, FTP or other? Thank you all, again
Wayne

ReadyNAS can be either or jointly SMB, AFS and NFS for each share… I suspect that Naim use SMB… so I would at least use that.
AFS was initially for Apple, and NFS for Unix systems, (SMB for Microsoft ) but many platforms support at least SMB now.

I am concerned if the NAS itself is showing the shares as unavailable on its config screen… that doesn’t sound right… I would contact a Netgear support.

Maybe I missed it but how old is your unit?
What drives are in it?
And you do have a complete backup,yes?

Naim do use SMB. For HDX and Unitiserve it’s SMB1 which is often turned off by default in networks these days. UnitiCore can work with SMB2 and SMB3 via its SAMBA implementation.

But as things were working before the router change, it seems unlikely to be a NAS configuration issue as it’s all on DHCP apparently.

It would be interesting to temporarily reconnect the old router (and restart HDX and NAS). Obviously it won’t connect to the internet but it should again allow the HDX to see the NAS. If it does then it points to a router configuration problem.
Best
David

Not sure if things are different over the pond but typically DHCP address start higher up the chain i.e. ending number would be 100 and up, all yours are under 20 so perhaps they are fixed, are the devices for sure on DHCP?

That has never been my experience. Perhaps it’s different for different DHCP servers, and maybe different if you have large numbers of client devices, but for me with typically around a dozen devices on the network, I have never seen an address higher than about .40 in use.

No makes no difference at all, it depends on the algorithm to select an unused address by the DHCP server… if the subnet mask is 255.255.255.0 then any address other than typically ending in 255, 0 is valid. Obviously the DHCP server won’t offer its own router/default gateway address.

I guess it must be different on the routers I have used (I used to use Asus typically, I never use the ones from the ISP.) Certainly within the ASUS if DHCP is enabled then it usually takes the range ending 100-200 for allocation anything under 99 therefore being ones for fixing, which typically is just the router on 1 in a normal home set up.

Mind you I have used untangle now for 3 years plus same here but my mind may be foggy.

The only other thing I can think is the changes to discovery and SMB 1 2 3 etc with early SMB being removed. I think having a user name and password for your share can help in this regard

All the routers I have used were set by default to use the range 1 to 100, although you can usually alter that if you want to. But the third number in the IP group does vary, usually in my experience it’s either 1 or 100. Sometimes changing the router settings to use the same settings as the previous router is the quick way to fix things if one or more devices has previously been set with fixed IPs. Otherwise I’m completely with the general advice that is given here in the forum: leave it all set to DHCP and it will sort itself out.

Incidentally to the OP’s original question there is no security risk to giving the full internal IP addresses used on your network as these don’t help anyone to do anything naughty. I probably wouldn’t publish my outward facing IP address, although in most home installations that is potentially changeable by the ISP anyway.
Best

David

@Rick. The ReadyNAS is about 8 years old. The drives are 2TB Hitachi and WDC. They both work fine according to the ReadyNAS admin browser page. The NAS shows up in the iMac finder with no problem, and I can access all the music on the share form the finders on any laptop or desktop on the network. The share can be accessed as ‘guest’ without a password. The HDX is also accessible by Mac finder. And everything is backed up.

@davidhendon I hooked up the old router (Apple AirPort Extreme), and (1) the music share appeared in the HDX with a green dot, (2) the Airport utility said ‘This Airport base station doesn’t have any DNS server addresses and might have trouble connecting to the internet’. As the music share shows up with the old router but not the new, seems to point to a new router configuration issue. But I don’t know how to fix the darn thing!

DHCP is definitely enabled. Looks like SMB applies only to the NAS, as there does not seem any setting for this on the router. As it worked previously, I don’t think it’s the ‘wrong’ type of SMB. Please keep the help coming.

One thing you could do perhaps is set the new modem to modem only mode and then use the AirPort Extreme as the router. But I don’t know your new modem at all so I don’t if that is possible. The AirPort Extreme is getting on a bit now but I use it as an extra WAP for my 200 Mbps broadband and it handles that speed fine.

Best

David

In iMac make sure all your preferences are correct. check for any software/firmware updates to the Nas and updates for the Mac .Then I think you need to completely remove the share you have for the NAS Not the music files, just the Share, and create a new share…