Roon and NDS - lack of waveform

I use Roon everyday, normally feeding a Unitiqute via RooExtend Ona RPi. Last night I listened to my NDS and noticed that the waveform was not functioning and that only two tracks played from the selected album. The Unitiqutes worked as normal.

I rebooted the Roon server but the issue persists, whether I’m streaming via RooExtend or the server. I’ve contacted Roon but so far the only advice is to reboot the server.

Was it locally stored music or a streaming service that you were having trouble with via Roon ?

Hi @Camphuw,
I’ve had to speak with Martin Smith at the Audiostore today, as the Roon Core apparently disappeared. It seems that we are not alone in experiencing Roon-related glitches in the last couple of weeks.

Mine started 2 days ago when the Roon Remote app on the iPad was updated “to offer a new experience”. You’re not kidding. Back into hours of root cause analysis to work out why the system doesn’t work anymore.

It seems that something’s not quite right with the latest Roon software update.

The solution: delete Roon Server from the Audiostore Prestige server, reboot the server then re-install Roon Server. The Roon Remote app on the iPad then instantly spotted the “new” Roon Core. Trouble is, it thinks it’s a new core, so I had to do all the logging in to the Roon Core, then logging in to Tidal all over again. Leave it half an hour for Roon to find the several thousand albums on the Prestige server, re-assign the Audio Zones and finally it all works like it did before.

Phew! What a massive waste of a few hours that was but at least normality has resumed.

Thank goodness for vinyl!

Hope this helps a bit, BF


The last iOS app update for Roon was released 12 days ago, it was the Build 935 for version 1.8 and was a minor Bugfix update, for which I would be surprised if it announced “a new experience”. Had you maybe not updated the iOS app on ages?

We have build 936 for version 1.8, in case that makes any difference.

Best regards, BF

Thanks for the advice. I had the same msg via a friend from Martin just now. Will attempt it later. But I’ve heard no buzz about the latest version of Roon being problematic.

Local music. I’ve not dipped my toe in subscription stuff since trying it a few years ago.

1 Like

For the server, but there was no 936 for remote apps.

Roon 1.8 (Build 936) Release Notes

Roon Build 936 is now rolling out for macOS, Windows, Windows (64 Bit), Roon OS, and Linux.

There is no update for the Roon iOS or Android apps at this time.

At least my Android duly reports 935, updated April 27, without any pending updates

Still a problem since the Roon upgrade … anyone know when / if the SonoreBridge is due for an update?

Whilst this doesn’t really help I’m using the SonoreBridge for my NDS and RooExtend for my Qute and the waveform is fine for me on both and I’m not having any issues playing beyond 2 tracks.

The main difference between our setups is the server, I’m using a Roon Rock so maybe there’s an issue with your server?

I use a Sonore Bridge and the waveform is present and correct with Roon up-to-date.

Thanks @trickydickie for your response. The problem seems just to be with the NDS as my ‘Qutes work fine. Perhaps because they are fed by a RPi running RooExtend.

Thanks @Guinnless - I took Martin’s advice from Audiostore and deleted Roon and SonoreBridge from the Nova, rebooted, then reinstalled them. But the NDS still won’t behave.

1 Like

Is your SonoreBridge is running on the Audiostore device? If so then that’s a difference to my setup which runs the SonoreBridge on a separate device as I have the Small Green Computer dedicated device. My SonoreBridge only runs the NDS as I use RooExtend for the Qute, the same as you.

I’m not aware of any updates to the Bridge, I certainly haven’t had any.

Have you tried using the NDS via RooExtend and have you rebooted the NDS?

My NDS with SonoreUPnP Bridge is running fine throughout all the recent Roon updates.
Roon Core is on a ROCK server running on an Intel NUC
SonoreUPnP Bridge is on an UltraRendu
Music Library is on a NAS

I prefer to have separate layers doing their part of the playback path, makes for easy debugging when something is misbehaving.

I don’t expect an update to the SonoreUPnP Bridge — last time there was, Andy broke it, so hopefully he will leave it alone, as it is working and neither the Squeezebox or UPnP protocols are subject to any change anymore.

I would like to see further Roon updates, with full screen “Playing Now” Artist pictures on iPads - they have this on other platforms.


Update: still no waveform, still not playing more than one or two tracks through Roon. However, using the Naim app both with music on the Audiostore and on other NAS I can’t play a whole album or access the booklet. So I think there might be an issue with the NDS. I will raise a query with HQ.

Thanks for all your comments and I particularly like @simon.pepper way of separating elements.

Can I suggest you flash the pi with roopieee?

Have you tried pointing the SonoreBridge at the Qute to see if the problem moves?


I can’t see it being the NDS as it just receives a stream from the Bridge. Have you asked on the Roon forum?

1 Like

Yes I’ve tried the Qutes they are fine @trickydickie and @Guinnless I’ve posted on the Roon forum and sent them a request.

Well I’m bemused: I powered everything down again, walked the dog, powered up and low and behold everything is fine. By my count that was after three previous reboots / switch offs and two reinstalls. It must have been walking the dog … a prolonged power down (30 minutes rather than five)

Thanks again for all your help / support.


You should thanks specially your dog :dog: