Setting a BubbleUPNP - help

Hi guys,
I have problem with setting bubble to share Qobuz to my Superuniti.
I saw this gtopic " BubbleUpnp on QNAP. help With setup"
but do I have to do the same?
In my situation the bubble is visible on my other desctop pc (where I have Universal Media Server) but it is not visible from the SU?! InQobuz I don’t hve EXTERNAL as an audio options…?!
The SU sees Universal Media Server and I am able to stream from desctop pc → SU but it doesnt find bubble. The bubble is on my laptop (wifi) the SU is wired and the desctop pc is wired if this is matters.
Something is wrong and I can’t understand what?!

The Superuniti can’t control Bubble directly. You need a third party app such as Linn or Lumin to control Bubble.

I don’t understand :slight_smile:
Can you explain me in more details.
I have Qobuz on my laptop - what shoid I do (have) to be able to have it on SU?

What you need is this:

You can probably ignore the stuff about chromecast. That’s an option, but you just want to select the uniti as a renderer.

There is an android version and iphone version. It will see your Superuniti as a “renderer”. You then log into Qobuz from the phone app, play some tracks and it will send the audio via upnp to the uniti.

When you run the app, click on the bottom right icon that looks like a speaker. This will display all the available “renderers” etc.

BubbleUPnP Server can serve music from Tidal, Qobuz or locally stored files on your home network. It will find your Naim streamers so that you can select them as client devices to which you can stream your music.
The Naim app doesn’t recognise this method of plaback, so you cannot use it with Bubble. Other apps are implemented very differently, and the Linn app will control non-Linn streamers using Bubble. Likewise with the Lumin app.
Once you have Bubble set up on your NAS, open either of these apps on your phone and they should find and play your music, and control volume on your Naim streamer.

1 Like

Note that we are talking about BubbleUPnP Server here, running on a computer or NAS.
The BubbleUPnP app that @wdoyle mentions above is different. As far as I’m aware it’s Android only.

Hi all and thanks for your replies. I installed Linn app on my phone and everything is fine :blush:
Firstly I thought that Qobuz and BubbleUpNp will be enough to stream. Qobuz to Bubble and Bubble to SU…
Thanks Chris, yes I have home network and stream flacs to SU from my desktop pc. Everything is working now maybe I’ll just need to move the Bubble on my other pc otherwise the laptop should be always on.
Thanks :pray:

Glad you are making progress!
I run Bubble on a Synology NAS so it’s conveniently ‘always on’ with no regular computer running.

I don’t have NAS so the desktop pc is named to be NAS :blush: it is always on and till now I was playing flacs from there to SU. But I prefer to have bigger library with easy access.

Let’s summarise what you need to run Qobuz on your Superuniti (I guess it is the same for other legacy streamers :blush:) I hope this will help others after me not to read all day as I did.

  1. Install BubbleUPnP on your PC (NAS) and make sure that it is set propperly.
  • On Network and Security tab check Allow to access the server from the Internet.
  • On Status tab make sure all the rows on Network ans Status sections are green rows with no errors.

    p.s. If HTTP and HTTPS Ports are not opened you need to set them from your router. You will have an error if they are not.
  1. You need to install Linn app on your phone (or Lumin - I did not try with it). Open it and it directly shows you Tidal and Qobuz possibilitys. Login with your Qobuz credentials.
    And that’s all.
    You don’t even need Qobuz app on your phone :face_with_peeking_eye:
    The Bubble needs to running, you play music from your phone Linn app :metal:

You don’t need “Allow access to the server from the internet” at all to use bubble server with Qobuz/Tidal for use at home. That is done for another reason (remote access to your bubble machine).

I would recommend you turn that off, it is not enabled by default for a reason.


@ChrisSU , if I may side track, what DSM are you using?
I updated mine to 7.something but to find out only after that Bubble is not supported anymore and Docker is too heavy for my DS115. Even worst, I can’t manage to rôle back to DSM 6. Synology don’t support the role back. Unless I missed something?

Hi, I too have a DS115, but I didn’t update to DSM 7 as Synology, despite listing it as suitable for running 7, also had a warning that mine might not have enough memory.

I did find an archive of old DSM versions on Synology’s website, so the old versions are available if your NAS will allow you to instal them:

(I have modified the link slightly as live links are not permitted on this forum).

Obviously you will have to take a view on any security risks if you run an old version of DSM. Alternatively, if you don’t want to spend lots of time on a possibly fruitless attempt to use Docker etc. I guess you may need to use different hardware if you want to continue with Bubble. A RPi would be a cheap option, or maybe another computer you already own?
Good luck!

1 Like

Thanks a lot for the link. I was hoping for something maybe I could have missed.

I already tried the roll back. Actually Synology don’t let you do it. It’s blocking it.
With a few good research I have found on the web smart peoples who have find a work around. It include editing some Linux boot file to cheat the system so he thinks you have 6.x DSM. To do so you need obviously the exact DSM file name but also the release time stamp date and hour. This is where it was getting more complicated. Just the editor itself OMG, is coming right from the age of stone. I could barely remember the little Unix class I had 30 years ago! Long story short I messed up big time and I won’t try again. I will maybe try a last full factory reset and use it for backup or it will go the recycle bin.

So yes that was a good excuse for me to investigate the RP4 who is tickling me since long time. :-). Actually I already started a draft topic that I’ll post on this forum. Just need a few updates since there is already good inputs in this thread.
I’ll put the link here in time.

I agree with Chirs, RP is a low fuss option and it seems like there’s quite a few people here running a RP on their network. I bought one after I had issues with my QNAP and ffmpeg preventing transcoding for Bubble Soft but in the end the the docker container worked without a hitch on my QNAP and didn’t consume much resources.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.