Some albums on USB don't start through USB icon on Naim App

Some albums on the USB front don’t start by using the USB icon on the Naim App But I can start them if I access them through search. Had anybody else experienced this problem?


I’m not sure why music would not play through the USB input, but I would suggest that you ignore this input and go to Server/Local Music where you will find the contents of your USB drive, but with proper metadata view so that you can browse album, artist, artwork etc.

1 Like

Thanks very much for your quick reply. This solves the problem. So I will access the albums on the USB through the Server-input instead of the USB input.

I think this is a better option, but remember that it takes a little time for the streamer to scan the USB drive and list all the music in the Server input. When you remove and replace the USB drive it has to rescan it. This may be OK for a small music library but for a large library or where you need to add to it regularly a music store on separate network storage might be easier.

Chris, while we are on the topic of the app, I have one other question. The view of my local albums when go from server to usb to albums I would also expect when I choose albums on the home page of the app. Do you know why this not the case and you first have to select more. Which I feel is completely unnecessary



step.

FWIW I agree and have posted about it many times. This is simply a UI design decision and IMHO a bad one. It displays most recent albums played and added, I think, but it it regularly confuses people because you have to hunt for the hidden More button by scrolling down, which is not obvious, and the sort options are not visible until you do and tap More.

Seeing most recent albums first my be useful, but it could be made so much better by making it clear:

  • Put a label somewhere telling me what this is
  • Put the More button next to it so that I can see it
  • Display the sort menu already in the preview. It can implicitly double as “More”, i.e., if the user taps it while being in the “latest albums” preview, simply show all albums by the chosen sorting option. There is no need to require that the user clicks More first

In your second attachment, it shows a list of folders. So what happens if you click on one of those folders?

Although I do agree, “local music” is a better way of accessing music. The only time I use the USB interface is when playing m3u playlists

Is it the & in the file name?

I had this problem and changed to “and”. All now play.

Ah, could be. & in linux can mean multi things. After ripping albums I do try to get rid of and characters that may become issues

It’s an interesting one as I didn’t have any issues with the & and suddenly it changed.
Not sure if an update has done something or not but I’ve solved the issue now.
Strange that it has only just become an issue though.

A decent ripper should have an option to automatically not use potentially messy characters in filenames

I now use dbpoweramp, so a good shout, I’ll check that out. I’ve used various rippers over the past years that may not have had options, so just got in the habit.

It’s been a while since I changed the configuration of my dBPA and that I looked at filenames (and right now sitting outside and far from computer, so sorry for not looking it up :pray:) but I am quite sure that it has the option in the ripping settings.
FWIW even the default ripper in Ubuntu has the option, I’m sure, so am surprised that not all do

Found it, and added “&” - will probably add a few more later - thanks

Screen Shot 2021-10-30 at 21.29.34

1 Like

Yes. I had a lot of &'s. Replacing them with ‘and’ solved the problem. Thank you.
It’s an interesting one as I didn’t have any issues with the & and suddenly it changed.
Not sure if an update has done something or not but I’ve solved the issue now.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.