The Naim app is so janky

As much as I love my Naim, the quality of the Naim app is starting to grate. It’s laggy, buggy and suffers from terrible UX. We spend all this money on boxes, cables and Fraims, yet the primary interface for interacting with it is 3/10 at best.

Take the Favourites flow as an example:

A long list, showing a preview of 8 for each category (Radio, Artists, Albums, Playlists, Pre-sets). Not particularly task performant or useful. The order seems arbitrary, so finding a favourite is fairly laborious. The preview list isn’t particularly helpful, so you end up selecting ‘More’ most of the time. Let me drill straight into type at the first level or just give me the complete list with sensible search and filters. Better yet, surface my favourites based on my listening.

The filters UI is very unintuitive and slow (click, scroll, click with some awkward choices on the way). It optimises to show a grid of album art ahead of a solid filter experience. The filtered list doesn’t show the set priority, instead you have to drill into the badly labelled A-Z icon for that. Selecting an album expands it but selecting a track plays it, with no visual difference. So you have a list with a single visual look and feel with different elements behaving differently.

The search input, unconventionally named filter, isn’t much better. After hitting cancel, it continues to remember your search term.

What do others think? Presumably some are using different tools all together? Sorry for the rant but I’ve spent nearly £50k on Naim and the app continues to feel like a uni project.


I’m having massive problems with the Naim app recently and it can’t play from my NAS drive. I have contacted Naim support for a solution. I have reset my NDS, router, Cisco switch and uninstalled and reinstalled the Naim app.

I can access the NAS drive direct from the NDS but not the App.

The Naim app has always been weak IMHO and at best 3/10 is generous.


Hi Dan, just out of interest have you tried changing the UPnP Input setting to UPnP compatibility mode? You loose a bit of functionality within the app but it made a big difference connecting to my network storage when I had my NDX.

1 Like

Hi @Phil1 . Yep tried that. It’s all over the place. When I try to play UPnP now it goes to rock iradio stations.

It has so many bugs it’s beyond belief!


I can’t see how people get such different experiences. I can find the music I want from my NASes easily, search on Tidal/Qobuz seems to work for me, the music plays from all sources I use, the only Internet radio I listen to is cricket commentary which seems to work fine.
For me the app does all I want it to do and does it in a simple and efficient fashion.


Unless you experience problems you won’t know. I was finding the app okay until the last few weeks and right now it’s terrible with the NAS drive.

What’s the reason? Who knows? But there are some of us having real problems with the Naim App. That’s a true story!


And in fairness maybe the problems are more with legacy products right now? What are others experiences?

Which app version, iOS or Android ?
I use both & beta test the iOS.
None have these same problems as listed in this thread so it makes me think it’s not just the app.
A mate uses iOS with his Atom & his big problem with the app is with Tidal,

Using Android, have tried the app on 2 different phones. Only other thing to do is look at NAS drive? Will wait for Naim support.

Will see if NAS drive works okay on Sonos system as well.

This is the world of computers and streaming. When it goes wrong it goes wrong big time.

LPs and CDs looking more attractive all the time !

No problems here. Using both the iOS version on an old iPad and the Android version on chepa Samsung phone. iOS is terribly slow but I chalk that up to the wifi of the iPad. Android version is lightning fast and reliable. Using just a simple Seagate NAS directly attached to an ordinary Linksys router. NDS is direct wired to the same router. Works flawless. Also using Quobuz through BubbleUPnP that runs on a PC that has a 5 Ghz connection to the router. Using Lumin on the iPad as control point. Works flawless too.

Go Roon and never look back.


Most of the time my N272 won’t even connect to the app.

Naim Support took a look at my network scan and suggested my Apple range extender could be the culprit. Alas, I don’t even own one of those – although it seems possible my neighbour does.

I get by without the Naim app as I do most of my listening via Audirvana / Tidal, but I’d still like to have the option, especially for radio streaming.

1 Like

All I use the Naim App for now is for iRadio and this part of the App isn’t great. I never had any issues connecting though - instant connection every time.

I have no WiFi extenders, mains networks plugs etc

1 Like

I don’t think it’s just legacy products, Dan. I have a 2017 NDS and have not been having any issues. But I do know that these problems people are having are very real, and it doesn’t seem like they are Network related at all.
The only thing I don’t like about the APP is using Tidal. I want to be able to easily custom sort my Tidal album and track lists into genres and artists and types. And all it does is just make a huge never-ending mixed genre list of every album/artist, that I have to scroll down thru.
And when I’m making up a playlist; after I select a track, it always zeros back to the top, which sucks.

1 Like

Wow, just tried using the Naim app on my NAS and it is actually working. Unbelievable! But for how long though? Lol :rofl: :joy: :rofl:

1 Like

The iRadio has always worked okay. Although the UPnP setting wants to play iRadio instead!

The Naim Gods have listened and everything is working! I do not understand any of this tbf.

Naim app and multiple Naim legacy devices on the network is not always a happy end user experience. Quite often get an error about another device is connected opening device via app. Problem is intermittent.

Also there was a previous thread where lots of people reported app doesn’t correctly reconnect to a device if it “loses focus” (i.e. reading a WhatsApp or opening Facebook). Also intermittent.

These issues completely put us off an ND5XS2 which has no remote!!!

1 Like

I think we need an answer from Naim support on this forum as it seems to be an ongoing issue. @Richard.Dane can you offer any support?

Right now everything is working great. Yesterday it wasn’t. Where do you we go from here? It seems mainly that legacy devices are impacted.

If the reviews are 3/10 and on the app review it is similar, it seems clear that this aspect of Naim is lacking in stability and customer satisfaction.

Thanks in anticipation.

Hi Dan, I can’t speak for support I’m afraid and obviously dealing with issues through the forum is not really possible. However, for you or for anybody else experiencing such issues, contacting support is a good idea. They’re there to try to help.

1 Like