Tidal issues

Hi chaps.
I’m not quite sure what’s going on but I cannot seem to play Tidal through any of my naim streaming devices. It was fine but since yesterday I cannot log in through the naim app.
I can log in to the native tidal app fine, but with both my ND5Xs and Superuniti neither works.

I just get…

Could not log in
client not found

I even deleted the naim app off my phone and reinstalled but still the same message.

Any ideas guys what’s going on?

Cheers. Garry

Oh… The Iradio works fine, so the phone app is communicating with both streamers.

Any idea how I can get this to log in to Tidal?


If you look at any of the recent posts about Tidal login, you will see that a year ago there was a legacy streamer firmware update to fix a problem that would come sooner or later as Tidal had announced that they were changing their authentication method. Well they finally did that this last week.

So the fix if you have legacy streamers is that you need to update the firmware on your legacy streamers to 4.8.


Preempting the next question

@Richard.Dane hi can you put a big banner somewhere on the forum? “If you can’t use tidal anymore ……”

Well I managed to find an old USB to USB-b cable…just left my pesky laptop locked in my drawer at work. Will have a go tomorrow evening.

I take it it’s an easy thing to do?

Links to ‘naim firmware updates for dummies’ might be good :joy::rofl::+1:

Yes pretty simple; most likely you’ll need to install the uart drivers which I’ve linked to, but the pdf tells you everything you need to know.
What can catch people out is the old style usb cable; not all of them will work, see if you can find more than 1 just in case.

Maybe I will change this thread title as suggested :joy:

When you download the update it should include a .pdf instruction sheet.

There was a thread sticky that was up for along time. I would have thought that most would have seen it or updated by now. Evidently not…

1 Like

Trying to use my uniti 2 to stream from tidal and not working. Can even get radio. I’m in 4.8, latest app versions. It’s like the app is not communicating with the device. Reinstalled the app, restarted my uniti2, tried my Muso qb. I can work via Bluetooth only.

I got a pop up message in my Naim app saying I need to update my firmware. Im already on 4.8.00 - is there a later version? Doesn’t appear to be in support list of updates?

4.8.00 is the latest version of firmware for the Uniti 2 and other green screen legacy streamers.

Apart from the things you have tried, I suggest:

  1. factory reset of your Uniti 2.

  2. try running it with an Ethernet connection if you are using WiFi on the Uniti 2.

  3. power off restart your router and when it has fully restarted, then restart your Uniti 2.

  4. try logging out of tidal on your Uniti 2, restart your Uniti 2 and your phone on which the app is running then try logging into tidal again in the app.

If you are using an iOS device, if the excellent suggestions above don’t achieve a satisfactory result, then try a phone Reset; always worth detailing your control point and the exact os version.

Thank you all. That’s done the trick. Switched all devices off including the router. Switched everything back on, router first, then iPad and phones, then QBs, then uniti2.

Now happily listening to Anarchy in the UK… happy Easter!

1 Like

Very good! It is surprising how often restarting the router turns out to be the solution. And I suspect it was actually that bit of all that you did that sorted it for you.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.