TIDAL stops playing before playlist ends

Is there a trick to get TIDAL to work properly when using the Naim app? Since owning my 272 I have only been using upnp and Spotify Connect and it has been working perfectly, never had a single issue.
Since signing up with TIDAL a few days ago, I have had nothing but problems with the Naim app. Sometimes it will play, sometimes it won’t. Sometimes it stops after a few mins, sometimes it stops after an hour. Its never once played through an entire TIDAL playlist. Sometimes, it kicks me right out of the app while trying to get it to play a TIDAL playlist. I am using the latest version of the Android app and 272 is updated to latest firmware.

Any ideas that can help?

*EDIT: 2022/01/25. Most issues were resolved with a factory reset. I have updated the thread title accordingly.
I am however still having 1 unresolved issue. When streaming TIDAL, the 272 stops playing 1 - 2 hours in, always, regardless of how large the playlist is.

Check the quality level in the app aligns to your level of Tidal subscription. If that is OK then issue is mostly likely with your home network.

1 Like

I only use TIDAL via ROON at this point so commenting on the actual TIDAL reliability.

I never have issues with TIDAL aside from the one of two outages they suffer from per year. So the issue is not with TIDAL.

I have a similar situation, Tidal rarely has outages, unless you haven’t paid the ISP bill?

My network is good, no issues there. I should have probably also mentioned my 272 is hardwired via ethernet and my devices are on a WiFi6 network. I have also locked in my IP addresses for both the 272 and the Tablet controlling it. I only have these issues with TIDAL, as mentioned, Spotify and streaming flacs from within my network are rock solid. My network itself is rock solid.

In response to TIDAL itself: I guess I should have titled this post better (which I have now changed). TIDAL is rock solid. It has no issues streaming from its own app, ever. I had been using it for years prior. Also, it currently has no issues streaming from its own app on my network, or on my PC. This issue is strictly within the Naim app.

And as for roon, if it is a solution to this issue, I will most certainly find a way to make it work with my 272.

Sounds like you should log a call with Naim support then.

The 1st gen Naim streamers were always susceptible to dropouts with Tidal due to their very small buffers which were only really designed for local streaming rather than web streaming where latency can be an issue.
Naim did go to great lengths to optimise Tidal performance as it was such a common problem, and things improved for most people but there’s always the chance it may be a problem for some.
A popular workaround is to use a proxy server to accept the stream, buffer it, and serve it to the 272 as if it were a local UPnP stream. Roon is a good way to do this, but it requires a subscription and a networked computer to run it (which you may already have). Because the 272 doesn’t have native Roon support you also need to deal with this, which can be done in software but the easiest solution is probably to buy a Sonore UPnP bridge from Smallgreencomputer for about £200.

Another option, which is free, is to run BubbleUPnP Server on a computer or NAS, which will also buffer the incoming Tidal stream.

1 Like

I am actually considering the Sonore/Roon option. But before spending $$ I just want to make sure it will help with my issues. My NAC just got kicked off the network again when using TIDAL, so I have done a factory reset now. So we’ll see what happens from here. I really don’t understand how using TIDAL can get my 272 kicked off the network so the app cannot find it. I don’t have this issue when streaming radio, upnp or Spotify connect. Just TIDAL. It would be very frustrating if I went the Roon way and it was still being kicked out of the app.

I’d try a few things, if you haven’t done these already, which have helped others.

Completely power down your Android device and back up again.

Factory reset your 272 - recommended after the Firmware 4.8 update if you’re experiencing any issues

Log out of TIDAL in the Naim App and back in again

Still no better?
Change your TIDAL password in the TIDAL App, and logging into TIDAL on Naim App with this fresh password

Let us know how you get on.

1 Like

Hi Clare,

I have rebooted my network, and android devices several times in trying to troubleshoot this issue. I just did a factory reset before you replied, so we’ll see if that fixes things (testing it now). I did also just do the 4.8 firmware update when I signed back on with TIDAL.

If the factory reset doesn’t help, next I will log out/in of TIDAL via naim app &/or reset my TIDAL passwd and as per your tips.

1 Like

Yes, certainly worth trying to get to the bottom of any networking issues before you try Roon.

1 Like

So first test run after a factory reset, It played approx 2 hours, 45 mins of a 7 hour playlist before stopping. So something is still off. Running a longer playlist now to see what happens, at least it let me start another one this time.

Second playlist stopped playing after an hour and 45 mins on a 500 track playlist. So it seems to just randomly stop playing whenever it wants to. I also logged out of TIDAL in the Naim app and back in before this one, seems to have no effect.

However once again, it let me start another one playing, which it didn’t do before, this is when it used to get kicked off the app, so maybe I have 2 issues here, and hopefully the factory reset fixed the booting from the app. issue. fingers crossed


Issue #1: I think it is now safe to say that the factory reset fixed all app connectivity and play starting issues. Unit has been running rock solid since yesterday morning after the reset. \o/

Issue #2: TIDAL stops playing after ±2 hours. This only happens with TIDAL as I ran a playlist from UPNP last evening for around 5 - 6 hours, no issues. Has anyone else experienced this?

Glad issue one is sorted with the recommended Factory Reset.

Issue two I’m not sure on - copying in @tomvamos for reference

1 Like

Same problem with my nd5xs. Tried various options with the naim app. Unfortunately it doesn’t work correctly when playing Tidal. I installed BubbleUPNP from Google Play on my Android smartphone and control Tidal playback from it. It works without problems.

1 Like

Thanks, will give this a try!

I tried bubbleUPnP, but it just plays the same track over and over no matter what I do. It refuses to play playlists. I will go back to trying to figure out the naim app, which should work in the first place.

So I figured out why bubble was playing the same track over and over, just had to enable gapless. Got it working, so I set a large playlist and let it play.

Same issue still persists as with TIDAL, the music stopped playing after 1.5 hours even though the playlist loaded was 24 hours worth of music.

Try disabling battery saving mode in BubbleUPNP settings and allow BubbleUPNP to run in the background in Android settings.