Trouble updating firmware Muso Qb 2

Hi there, can anyone please help me. I try to install a firmware on my Qb 2 but the system didn’t work anymore.
I read in other topics what to do. I did but still my Qb2 isn’t working.
It’s also not show on my iPhone it’s still searching.
This is what I’ve done till now, and several times:

  • Unplug it from the electricity and wait for an hour
  • Direct to my router (no wifi)
  • Factory restart

When I do these things the Qb restart and the ring will burn and I see the lights clockwise go out, but when all light are out the system won’t start up.

Please help me I don’t know it anymore

Have you tried a reset of the Mu-So?

Hi Richard,
I’ve done it several times. At he moment the ring is flashing 2 seconds on and the 2 seconds off. And the bleu light is on at the back site.

The unit is still in fw update or recovery mode. Describe your reset procedure and if different from this, try again as the pic below which is different than the supplied manual procedure…

To return your Mu-so or Mu-so Qb to its default settings use the pin-tool supplied (or a straightened paperclip) to press and hold the pin-hole button adjacent to the status indicator (see Diagrams 2 and 3 respectively for Mu-so and Mu-so Qb). Hold the button pressed for six seconds. Mu-so or Mu-so Qb will return to its default settings and restart. The rotary control and logo illumination will flash while the factory default procedure is underway.

Hi Aboulfad,

I did the reset procedure this way;
pushed with a paperclip in the pin hole for 6 seconds
the rotary control is flashing and the light on the control turn off clockwise one by one
the light on the back is flashing red

This was also last night so I turned off the current and tried it again this morning but it’s the same it doesn’t work.
Also the app on my iPhone can’t find my Qb 2 and it’s on the same network

btw thanks for your support

Sorry for your trouble. If your QB2 has the blue light, the app may not be able to discover the Muso as its in “firmware update underway or recovery mode”. Are you resetting with the unit on and not on standby mode? Also unplug the power cable from the unit not via other means.

There’s a manual firmware update (with cautions) that is initiated from the unit’s web interface. If you know the IP addr (which now you can’t get from the app), you can try that but it’s possible that functionality and the web server isnt running during a blue light. If you know how to check for attached devices in your router, look for the Muso, if it doesn’t show up, it means it’s completely offline…

It is odd that there’s some users that have trouble with firmware updates while for others is as simple as turning a light on. I had to go through all these reset steps when I first got the unit as it wouldn’t join my wifi network (5Ghz band C, fixed in 4.3 update) so I know how frustrating it is not to be able to use the unit.

Oh according to the above screenshot, red (flashing) is a system fault :frowning_face: I hope it isn’t!

Did another reset. At the moment the ring is flashing and the light at the back site is burning bleu.

Fingers crossed

What can I do more? I don’t know it anymore, it’s very frustrating.

I know, sorry. Do you know how to look for attached devices on your router’s page to get the Muso IP address?

Is the indicator light back to solid blue (bleu en français )?

In parallel, you should email naim support with all the details, and most likely it’ll take many days before a reply.

I made a printscreen

Is that screenshot from your router app? In a browser, enter the Muso IP address, and if the web server is running, you should have a similar screenshot that I added above. From there, you can go to the manual update process. I have never done it, and not sure why there’s so many warnings…

PS: Ben je Nederlands? Mijn vrouw is : ) I can write/speak few phrases.

try pressing in the reset hole for about 30 seconds. Then see what colour lights it comes back with when it restarts…

DONT USE THE MANUAL UPDATE because you need a firmware file and it isn’t found on Naim firmware update site. Maybe the manual update process locates it and downloads it, but unsure as my QB2 is up to date.

I wonder if 10s or 30s makes a difference? The manuals refer to either 6 or 10s, I guess no harm in trying much longer. Akin to the 30/30/30 old router procedures.

Hi, I had this same problem for the past 24 hours. Solved by opening Naim app on ipad and keeping it open while blue light flashed. In about 2 mins update finished and now ok.

Yes I’m from the Netherlands.

I’ve done what you’ve written, see the screenshot

I don’t have a file to do a manual update. Where can I find this?

Oh your Muso already has 4.3.0, check your screenshot and compare to mine, so it did upgrade but the unit doesn’t start?!?

PS: :grinning: I said I speak few sentences not fluent in Dutch and also if you’d want others to help it has to be engels .
PPS: congrats about Max Verstappen :wink:

I translate my last message in English.

Yes it has done the upgrade, but it won’t start up. I also tried to push the small button for 30 seconds, no positive result.

1 Like

You’d only want to do that manual firmware update as a last resort, sadly I don’t know whether those files are available publicly for Muso.

It’s a bummer that’s happening, maybe next week Naim staff can help? (Definitely create a support ticket)

I was reading this Help Centre and it mentions 10mns to an hour for an update, I assume your internet connection is “fast” and reliable. Mine took 2 or 3mns to complete, 450Mbps service.