Uniti Atom cannot see UPnP Server

My Uniti Atom does not seem to see my UPnP server.

The server is running on Windows 10, (the software is Universal Media Server 8.0.1). I can see this server from other software (e.g. VLC media player running on the same windows machine). However, when I open the Naim app (on my Android phone), and click on servers, this server does not appear to be there. I have restarted, reinstalled the app on my phone. I have updated the Atom itself, and restarted it, and also turned it off from the mains.

Now, everything is restarted, and the server is working, but the server cannot be seen by the app. What do I do?

These issues are often network related so you’ll be helping by describing your network. Wired, wifi, switches etc

My network is wireless.

PC <—wifi—> Router <—wifi—> Uniti Atom
Router <—wired—> ISP

I know the Atom can access the internet because it can play Spotify and Internet Radio.

Any more info I should include?

Hi cammil, is the windows upnp server visible on another control point app on your android device, eg mconnect?

Is UPnP enabled on your router?

That’s the wrong kind of upnp! The router upnp setting won’t affect this issue.

A good question to ask is whether this used to work and doesn’t now suddenly or has the OP not tried to do this before (eg because the Atom is new).



It doesn’t seem to be. I have tried finding the UPnP server from my Mac Book (using VLC), but it’s not there.

I think I changed some network settings on the Windows 10 PC (turned on network discovery, and turned on file and printer sharing), but the server is still not visible. Also, the firewall is ON for domain, private and public network (I am not sure if this is correct).

I couldn’t find the UPnP settings on my router. I have read some other forums and it might be enabled by default.

I have seen the UPnP server from my Atom at least once before. But not had it working reliably ever. I would like to fix this properly now, instead of chaotically turning everything on and off at random!

1 Like

I’ve turned off firewall for private and public (temporarily) and the server is still not visible.

I tried Asset, but it seems I have the same issue. The server is seen on the windows 10 pc (using VLC), but not there on my MacBook (using VLC).

I also have turned off my VPN temporarily. Though my VPN software has the option of allowing communication on the same network, I have turned it off just to check.

Hi cammill

It’s been a while since I used windows. You have turned network discovery on on your PC - can you confirm the settings?

Also, what router do you have?

Check your firewall is not blocking it and allow the app through. Updates on Windows often do some odd things to the firewall.

The Atom built in UPnP server works only with files on a directly attached USB drive, is that what you were doing? If not, I would suggest that you give it a try.

I’m not sure what you mean here. I have a UPnP server on my Windows machine, and I want my Uniti Atom to play from it. I cannot connect my hard drive to the Atom via USB. It’s inside my PC.

I have completely turned off the Windows firewall, still I cannot see the UPnP server.

Is there another way I can play files from my PC on the Atom, if not with UPnP?

I’m absolutely no network expert unlike many here so treat my suggestions as just a friendly attempt to help. Can your MacBook see your PC if you run a network analyser such as LanScan on it? And can it see the Atom? If no and yes it looks as if your PC is still blocking full access. If so, perhaps there’s a forum for UMS users where you could raise the issue?


Asset is well respected and familiar to many on here which would make it easier to offer assistance.

Asset should also be visible from the Windows PC itself, no need for VLC.

This is definitely network related. You need to ensure the computer running the UPnP server is on exactly the same subnet as the Atom as is the appliance running the Naim app or it won’t see it. UPnP won’t pass across vlans unless it’s specifically configured on your neteork to do so and it won’t traverse a VPN. The ip addresses must be in the same range for the first 3 set of numbers e.g. 192.168.1 the last will be unique. Also ensure there is nothing on your router blocking multicast traffic.

Hello Camill

You never stated what your router is?

You mention you have a Mac on your home network. If so, using Spotlight, type Network Utility, open it and run the Port Scan against the IP address of your PC running UMS. I believe ports 5001, 2869 and 1900 should be open and responding. This would prove that the UMS server is visible on your network to other devices and the PC firewall isn’t getting in the way. Also as @CrystalGipsy has stated, ensure the PC, Atom (and Mac and Tablet) are all on the same IP subnet.

Keeping everything on the same subnet is best accomplished with DHCP.