Uniti Core questions

I wanted to listen an album from the front USB.
I found the settings to declare it as a store and saw the music on it.
But, things get obscure when I wanted to go back to the internal HDD…
It had to re-declare it as a store, with the option to keep the music, to get access…
Did I missed something there ?
Will it be each time like this when I want to use the front USB ?
Or this port is only for importing music ?
Confused here… ( the support videos are not really helping).

Help. The Core is ripping cds but there is no metadata.
I’ve tried quite a few but it is no longer providing metadata for anything. Tried different providers but nothing. Everything else is working fine

1 Like

You should declare your USB HDD or whatever as a Music Share. You keep the internal Drive as the Music Store and there is no reason to change that in your application.

Music on both the Store and any Shares will all appear in the Naim app.

Have you tried a full power off restart of the Core, so not just pressing the button on the front, but take the power right off for a minute or so? That should fix the problem.

1 Like

Will try that now David

Thanks David. Everything back to normal :+1:


@davidhendon Hello David. Problems again. The Core rips cds without error and with metadata but has stopped doing album cover. This is happening with every cd. Any idea? Thanks

I never seem get album art automatically on the Core, just normally the Rovi metadata fields …It’s only when I do a manual metadata lookup after the CD is ripped, I then get the Musicbrainz alternatives as well as typically receiving some album art……

To be honest, it doesn’t bother me too much as I almost always replace the artwork with my own sourced as I find the auto retrieved versions fairly crap…! But I’ve never understood why it doesn’t seem to happen automatically in the first place though….


1 Like

I’ve ripped around 500 albums and most have automatically had artwork but this last week it’s not providing any. Wondering if my broadband is to blame

Do another power off restart….I’m serious by the way.

I can confirm that I’m also having problems with the Core album artwork automatically uploading after a cd rip on two separate Uniti Cores on different networks. I have tried the whole power down process and that doesn’t seem to remedy it. I have officially reported it to Naim as an issue.
Fortunately, the manual album artwork option works fine and the track/album name metadata seems to be unaffected, so I’m sure it will be fixed in the future. How far in the future remains to be seen.

1 Like

I too had the same issue yesterday when ripping a few CDs, couple of weeks ago no problems. I will try the power down routine next time I go to rip thou it does seem odd that a few of us have had the same thing occur this week.

1 Like

Tried David. Same problem. Ripping cd and metadata ok but no artwork. Noticed others having same problem this week so suggests problem with Naim or more likely Rovi.

I think you probably have to just wait then. I know Naim is looking at Rovi changes at the moment. So hopefully it won’t be too long.

1 Like

Thanks David. If you hear any more from them let me know.

Whilst they’re at it, hopefully they can finally mature the firmware and App and at long last support some extended metadata fields….Well I say ‘extended’, but hardly really….
I’m not sure Artist/Album/Track/Genre/Art is that sufficient these days🙄…it was lacking even back in the days of the US/HDX etc……
Perhaps when VerVent is sold some funds can be put into some software/UI development….! :crossed_fingers:


Confirmed. I ripped 3 cds this week and none found the artwork. I did that step manually through the app and all is good, but should not be necessary. Something has changed, this problem did not exist before and i have easily 1500 cds on the Core.

1 Like

My Core is fairly new and I’m right in the midst of a huge ripping session, aiming to get all my existing CDs re-ripped once and for all before discarding….As I have said, I have never had the artwork come in automatically since I’ve started, only when I do the manual look-up…So I was never sure if this was ‘normal’ and another quirk of the Core….Seems from longer term users here it normally (or used to) does come in automatically….So I guess there’s an issue in the Look-up chain somewhere, and has happened in the last few weeks….
Would be good if Naim could offer any insight instead of us all just guessing……

As far as I can tell, I also only seem to get the Musicbrainz metadata (which I tend to prefer as a basis) if I do the manual step, though for all I know this could be the normal function if Rovi metadata has been found at the initial lookup when the CD is inserted…?

I think once this lot is done, my plan will be to move all the MQ files away and treat them all through SongKong/Jaikoz, get everything tidied up and populated in a more extensive way, as per my purchased 24Bit music….and then there’s the thought of Roon……


Seems like it’s a common problem with all Cores everywhere (not finding album art earlier, need to lookup metadata first, or add manually) :thinking:, including mine. This occurs just lately, I wonder if there’s some firmware update recently that caused this.

Somehow I also feel recently, my Core become a bit more “sensitive” to indicate errors while ripping (although nothing really disturbing during play).

My Core is on Ver
Which was the initial update it wanted to do when I first turned it on out of the box…

Sensitive?! I’d say…! Fingers crossed, I haven’t had all that many indicated Rip errors and what ones I have had I’ve normally been able to give the CD an extra clean and re-rip with then no errors……What mine does do fairly often however, is just spit CDs out for no reason (which coincidentally, or not, also often seems to take the Core off the network and disappear from the App for like 2-3 secs)…Reopen the App, go back into the Core, reinsert the CD….and all proceeds fine…! :man_shrugging: