Uniti Star Display Disappears after Firmware Upgrade

My Uniti Star performed a Firmware upgrade to version just over a week ago. Since then the display on the unit has stopped working. I can access all features via the app but the front panel display is black. I have tried powering down for an hour, factory reset, increasing sleep time to 2 hours, turning on and off the new ‘Sleep during Playback’ feature. When restarting the unit the boot screen appears then I get the home menu. Initially the input menu is in list mode but suddenly changes to icon mode. After a few minutes the screen goes blank and I can’t get it to turn back on. Anyone else having this problem? It certainly has all the hallmarks of a software problem.

Have you contact Naim support (support@naimaudio.com) about this? If not, I would recommend you do so.

1 Like

Yes I have thanks. No solution as yet. It’s been referred to their software team. I’ll post here if I get a solution. I’m curious to see if anyone else is reporting the same problem.

This is on purpose, and was a request of the users of UnitiStar. Go to the settings on Naim app and check the preferences on the Display.

Display on my nova had been fine with it coming on for 10 secs when vol change etc is commanded from either Roon or the naim app but tonight nothing. Reboot and it’s fine. Nova was in standby for two days.

I have done that and it makes no difference at all Lekain. Thanks.

Looks like a few people are having the same issue with Nova’s. I’m convinced its a bug in the firmware update.

Interestingly my display went haywire after I turned off the server mode…it’s been fine since I turned it back on

Nope it’s frozen on home screen. Music played but the display stays on the home menu until I tried several different commands on the remote, then good again

Well it wont respond to anything now so unplugged. Odd as it was perfect until yesterday?

Same here, frozen on home screen. I had to unplug.
The Nova is disappointing so far

+1. I had the same thing happen. I cycled my Nova through ‘deep sleep’ and all was good again.

Damn thing is frozen again this morning. I can get music via the app the non of the buttons respond on the remote apart form power and vol , no buttons work on the nova and it’s stuck on home screen

This is clearly a very annoying firmware bug. Naim had better get their act together and issue another version pronto.

Same here on my Atom. The screen freezes on home screen but it is less bright than it normally is.

Yep I had that yesterday but today it’s all fine?

What did you do that changed the situation Hifi-dog?

Nothing! It had a hissy fit yesterday pm with dim home screen so I put it into standby and back again and it went back to hone screen then bingo the radio stn I was playing appeared and it’s been fine since.
No idea why?

I’ve emailed my dealer about it and he’s had no other customers with issues so it’s entirely random. Odd as my nova behaved impeccably for the last year and was fine after the update for over a week

Standard phrase from the dealer:
“We have not heard of it jet”