Unitiserve not connecting

My Unitiserve was repaired last year by a Naim under warranty as the wireless stopped working. It had previously connected to my iMac with no issues.
Since it’s return it cannot be connected to my iMac. It rips my cd’s and plays perfectly but I cannot download from my computer and transfer to the Unitiserve. I spoke to Naim who sent me away to look at file sharing on Google! Has anyone else managed to sort out a similar problem?

I take it you mean that the Ethernet stopped working, as the Unitiserve has no WiFi.
There may be an IP address issue if the repaired unit has had its software reloaded, or a factory reset. The first thing I would try is a router restart. If that doesn’t work, a full network restart might do it. That means turning off your router, Unitiserve, computer and any other devices. Then turn the router back on, and let it fully start up. Then start the other devices one at a time.
If that doesn’t work, you may need to dig a little deeper.

Hi Chris,

Yes , the ethernet card or some such item had to be replaced. All of your suggestions have been tried, my dealer has also tried to speak to yourselves with no success in obtaining an answer. My system has been completely disconnected as I invested in in new rack and was put back together by my dealer so everything has been completely turned off at some point.

My iMac can see the unitiserve as nssrvb957 but fails to connect. If you click on connect as a registered user it asks for a password which I do not have. Did not have these problems before Naim “repaired it”. I am very dissapointed that it returned with a problem it did not have and that Naim have been unable to resolve this issue as this stops me using the Unitiserve as I wish. I have been a Naim user for around 16 years and last year invested in new items totalling around £7000 , so this is why I am a little dissapointed not to be able to resolve this issue which has been ongoing since last year.

Kind Regards


To be clear, I’m just another punter like you! This is a primarily discussion forum, not a support forum.
You don’t need to log into the Unitiserve with a password, just connecting to it as a ‘guest’ is all you need. I would get back to your dealer and ask them to help, with support from Naim if they need it.


A few questions please.

Slightly confused when you say tha iMac can ‘see’ the Unitiserve but not connect to it. When you look on finder do you see the Unitiserve on the network and if so are you able to view the files?

Have you N-Serve installed on the IMac and if so does this see and connect to the Unitiserve?

When you say that the Unitiserve plays ok is this to a streamer on the same network as the iMac?

Hi Chris,
Apologies, for some reason I got the wrong impression from yourself, my mistake. You are correct in that this was how it worked previously. It will not connect as guest and yes I have been back to a dealer who I have used for over twenty years and neither the dealer or myself has been able to get an answer to resolve the issue. As I stated before, all Naim told me to do was look up file sharing on Google and my dealer cannot get a reply.

Hi Camian,
Sorry to be confusing. To answer your questions, computer, Unitiserve and streamer etc all on the same network.
Computer can see Unitiserve in Finder but cannot connect.
n-Serve is on the computer and connects, but you cannot download Hi res files onto n-Serve from the computer this way, the iMac has to be connected in order to drop files onto the Unitiserve. So I have no way of transferring files from the computer to the Unitiserve. Previously I could drag and drop files on my iMac into a download folder on the Unitiserve but it was connected through Finder
So , in other words, I can rip cds and play them from the Unitiserve via my streamer, but I cannot download files from my iMac onto the Unitiserve.

Are the Music and Downloads folders visible in the Mac Finder? If not, what happened when you click on the Unitiserve to try to open it?


That doesn’t make any sense, everything is clearly connected on the Network so something appears to be a problem with the IMac

Chris beat me to the question below but in addition have you tried rebooting the IMac?

I can see my iMac download and music folder in Finder, but not any Unitiserve folders. I now have to click on network in Finder to see the Unitiserve and it fails to connect. If I then try to connect either as a guest user or registered it fails. And guys, this problem has been ongoing for months , it is not new, iMac has been rebooted lots , system has been apart, routers turned on and off again lots of times. My dealer is as confused as I am. Next step is to take into dealer to see if they can connect up to their network.
If it is my iMac then I have no idea why it worked perfectly well before as nothing has changed on the computer.

But sorry. Try another PC or at a friend’s house so you change internal network …

Thanks Andrea, have already tried a windows laptop, with the same results, unable to connect, but this was on the same network. So maybe trying on a different network a good idea


From what you are saying this does not appear to be a network problem and thus not a problem with the Ethernet card in the Unitiserve, if it were the streamer/N-Serve would not work. I assume you can see the Unitiserve in the Naim App.

Andrea’s suggestion is a good one, if you have a laptop connect it to the network and see if you can access the Unitiserve through that. If you can, it would appear to be something with the IMac interface.


I promise I will be through with daft questions shortly but this is a 2tb Unitiserve you have here?

No such thing if it helps, it is a 2tb version

i have regularly the same problem on my pc: the unitserve appears but it’s disconnected ( in red cross on the screen). When i double click on the unitserve, some seconds after it can connect again.
If i am talking about the same problem, it should work.

Camian - the network card was replaced as the original problem was with this and as you quite rightly say , it would not connect to the network

i wanted to say double click on the unitserve on the pc screen. ( unitserve downloads or nssr downloads)


This is a real conundrum and I don’t know the answer I’m afraid. I know one thing though, Phil Harris would have done.

Just try one last thing, if you are able, can you post a screenshot of system status in N-Serve.

Good advice, but this does not appear to be the problem. Unitiserve is connected on the network but the file structure is not accessible, we and the OP and his dealer do not know why.

I have had much appreciated help from Naim’s software manager in the past and with your permission Ian, I would like to alert him to this.