Unitiserve SSD battery

Indeed, you don’t need a mouse, just a keyboard.

Only reason I don’t recommend USB, is that I have not tried it before! YMMV.


In theory, as long as the generic drivers are present in the (very old) operating system, USB peripherals should work ok.


Hi NeilS,
I have just replaced the CMOS battery and reconnected the Unitiserve to the power and router.
After switching it on again the Green Naim Logo still flashes constantly and cannot connect to the internet. Should the flashing stop when the battery is replaced or does it need to be reset to default settings before it stops flashing?

I know what NeilS would tell you. You have to reset the CMOS to the Naim default. So turn it off again, connect a VGA display and a PS/2 keyboard to the US and turn it on. You will see that the startup pauses after the memory check and you have to use the keyboard to highlight and accept the Naim defaults. Then it should finishing starting up and you should be rewarded with a steady front logo light!



Thanks davidhendon I don’t have a VGA or play station / 2 keyboard but tried connecting to DVD recorder and TV via s video connections. That didn’t seem to work. Thanks for advice. Don’t really fancy paying £395 for something that should be a simple fix. Bought 2nd hand from a Naim Dealer just over 6 months ago had a quick check when I got it worked fine went back to setting up with my new system last week and found flashing light. Replaced battery and still flashing.

Its not a play station/2 keyboard! It’s a PS2 keyboard which is the old single plug that everyone used before USB. Recently one forum member said you could also use a USB keyboard. You might also be able to use something other than a VGA monitor. In any case you could buy both second hand on eBay quite cheaply I think. You should talk to the dealer because he may be able to set the defaults for you. It takes just a few seconds to do. No need to send it back to Naim.

But you do need to get the default settings set somehow. It won’t work otherwise.



Thanks, that makes it a lot easier.

It must be a VGA monitor - when the CMOS battery dies, it restores defaults (not Naim defaults) and the s-video port default state is off.


1 Like

Thanks NeilS much appreciated. I’ll give a spin tomorrow .


Job done. Many thanks! Just need to find out how to connect unitiserve to my Uniti Atom.
Cheers, Thedon59

Correct. I had the blinking light so I opened the unit, changed the battery (not sure if it was bad or what but did it anyway).

Then I had to connect it by VGA. A USB keyboard was enough.

Thanks for the help!

This thread has been VERY useful!! I had the same ‘blinking’ problem and i had absolutely no idea it may have been something to do with battery change. after which followed same process as above and the blinking seems to have stopped and i can now ‘see’ the Unitiserve from my iPad network analyser. More importantly, the NDS can ‘see’ (and play music served by) the serve so seems all is OK now.

If all this isnt in the FAQs, then i would argue it should. If it is already there – then sill me for not searching there…


It’s not there because Naim doesn’t like to encourage DIY repairs. But this is such a simple thing to do and could save someone shipping a US half way round the world, so in the last few months there have been many such threads, all about the Unitiserve battery change, and it’s become acceptable to discuss it somehow.


Works great the US, but still I haven´t been able to do a backup, what a pity

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.