Wi-Fi connection regular disconnection from network

Dear all
I have an Atom that is great when it is up and running but alas I almost always have to switch it off and on in order for the app to find it. It is incredibly frustrating. I have a talk Talk Wi-Fi hub (FAST 5364) connected to a gFast MT992 Modem. This gives a solid 125mb/s. I have tried reserving an ip address and switching on server mode with no effect. Bluetooth is on on my iphone and iPad. I have the latest firmware and app version. I have tried factory resetting the Atom. Does anyone have any suggestions that might help? Many thanks, Guy

1 Like

Is it possible to hardwire the Atom to the router? That often solves these problems. Alternatively you may be able to get the Atom and router closer together. Server mode won’t help. I’d forget fixing the IP and reverting back to DHCP.

We had a wifi problem that was solved by switching off the 5Ghz.

Might not help, but it’s free, simple to do and reversible.

+1 try turning off the 5ghz and or only using the 2.4ghz band.
If I have both on my FAST wifi router I’ve had problems.
Mine are now named separately so I can be sure my ipdad / iphone is connected to 2.4 band

Oh dear it sounds like a sub standard wifi lan controller on the Talk Talk hub. I thought ISPs were using quality devices now… perhaps it just the bigger ISPs that do.
Just remember by switching off the 5GHz channels, you are disabling the whole of wifi 5… and forcing older less efficient protocols … but if it’s the only way you can get your hub wifi to work properly, you have no choice.

Simon, I forget to mention on another thread, when I combined both 2.4 & 5Ghz networks, I ran into problems again, so until I get a proper Wi-Fi network set up by my dealer, I have separated them again.

When I turned off 5Ghz every device in the house worked just fine. Even a Roku 4k TV streaming dongle.

If somebody finds only using 2.4 is a problem, it’s easy enough to switch 5 back on.

1 Like

Thanks so much everyone. I’ll switch off 5ghz and see what happens. We are not exactly power users so it maybe ok. If it’s the router that’s the problem should I fork out for another one? Not sure whether the gFast thing means that I can’t get an ordinary router. Guy

I definitely echo this recommendation. Always hardwire if you can.

Sure it’s WiFi 5 or 802.11ac that only works on the 5GHz ISM band (and the now rare 802.11a), so unless you have a more recent wifi such as wifi 6 (or newer wifi 6E adds the 6GHz band wifi 7 work slightly differently so it’s unlikely you would disable a band), then you are forcing all the devices on your home network to work on old inefficient wifi protocols.

But it does sound like there is a wifi fault on those hubs… I hope you have let them know, they might replace it for you. Having to disable most of the wireless radio bandwidth spectrum to get the thing to work with home devices is ludicrous.

If you have a capable WLC in your ISP hub you could set up a separate SSID supporting only 802.11ac or 802.11ax, and a different SSID for older protocols. You can let all your non legacy devices connect to the 802.11ac SSID… that would be a better way of handling the situation (and can be beneficial in a home with a range of wifi devices which could be upto 20 years old) , and is better than the sub optimum way of disabling much of the radio spectrum your wifi wants to otherwise use. (Some of the legacy wifi protocols use 5GHz )
If you only have two or three devices on wifi then probably this is inconsequential forcing a wifi downgrade to legacy wifi protocols, but increasingly homes have many devices on wifi… from door bells to washing machines and mobile phone wifi calling. (Most mobile phones will now use wifi if they can instead of over the air, to give better performance inside)

1 Like

I don’t know if I am understanding this correctly, but from a previous post of yours I thought that if I had 2.5 and 5 GHz enabled that it would show up just as one wireless connection and each device would choose which frequency to connect at, whereas with my virgin Hub modem if I select both 2.5 and 5GHz they show up as two individual wireless connections?


I depends on the capability / quality of your home router WLC. One shouldn’t confuse radio spectrum band with wifi networks.
So a wifi network can use one, two or more radio bands (2.4, 5, 6) depending on the wifi protocols being used.
For best performance you should let the wifi protocols use all the bands it has available and it can support for a given wifi network (SSID).
Some protocols like 802.11n, 802.11ax and 802.11be (wifi 4, 6 and 7 respectively) hop connections (steer) between bands, within a network SSID so will manage the load of connected clients depending on the radio bands and protocols a particular client supports.… so you dont want to cripple your wifi controller by starving it of its radio spectrum.

At a data level, on most home/consumer router WLCs built into routers, the wifi networks (SSIDs) are connected to each other using a network bridge so everything appears as a single LAN. It is this functionality on some poor/cheap ‘router’ devices that seems to be a bit questionable.

So if you can, unless there is a very good reason not to and you know the details of what you are doing, you should use a single SSID / wifi network on your home network.
If your router WLC has compromised or very limited capability you will have to do whatever to get it to work, but then think seriously about replacing it.

Wifi protocols have massively transformed over the last 10 years or so. Artificially limiting radio spectrum feels like tweaking the antenna on top of an old black and white TV set to get a picture, when most others are watching 4K UHD on a flat screen, but if you only have an old black and white TV, that is all you can do…

For what’s it worth I use a single SSID on my home network, and support protocols using 2.4 and 5 GHz either jointly or separately radio bands…

Everything connects and sees each other as a single network. I use Ubiquiti equipment.

1 Like

Thanks Simon for the comprehensive reply. I think my issue might be that I added 5G to the name of my SSID so they de facto have different names. I am going to change them to the same SSID and hopefully it will work as you describe. Unfortunately my router seems to think I am logged in in another session and won’t let me login currently so I’ll have to wait and try it later.


Good luck… perhaps it’s time to update the wifi :wink:

That’s done the trick, now only 1 SSID showing and my iPhone speedtest gave me 250Mbps download whereas with just 2.GHz enabled I was getting around 50Mbps.

Thanks again for your help.


1 Like

Brilliant, glad it worked out.

2.4Ghz is limited to max 50mbps, (or is it 56) but presumably that is 50mbps per device.

Just checked my wifi, it’s running exactly 50mbps.
4K TV requires 25mbps, so with my 100Mb virgin broadband, I could stream to four 4K TV’s at the same time, on the 2.4Ghz band. At a push. :grinning:

2.4 band is not limited, it’s the protocol you use, how many other devices there are on the channel, channel width, and how much overheads and interference there is. The old protocol 802.11g which only worked on 2.4 GHz had a theoretical max throughput per client of 54 Mbps. The even older 802.11a which only works on the 5GHz band also has a theoretical max bandwidth of 54 Mbps

Ok. That rings a bell.

I seem to remember that I had to set the router to 802.11g when I bought a QB1.

I understood that this limited everything on 2.4ghz to 54mbps.

At present, nothing on WiFi is above 54.

But as the Roku 4k TV is working at 26.95mbps, it’s all good :+1:.

You don’t need to restrict the SSID to 802.11g, as devices will connect based on their capabilities. (Certainly my experience with the Qb gen 1.)

1 Like