Wifi /network connection problems

Hello Naim/Focal community, My Muso QB2 sounds incredible when it works. Unfortunately in the last 3 months it has struggled to find my Home Wifi network on a consistent basis. I use an Orbi Mesh system with 1 router and 3 satellites for my home Wifi network. My broadband comes from Virgin is FTTP and regularly provides 850mb+ of Bandwidth. I have converted the Virgin router to a Modem setting which is attached via ethernet to the Orbi. My home Wifi is very robust and stable. It has hosted up to 20+ devices with no bandwidith limitations or buffering issues. On my big Hifi I use a DCS streamer and their App Mosiac. I never lose the network with the DCS or App. The only time there is problem is if there is a Virgin network problem outside of the home network. Thankfully very rare in my neighbourhood.
So the issue is the Muso loses the network and then does not reestablish itself on the network unless I power it down at the wall and then turn it back on at the wall. When I check my Wifi network I can see the Muso QB2 listed as a device, I can see the network is connectwd via the Orbi Satellites but the Muso connection process just goes round and round failing to connect. If I use the Naim/Focal software to check the network it will usually, but not always, identify the Muso on my Network but it will not connect. I have owned the Muso for about a year and it has had the WiFi connection problem for the last 3 months. I believe it has something to do with a recent update to the Naim/Focal app. I use a Samsung S20+ as my controller. The handset is attached to my network and has a full signal
Wifi connection throughout my Home. Any insights and comments are most welcome. I have not tried “hard wiring” the Muso to my network using an ethernet cable. I could do but sort of defeats the purpose. Thanks

Long and short is, if you can hard wire do so. Wifi issues can be insanly annoying to work out, and often the simple solution is the best one.

Thanks Gary. I am sure a hard wire will work but defeats the purpose of the small stand alone Muso QB2 cube to have an ethernet cable running out of the back. Trust me my Big Hifi is a sea of cables and cords. My view it is a software/Firmware problem that needs to be fixed/patched by Naim/Focal which is why I posted the topic

1 Like

I had terrible problems with my Naims when I had an Orbi mesh, with boxes disappearing regularly. I then tried two other mesh systems, one an Asus Zen and one a Google Nest and both had issues, though neither as bad as with the Orbi. In the end I ditched mesh and went for a Netgear Nighthawk, which - touch wood - has been fine. Nothing other than the Naims disappeared when I had the mesh and I never worked out what was wrong. The Naims were wired to the mesh boxes and I had wired backhaul. The hours I spent trying to sort it out…. Usually boxes vanished, and nothing I could do would get them back, and then lo and behold they reappeared a day or so later with no intervention from me. It was just weird. You have my sympathy.

2 Likes

I have Orbi mesh, but my Naim device is hard wired. The only problem I have with the Orbi is in the last year, I found it needed rebooting every week or so. Now I have all the Orbi devices plugged into Smart Plugs and they get powered off during the night which has solved the issue.

Can I assume you have checked that the Backhaul Status of your Satellites is GOOD? Also, whilst hard wired is a pain, I would suggest it as part of a diagnostic process. You could hard wire to a satellite if one is near.

Is the Muso near enough to your router, such that you could enable WiFi on the Virgin router with a different SSID, and connect to that - again as a diagnostic test

Also under the Orbi settings, you could try and reserve the IP address on your MuSo.

Yes reading your description, this sounds possibly like a bad implementation of IGMP snooping somewhere on your network … possibly your WiFi controller.
Look for a setting on your wifi controller, switch and/or router and if enabled, try disabling.
If that works pester the manufacturer of the device you disabled it on for a newer firmware update.
If it’s disabled, try enabling it… does that then work? (Depends on how your product implements this)

Usually important to have IGMP snooping enabled to keep your network working efficiently as it can with respect to transmitting group data.
Also ensure you are not disabling or ‘optimising’ multicast group data on your wifi … unlikely, but worth checking,

Devices ‘disappearing’ from the apps such as the Naim app, but physically being active on the network is usually a sign of an interruption of SSDP by a network device. If the SSDP group address is not correctly monitored by a network device on your network that manages group data like a wifi controller/bridge, it will time out, and the end device is removed from the group… and it ‘disappears’. This monitoring is called IGMP snooping.

Some ISPs, ie BT, now incorporate IGMP queriers into their routers that make this sort of thing less likely., and Naim themselves last time I looked made their software compatible with different ICMP versions to again provide as best interoperability as possible.

@Craig1 do you have Sky Q - if so, how is it connected?

Amazing how it seems it’s always only the Naim kit that has issues with our home wifi, yet we have to find solutions in the wifi network rather than the naim box…

1 Like

Sound Hound, I have Sky not sure what version. Probably Sky Q. Connected via satellite but these days also connected to my network via ethernet cable from the set top box to the nearest Orbi satelitte. Are there issues with Sky and Naim dvicws on the same network?

Jamie, agreed. Hence my post. I am trying to be professional, considerate and polite. Bonkers actually

Gadgetman,

Thank you for your response. Yes my back haul status is all good. I have worked hard with satellite positioning to consistently get a good back haul status from my Orbi anchored network

Simon, Thank you for your detailed insights. I will do some investigating this evening when I am home.

If you don’t know what version of Sky you are subscribing to, a pic of the box will identify it, posted here, or you can identify it yourself!

The issue is not Naim and Sky on the same network.
The reason I asked the Sky question, is because, in recent past, the Sky forum has been alight with issues and network probs which Sky Q causes. I rejected Sky Q as an upgrade.
You could try totalling switching off Sky Q, if that is what you have, and then see if you have issues with Naim kit and app.
Establishing a stable network environment is key to having reliable Naim kit and app. I have a number of streamers, Muso Qb2, Muso2, first gen and next gen kit. No issues whatsoever connecting to all, promptly and seamlessly.
I can appreciate to read such is frustrating, but a stable and reliable network is key. Not all wifi / network kit is equally robust; significant variances exist. @Simon-in-Suffolk has long and significant experience in this aspect of networking. I have followed his advice and indeed of those who very long ago, posted similar advice. It would seem there are good and there are less than ideal network solutions.

I agree that @Simon-in-Suffolk knows his stuff and his answers have often been helpful. I just wish I understood more of what he is talking about. :wink:

Do you think I do :wink:

BTW no issue of Sky Q on the same network as Naim, I have been doing it ever since SkyQ came out… absolutely no issue what so ever. Sky Q uses native layer 2 network addressing and is rock solid, therefore you want a good simple network in a single subnet … definitely no routing between home networks or NATing in your home network setup… pretty similar to UPnP in that regard.
Unfortunately some consumer network devices, especially some WiFi consumer solutions appear to screw this up… keep well away from those. Ensure your devices both on Ethernet and wifi can all work within a single subnet with no NATing and you should be fine.

2 Likes

Thank you for all the detail and in some cases technical responses to my questions. I have no doubt a detailed analysis of all the devices on my network both ethernet and wifi connected would uncover a problem device or protocol. The big question which no wants to address is why the Naim/Focal device/app is the one causing a problem? No problem with my DCS/Mosiac connection also controlled by my Samsung S20 handset on the same network? Or my Laptop based desktop music system controlled by Roon. Also on the same network? Why are Naim not engaging on the support? Really not good enough!!

2 Likes

You could try with the 5ghz WiFi band switched off.
A few Naim users have found that doing so, made connectivity problems disappear.

1 Like

Classic example of interoperability issues between bands, which some router manufacturers don’t address.

Many Naim users have no issues with wifi connectivity. I installed Ubiquiti WAPs in two separate buildings a decade ago, never had an issue. Provided Naim has adhered to the various specifications for wifi, which it is likely they have, why is this Naim’s problem to address?
How many makes and models of router are there worldwide in use? Hardly realistic for Naim to check the performance of every one.
If Netgear, mentioned in an earlier post by HH, are selling kit which reportedly doesn’t function well against alternates, then any assumptions about reliability et al, may be misguided. Against alternates, it is also not a lower cost choice.
This isn’t by any means the first thread with issues where Netgear is involved. It is unfortunate but afaik, Netgear is not ISP supplied, so consumer choice.
Plenty of threads and posts about wifi kit with which peps have good experience.
Understand the frustration Craig, so hope you find a workable solution.

Not really - different wifi protocols only work on specific bands and some on both. The newer standards merge the bands together as it were… and there are new bands on the latest standards

So this is really only an issue if try and force different WLANs to use different bands, which was popular in some quarters several years ago with older protocols. This is such a bad idea- just don’t do it now.
If you want to encourage one band over an other - use bandstearing if your devices and wifi access points support it. Old devices will use what ever bands their firmware and radio hardware supports.
These days wifi is ubiquitous and really should not be problematic unless badly setup or you have driver problems on your clients. Wifi us usually preferable to ethernet for end user clients these days

If you have many old devices - (ie 8 to 10 years or older ) then enable maximum interoperability on your wifi controller - this will enable older protocols on you WLAN but at a cost of overall performance. Some times this is shown as enabling older protocols such as wifi 4 or 802.11n. Wifi 4 used both ISM bands.
Unless you know what you are doing - I encourage one to set max interoperability or enable all wifi protocols - and then slowly disable one by one the older protocols and see what stops working.

I had a similar issue with a Muso 2. Orbi mesh network. ND555 and Nova would both connect but Muso refused to. I just hard wired the Muso to the mesh router in my kitchen which works fine and reliably. I already had the Nova and ND wired and only put them on WiFi to test. Naim support essentially said wifi6/mesh not supported when I emailed them at the time.