Delay Finding Rooms in Naim App

They will likely address this and the “frozen screen” with next firmware update

1 Like

As a further test I have now also installed the Naim app on my Android phone. Same network and streamer, obviously. This does not have the same issue, and finds the device immediately I open the app. So it does look like a specific issue with the Naim app on iOS.

I just had my dealer remotely set my NDX2 to an assigned IP address and it’s always there when I open the app now.

I used to have a delay of typically somewhere between 3 and 10 seconds before the app would find the streamer and again before it could find my media server, occasionally this would get to be 30 seconds - it was all rather irritating.

Well, my Naim app now reliably finds the streamer in less then 2 seconds, then goes on to automatically find the NAS music servers again in less than 2 seconds. Often the whole operation is completed less than a second.

The change I made?
Using a faster router to provide the DHCP server for the LAN.

The old one now just acts as an ADSL terminal adaptor.
(Sometimes a TA is inaccurately referred to as a modem: a TA does a similar job but for digital lines).

Xanthe, this is nothing to do with DHCP, that’s a quite seperate group of processes, functions and addresses.

This is about home network product (likely to be home router) interoperability on Wifi with iOS for broadcast and group addressed data (multicast), as well as group snooping functions where present. A lot goes on with Wifi underneath the covers for it to work well in a general purpose network… and some Wifi routers do things a specific way that can cause interoperability issues.
It appears that iOS can loose the group addresses data in some circumstances and not present to the Naim app, and this can affect not receiving discovery messages.
It may be possible for Naim to to modify the app to bypass the Apple bug or ‘feature’.
Fortunately I don’t suffer from such issues with iOS, but I use Ubiquiti Wifi access points.

A work around if you have certain iOS discovery issues with your Wifi access point, and you can’t follow the Apple support recommendations, or they make no difference for you, is to nail the connection up to avoid the need of subsequent discovery sessions in the Naim app… but increases iPad / iPhone power consumption, but worth a try if you are really stuck.

1 Like

I appear to have resolved this problem which was affecting both my ND5XS2 and Qb2 :-

A Solution for me at least !! :sweat_smile:

Prompted by @Simon-in-Suffolk 's references to IGMP I have reduced the IGMP ‘General Query Interval’ from 125 seconds to 30 seconds under the ‘IGMP Proxy’ application controls on my Draytek Vigor 2862 router. I did this based on the frequent timeout when trying to connect to ‘rooms’ under the Naim iOS app - Now both of my ‘rooms’ (a Muso Qb2 and a ND5XS2) connect to the Naim iOS app on both my iPads without fail over the last 2 days since I made this change.

I run an Ethernet cable (BJC Cat5e :slight_smile: ) from the Draytek router to a Cisco 2960 switch (I have not checked the IGMP settings on the 2960 - since the problems have receded), then an Entreq RJ45 Primer cable from the switch to the ND5XS2, a Melco RJ45 patch cable from switch to the Melco N1, and a BJC Cat5e from switch to the MBAair (Roon Core) . The ND5 XS2 is 5 metres from the router for the wi-fi connection.

The Qb2 uses wifi connectivity to the router downstairs from its upstairs location.

Other points:

This has been a a frustrating issue since with Linn Kazoo & Lumin app (for Melco N1), and with Roon for the two Naim devices with a MacBook Air as the Core (RAAT and Airplay), have not had similar connectivity issues. At least I have workarounds.

I do not currently use the ‘Player RJ45’ link from Melco to ND5XS2 as I cannot discern any improvement in SQ over going via the switch/ND5 XS2 or via the direct USB link into my DAC when using the Melco as a player - and I did suspect it might have had a bearing on the ‘finding rooms’ issue with Naim, although it was as (un)reliable as the direct connection

PS. I did previously have to change my router (BT HomeHub 5 to the Draytek) to get reliable connectivity for the Melco - the dealer had no settings /solution for the BT HH5 apart from ‘change the router’.

I hope this helps others.

1 Like

BTW you may find the new BT Smart Hub 2 works well in this regard and is also a top modem performer on VDSL. My 2960 confirms the BT Smart Hub 2 handles igmp queries well and nicely works with a Naim and more advanced network equipment.
Glad you got it working…

Thanks Simon.

1 Like

the app finds my NDX2 much quicker since the recent FW upgrade

…with the software upgraded yesterday, the connection has taken place on first try each time I have used it so far. A few seconds of my life back each time I use the product and at my age I enjoy every second I have!


The app Finds my ND555 much faster since the firmware update I applied today - it was rather irritating but now perfectly acceptable

Same here with ND555 upgrade.

For the past few weeks I’ve been having an ‘app’ issue which I think it’s worth telling because it might potentially help others.

So the problem has been the app would occasionally crash saying it couldn’t see the streamer. I have the app set to keep the link permanently live so this shouldn’t happen. If this happened you just had to go back to the equipment page and it would refind the NDX and then it was fine. However this was starting to happen with increasing frequency. Then, on Monday, I noticed that Netflix was starting to complain and this coincided with the app conking out. So I’m thinking what’s the connection? Perhaps it’s the internet connection dying. So lots of checking with the ISP and also the router logs… nothing of note. Anyway after an extended swapping items out session (AP, switch, cables) it’s turns out it was my router! It was confusing because the AP and the NDX (and the NAS) are directly connected to a 1gig switch. So the traffic doesn’t actually go through the router! Anyway it seems the router was having a little blip. The tablet detected this and tried to redo it’s DHCP request and this caused the app to get upset. The test was to swap out the router for cheapo unit borrowed from work. Swapped this and no issues for the last 2 days. A strange one and, tbh, I think the average home user wouldn’t have had a clue what to do. Fortunately I had access to a stock of ‘spare’ parts to swap out but even so it has still taken many hours to resolve.

Now I just need to get the VPN working on the replacement router and it’ll all be sorted: 4 hours yesterday evening trying to get the VPN working :frowning: Ho Hum :slight_smile:

Hi. Most people completely underestimate the needs of IoT boxes like Naim Audio, and at the same time completely overestimate the performance of their wifi router. In my experience (and it’s A LOT, trust me please), the ISP provided router is basically useless. Avoid powerline adapters and ‘wifi extenders’ like the plague. Ethernet connection is the best for boxes that CAN be wired, leaving a DECENT wifi system to do its job. There’s much more to networks than just wifi strength (which is but one factor in getting your devices to play nicely) - you also have to understand that Naim in particular requires adequate MULTICAST communication implementation (meaning one server can service multiple streams to multiple devices). Almost ALL ISP routers do a miserable job of this crucial routing protocol. If anyone wants to understand why multicast routing is a problem for cheap routers, I can happily explain as much as I understand.

A simple solution for most people is Netgear Orbi - and I’m not paid to say that. It’s cheapish, scalable and can be set up without too much drama (though there is a cool UFB cheat I can let you know at extraordinary prices j/k - just ask). Most importantly it handles multicast traffic really well. After that, if you have the necessary ethernet cables already run, try Ubiquit’s EdgeRouter, PoE switch and on-wall/on-ceiling APs. But you’ll likely need a techie to set that up.

1 Like

Yes these things are straightforward normally, but when a home network component fails or goes wrong, there is usually not too much in the way of diagnostics / logs for the average consumer device.
Anyway glad you got it sorted…
BTW a host should only issue a DHCP request if its leases expires or it detects it has a new connection…or if smart enough, if it detects it has a duplicate assigned IP address… oh the fun and frustrations of ipv4… wish we could all move to ipv6 and be done with this… give me stateless ipv6 address allocation and NDP any day… alas Naim only support ipv4 currently.

1 Like

Countries aren’t allowed to make people stateless, it’s contrary to international law! :frowning:

1 Like

For people too right

For IP addresses stateful assignment and associated protocols are restrictions imposed by the inherent limitations of IPv4. Although to be clear stateful assignment can still be used for IPv6 - one would only do in specialist scenarios and the average home user wouldn’t need to. Home networking with ipv6 can become more plug and play and robust…

in fact if human rights extended to IP addresses - you could argue ipv6 is more appropriate as it lets hosts determine their own identity within a subnet or globally rather than have the identity typically imposed on them as in ipv4 :grinning:

btw I’ve fixed the issue with intermittent finding the streamer when the app comes out of standby/wake-up… I’ve installed a free app that keeps the tablet awake all the time - brilliant. Never misses a beat. No delays at all. Instant.


But probably best to see if you can fix the underlying issue… as your battery life on your tablet will decline if it’s having to be on all the tine, even when it shouldn’t be required,
It sounds like there is an issue somewhere that sooner or later you will run into again perhaps with another amplication.
It’s a bit like putting Radweld in your car to stop a leak , it will get you home fine or last a holiday, but you want to get your car fixed.

I’ve had three tablets with this issue. Varying android versions. Two are Asus brand and one a generic. Different wifi access points tried. Different everything! If someone can suggest another thing to try then I’m all ears. Since the tablet I use is is a cheap-n-cheerful just for this job then having it on all the times isn’t a problem. If/when it dies in few years then it’s not an issue.