MuSo 2 WiFi problems

When I did a search before posting this I saw that this topic showed up some months ago, but there seemed to be no real resolution.

I have a MuSo 2nd Generation and a Qb first generation. The MuSo keeps not being found in Rooms by the app and also won’t show up in the iOS AirPlay list. I have to unplug and restart it to get it to show up but then it drops out after under 30 minutes. The Qb is rock solid. My first generation MuSo was also very stable but unfortunately I gave it away to my son and bought the 2nd gen with these problems! So it can’t be a WiFi issue. The firmware and app are also both up to date.

I am in Washington DC but we also have a home in Singapore where I have a Unity Nova and a MuSo first generation and they are both very stable with their WiFi connections.

Has anyone found a fix to this that I have missed?

@VikasMG I had similar issues with my Muso-2 on Wifi. It would disconnect itself after one day. I did not attempt to troubleshoot the issue as I was just experimenting with WiFi to compare sound quality vs. wired. It was disappointing because I never have issues with any of my other wireless devices. The Muso should just work! And if it does disconnect it should be able to reconnect itself. I understand your frustration. My Muso is normally on wired connection and I never have network problems. That is probably not an option for you. Maybe someone who has spent more time on this problem can help by posting here. In the meantime there is this general network troubleshooting page on the Naim site

I’m sorry I could not be more helpful. But at least you know there are others who have experienced your WiFi problems with the Muso-2.

1 Like

This could be an issue with your router being “older” and not really fully compatible.
Many ISP standard routers are apparently, not very good and fairly basic.
Naim suggested to me I use a Netgear one from their mid to upper range.
For testing purposes to rule out low signal strength to your QB2, can you try it really close to the router wifi for a few days?

Thank you very much for your reply. Good to know it’s not an isolated problem for me!

Actually my router is very new. I have WiFi access through Verizon and they installed their new router with quite a long reach and I have no problems even in the corners of the house much further from the router than the MuSo is. The QB2 is about the same distance away and is completely stable.

So is mine a new one, but Naim still told me that most ISP supplied routers are not great… They may transmit a decent distance but the ability to handle high quality streams might not be so good.
Here’s the reply I received from Naim when I told them I had some issues with my QB2 with Airplay and Multi-room:

"I am sorry you are having some issues with your Muso qb 2. From your description the issue sounds like it is related to your router. The Muso qb 2 uses Airplay 2. The 1.8 update added this to the 1st generation Muso’s. Airplay 2. Airplay 2 is much more demanding on the router.

The original Muso only works on the 2.4Ghz. The 2nd generation Muso can work on noth 2.4 and 5 Ghz wifi band.

You can try resetting your router. This can sometimes help resolve issues. You do not mention which router you are using. In our experience the free routers which are supplied by ISP’s a very basic and not up to the job of steaming high quality audio and multiroom.

We would suggest using a router from a known router manufacturer, picking one from the middle to the upper part of their range. We use a Netgear router in our office and do not have any issues with Airplay 2 and multiroom."

Personally i dont buy that explanation. Just my 2p from odd behavior of both a Muso2 and ND5XS2, in different countries with different routers (good known ones) and different protocols and ISPs with family using a mix of android and IOS over varying distances from the router that we have moved all around the living spaces we have, both closer and further away from the router

Still odd behaviors :thinking:

1 Like

I agree. There is something finicky going on with some of the Naim streamers when it comes to wifi. These are no isolated incidents. As I mentioned in my post above, the Muso is the ONLY wifi device on my network that disconnects itself.

1 Like

Like the other responders I don’t buy this explanation. I have good routers in both my locations and use AirPlay 2. There is a problem and after several years of using Naim products it’s hard to say this but I can’t help thinking Naim is passing the buck.

1 Like

I also agree with you guys. I simply posted Naim’s reply to me.
I mean, a brand new router from Australia’s main provider (Telstra), using their latest “NBN Broadband” technology and it’s not up to the Muso’s quality?
OK, ISP routers are not usually much good but it’s what “most” people will be using.
My Muso QB1’s both work perfectly, my Muso QB2 does not. There is something odd.
I don’t actually use Airplay so I’m not about to buy another new router to fix something I don’t generally use.
As we only recently switched over to the new NBN fibre service, so I want Telstra support using their supplied equipment, for at least long enough to confirm it’s stable before I even consider messing around with it and a new router which won’t be supported and, possibly not support the VOIP phone which is part of our bundle. Can a third party router even support VOIP and our phone number??
Everything else works perfectly, so I’ll live with it.

2 Likes

I find that unplugging the MuSo Gen2 and plugging it back in after a minute makes it discoverable on the Naim App or as an AirPlay device. Have to wait a minute or two after plugging it back in for it to find the WiFi network again, and its a very untidy work-around, but it does seem to work.

1 Like

I decided to troubleshoot my Muso-2 wireless problem again just because I want to understand what is really going on. So yesterday I unplugged the Muso-2 from my switch and set it up wirelessly. The first thing I noticed is that the wireless connection was 2.4 GHz (I have both 5 GHz and 2.4 GHz on my network). I also noticed that the wireless connection has a different MAC address than the wired connection; not a surprise.

I was using DHCP reservation for my wired connection. So I set this up for the wireless connection too. It all worked fine. Music sounded great. I listened for 2 or more hours. It was all good; until the next morning.

The Muso-2 was disconnected from my network. This is the same result I had a month or so previously. At that time I just went back to wired and did not think much about it until now.

I wonder if the DHCP lease expiring and not reconnecting? I don’t know.

I deleted the DHCP reservation entries on my router for both the wired and wireless connections thinking maybe this is somehow related to the issue. I turned off the Muso-2 then turned it back on. It reconnected itself. It played music with no problems. I notice now it had now connected itself on my 5 GHz network. No problems it played fine. Until …

I went to my browser and typed the url of the Muso-2 (which I obtained by logging into my router) 192.168.xxx.xxx. That will bring up the home page for the Muso-2. I have done this many times when the Muso was connected wired. Now with the wired connection as soon as the Muso-2 home page appeared the music stopped playing. Very odd behavior. I pinged the Muso address. The music started again. The Muso-2 was now connected to the 2.4 GHz network. It’s been playing music for 2 hours now. I did not go back to the Muso home page.

Crazy behavior. I’ll report back tomorrow.

2 Likes

Hi @mike33 ,
As a test propose log into your wifi router and give the 5GHz and 2.4Ghz SSID’s for the wifi network different names.
eg.
MikesNet24
MikesNet5

Then connect the Muso to ‘MikesNet5’.

Also, could you let us know what Wifi router you have (brand, model number)

Best

Steve Harris
Software Director

@Stevesky The networks already have different names. When I connected the Muso wirelessly, I connected to the 2.4 bandwidth. By the way; it’s been playing continuously now for 4+ hours with no hiccups (radio paradise).

Thanks for following up on my post.

Synology Router information is:

image

I also noticed this while exploring around the router settings:

image

Could this explain the back and forth between 5 and 2.4 GHz?

Hi @mike33

Was just looking at the routers user manual. See:

On page 11 it does indicate that the Smart Connect uses some mystery logic to decide who can connect to what. I would suggest turn that off as anything that is ‘smart’ often becomes the thing that makes a mess of things :slight_smile:

Best

Steve

OK so I bought the Mu-so qb gen2 last week. It’s fantastic but these connection issues are so irritating. As the Naim website encourages use of faqs and forum I’m surprised they don’t contribute more here. My issues sound similar. I want to move my speaker around the house occasionally as I can’t afford one in each room. When I have tested this a few times I find I can connect with iPad but not iPhone, or I can connect with iPhone but not iPad, or I can connect with Tidal app but not Naim app, or I can connect with Naim but not Tidal, or I can connect with Chromecast but not…it goes on but you get the idea
I’m no tech expert but there seems no rhyme or reason to it. I am closing the apps each time and waiting for speaker to set up each time I plug in but there seems no pattern or logic to it.
If I can’t find a solution soon I’ll call support
(PS as a single speaker user I also find it irritating having to use ‘rooms’)
So far I have to agree with reviews I read before buying ‘terrific product and sound but annoying set up/connection issues.

2 Likes

@Stevesky Agree about the “smart” features. I’ll disable that feature. I’m going to keep the Muso-2 on wifi for the time being and see how it goes. Thanks for your help.

A couple of years ago I posted details of what virgin call “channel optimisation” basically, the router switches channel if it is enabled. Connection is obviosusly dropped when the channel is changed, most devises cope with this and reconnect.

It might be worth investigating if router changing channel is the problem.

Posted a couple of years ago.

My virgin 3 hub definitely changes channel while in operation. Yesterday, when you said it didn’t, I changed channel to 1 and switched channel optimisation back on, twice it automatically changed to channel 11. (Just to make sure it did)

When the channel changes, the stream is obviously lost. That’s why I suggested turning channel optimisation off to prevent dropouts yesterday.

Apparentley, I’ve been taking part in a secret ‘broadband trial’

Well, my virgin superhub has channel optimisation; the options are ‘channel optimisation off’ and ‘channel optimisation on’ under the heading ‘smart wifi’.

If you’re a bit nervous about changing the settings, take a screenshot of the default setting before changing anything. I did.

I found channel 1 was better than the default 11. However, overnight I’m pretty sure the channel was switched from 1 to 11, even though the channel optimisation was off and selection set to manual.

I also found a significant improvement is gained by switching wireless mode from 802.11b/g/n mixed to 802.11n. My firestick loads pages a lot quicker on this setting.

Apparently set on 802.11b/g/n, the virgin superhub max wifi speed is 54Mbps. (I think). So if you don’t have any ancient wifi devices that requires b or g, try 802.11n. If any device stops working, a few clicks of the mouse will get you back to default.

https://community.virginmedia.com/t5/image/serverpage/image-id/112429iF224215F1FD93FE9/image-size/large?v=1.0&px=999

1 Like

@Stevesky I have an update regarding my Muso-2 on wireless. The Muso-2 stayed connected all day and towards the end of the day I wanted to connect it to my 5 GHz bandwith and also remove the feature on my router called “smart connect” as suggested by you.

  1. The start point is the Muso is connected to my 2.4 GHz network. It’s working just fine.
  2. I turn off the “smart connect” on my router.
  3. I now want to connect the Muso to my 5 GHz network. I go to the Muso home page in my browser (Chrome). I see where I can select a network and connect to it. I select my 5 GHz network. I type my password. I hit connect nothing happens. I try again nothing happens. I realize the Muso is now disconnected from my network.
  4. I use the Naim app to set up the Muso again. Turn off power, pull plug, power up again. The follow the steps in the Naim Android app to connect my Muso. However, the ONLY choice I see for network is my 2.4 GHz network. So I continue with the set up. It works.
  5. End point. The Muso-2 is connected wirelessly to my 2.4 GhZ network and it is working properly.

I’m interested to see how long it stays connected and if it works without a hitch for the next few days.

A question for @Stevesky. Why did my 5 GHz network show up in Muso home page in my browser but not in the Naim app? At this point I do not know how to connect the Muso to my 5 GHz network.

Hi Mike,
There is something definitely funny going on with that 5GHz channel.

  • When the products webpage is used to connect to the wifi router, the product does the wifi scan (hence it finds the 5GHz network) and then attempts to connect to it.

  • When the Naim app does the setup, it is typically the phone OS that enumerates the wifi access points out there. It indicates they’re all handling this tricky 5GHz feed differently.

It indicates that there are some security restrictions set on the 5GHz channel on the wifi router. Maybe:

  • Mac address filter
  • protocols allowed (Muso supports 802.11ac)

I would suggest get the access point to where other devices can connect on the 5GHz using 802.11ac, as that will prove that it is feasible to connect on that channel. .

If it helps we can take this one off-line, just email me on steve.harris(at)naimaudo.com

Best

Steve